summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-02-25 05:52:50 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-02-25 05:52:50 +0000
commit83a1f7f7615d40d8a3a984f5e3e26cfe1ddba1cc (patch)
tree967d650d06328057faa4623a658ad8876e73a035 /app-emulation
parentBump (diff)
downloadgentoo-2-83a1f7f7615d40d8a3a984f5e3e26cfe1ddba1cc.tar.gz
gentoo-2-83a1f7f7615d40d8a3a984f5e3e26cfe1ddba1cc.tar.bz2
gentoo-2-83a1f7f7615d40d8a3a984f5e3e26cfe1ddba1cc.zip
Fix up depends. Disable building of tools for the user emulation targets to remove some necessary depends. Fix automagical depend on GnuTLS when VNC WebSockets are enabled.
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/ChangeLog8
-rw-r--r--app-emulation/qemu/metadata.xml3
-rw-r--r--app-emulation/qemu/qemu-1.4.0.ebuild7
3 files changed, 14 insertions, 4 deletions
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index dfcf2413a4aa..7e33e4edbda5 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/qemu
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.189 2013/02/25 05:27:17 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.190 2013/02/25 05:52:50 cardoe Exp $
+
+ 25 Feb 2013; Doug Goldstein <cardoe@gentoo.org> qemu-1.4.0.ebuild,
+ metadata.xml:
+ Fix up depends. Disable building of tools for the user emulation targets to
+ remove some necessary depends. Fix automagical depend on GnuTLS when VNC
+ WebSockets are enabled.
25 Feb 2013; Doug Goldstein <cardoe@gentoo.org> +files/qemu-kvm-1.4,
qemu-1.4.0.ebuild:
diff --git a/app-emulation/qemu/metadata.xml b/app-emulation/qemu/metadata.xml
index b002a513c4c0..d5d5545c07c2 100644
--- a/app-emulation/qemu/metadata.xml
+++ b/app-emulation/qemu/metadata.xml
@@ -24,7 +24,8 @@
<flag name='static'>Enables both 'static-softmmu' and 'static-user'</flag>
<flag name='systemtap'>Enable SystemTAP/DTrace tracing</flag>
<flag name='tci'>Enable the TCG Interpreter which can speed up or slowdown workloads depending on the host and guest CPUs being emulated. In the future it will be a runtime option but for now its compile time.</flag>
- <flag name='tls'>Enable TLS support for the VNC console server</flag>
+ <flag name='tls'>Enable TLS support for the VNC console server.
+ For 1.4 and newer this also enables WebSocket support.</flag>
<flag name='jpeg'>Enable jpeg image support for the VNC console server</flag>
<flag name='png'>Enable png image support for the VNC console server</flag>
<flag name="usbredir">Use <pkg>sys-apps/usbredir</pkg> to redirect USB
diff --git a/app-emulation/qemu/qemu-1.4.0.ebuild b/app-emulation/qemu/qemu-1.4.0.ebuild
index e96aae232f83..813514e1e5ec 100644
--- a/app-emulation/qemu/qemu-1.4.0.ebuild
+++ b/app-emulation/qemu/qemu-1.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.4.0.ebuild,v 1.3 2013/02/25 05:27:17 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.4.0.ebuild,v 1.4 2013/02/25 05:52:50 cardoe Exp $
EAPI=5
@@ -101,7 +101,7 @@ RDEPEND="!static-softmmu? ( ${LIB_DEPEND//\[static-libs(+)]} )
sdl? ( media-libs/libsdl[X] )
selinux? ( sec-policy/selinux-qemu )
smartcard? ( dev-libs/nss )
- spice? ( >=app-emulation/spice-protocol-0.12.2 )
+ spice? ( >=app-emulation/spice-protocol-0.12.3 )
systemtap? ( dev-util/systemtap )
usbredir? ( >=sys-apps/usbredir-0.5.3 )
virtfs? ( sys-libs/libcap )
@@ -252,11 +252,13 @@ qemu_src_configure() {
conf_opts+=" --target-list=${user_targets}"
conf_opts+=" --disable-bluez"
conf_opts+=" --disable-sdl"
+ conf_opts+=" --disable-tools"
fi
if [[ ${buildtype} == "softmmu" ]]; then
conf_opts+=" --disable-linux-user"
conf_opts+=" --enable-system"
+ conf_opts+=" --with-system-pixman"
conf_opts+=" --target-list=${softmmu_targets}"
conf_opts+=" $(use_enable bluetooth bluez)"
conf_opts+=" $(use_enable sdl)"
@@ -277,6 +279,7 @@ qemu_src_configure() {
conf_opts+=" $(use_enable smartcard smartcard-nss)"
conf_opts+=" $(use_enable spice)"
conf_opts+=" $(use_enable tls vnc-tls)"
+ conf_opts+=" $(use_enable tls vnc-ws)"
conf_opts+=" $(use_enable usbredir usb-redir)"
conf_opts+=" $(use_enable uuid)"
conf_opts+=" $(use_enable vde)"