summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-10-13 21:10:18 +0000
committerDan Armak <danarmak@gentoo.org>2001-10-13 21:10:18 +0000
commit7bc9f759a9afc4bdf4bdcf477634b576d65e6543 (patch)
tree354d17ad14808889ec950b120a968617020403ea /app-emulation
parentnew incoming (diff)
downloadgentoo-2-7bc9f759a9afc4bdf4bdcf477634b576d65e6543.tar.gz
gentoo-2-7bc9f759a9afc4bdf4bdcf477634b576d65e6543.tar.bz2
gentoo-2-7bc9f759a9afc4bdf4bdcf477634b576d65e6543.zip
latest wine
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/files/digest-wine-200110041
-rw-r--r--app-emulation/wine/wine-20011004.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-emulation/wine/files/digest-wine-20011004 b/app-emulation/wine/files/digest-wine-20011004
new file mode 100644
index 000000000000..12bb21993439
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20011004
@@ -0,0 +1 @@
+MD5 3a23a634b7eff17a1631571f7be25421 Wine-20011004.tar.gz
diff --git a/app-emulation/wine/wine-20011004.ebuild b/app-emulation/wine/wine-20011004.ebuild
new file mode 100644
index 000000000000..0f28b022bcce
--- /dev/null
+++ b/app-emulation/wine/wine-20011004.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20011004.ebuild,v 1.1 2001/10/13 21:10:18 danarmak Exp $
+
+A="Wine-${PV}.tar.gz" #winesetuptk-${WSV}.tar.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="Wine is a free implementation of Windows on Unix."
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/${A}"
+ #http://twine.codeweavers.com/~mpilka/winesetuptk/winesetuptk-${WSV}.tar.gz"
+HOMEPAGE="http://www.winehq.com/"
+ #http://wine.codeweavers.com/winesetuptk.shtml"
+
+# need to add: db2html, db2ps, db2pdf for building the docs
+DEPEND="virtual/glibc
+ virtual/x11
+ sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ net-print/cups
+ >=media-libs/freetype-2.0.0"
+
+src_compile() {
+
+ cd ${S}
+ local myconf
+
+ if [ "`use opengl`" ]
+ then
+ myconf="--enable-opengl"
+ else
+ myconf="--disable-opengl"
+ fi
+
+ if [ -z $DEBUG ]
+ then
+ myconf="$myconf --disable-trace --disable-debug"
+ else
+ myconf="$myconf --enable-trace --enable-debug"
+ fi
+
+ ./configure --prefix=/opt/wine --sysconfdir=/etc/opt/wine \
+ --infodir=/opt/info --mandir=/opt/man \
+ --host=${CHOST} --enable-curses ${myconf} || die
+
+ make depend || die
+ make || die
+
+}
+
+src_install () {
+
+ make prefix=${D}/opt/wine install || die
+ insinto /etc/opt/wine
+ newins ${FILESDIR}/wine.conf config
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README WARRANTY
+
+ insinto /etc/env.d
+ newins ${FILESDIR}/wine.env 90wine
+
+}
+