summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2008-09-15 14:14:32 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2008-09-15 14:14:32 +0000
commit76af237901678fb205a43aca5078d9a8ab4fc6e3 (patch)
tree18940d00e31a7bf818a4d098441bc65e2ac88807 /app-emulation
parentBump to kvm-75 (diff)
downloadgentoo-2-76af237901678fb205a43aca5078d9a8ab4fc6e3.tar.gz
gentoo-2-76af237901678fb205a43aca5078d9a8ab4fc6e3.tar.bz2
gentoo-2-76af237901678fb205a43aca5078d9a8ab4fc6e3.zip
Nuke old versions
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/kvm/ChangeLog6
-rw-r--r--app-emulation/kvm/kvm-71-r2.ebuild190
-rw-r--r--app-emulation/kvm/kvm-72-r1.ebuild192
-rw-r--r--app-emulation/kvm/kvm-72.ebuild190
4 files changed, 5 insertions, 573 deletions
diff --git a/app-emulation/kvm/ChangeLog b/app-emulation/kvm/ChangeLog
index 713da01e3a5d..3c880dff0704 100644
--- a/app-emulation/kvm/ChangeLog
+++ b/app-emulation/kvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/kvm
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm/ChangeLog,v 1.16 2008/09/15 14:12:11 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm/ChangeLog,v 1.17 2008/09/15 14:14:32 dang Exp $
+
+ 15 Sep 2008; Daniel Gryniewicz <dang@gentoo.org> -kvm-71-r2.ebuild,
+ -kvm-72.ebuild, -kvm-72-r1.ebuild:
+ Nuke old versions
*kvm-75 (15 Sep 2008)
diff --git a/app-emulation/kvm/kvm-71-r2.ebuild b/app-emulation/kvm/kvm-71-r2.ebuild
deleted file mode 100644
index a1a6062b38e1..000000000000
--- a/app-emulation/kvm/kvm-71-r2.ebuild
+++ /dev/null
@@ -1,190 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm/kvm-71-r2.ebuild,v 1.2 2008/07/17 13:55:58 dang Exp $
-
-inherit eutils flag-o-matic toolchain-funcs linux-mod
-
-# Patchset git repo is at http://github.com/dang/kvm-patches/tree/master
-PATCHSET="kvm-patches-20080716"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- mirror://gentoo/${PATCHSET}.tar.gz"
-
-DESCRIPTION="Kernel-based Virtual Machine userland tools"
-HOMEPAGE="http://kvm.qumranet.com/kvmwiki"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-# Add bios back when it builds again
-IUSE="alsa esd gnutls havekernel ncurses pulseaudio sdl test"
-RESTRICT="test"
-
-RDEPEND="sys-libs/zlib
- alsa? ( >=media-libs/alsa-lib-1.0.13 )
- esd? ( media-sound/esound )
- pulseaudio? ( media-sound/pulseaudio )
- gnutls? ( net-libs/gnutls )
- ncurses? ( sys-libs/ncurses )
- sdl? ( >=media-libs/libsdl-1.2.11 )"
-
-# bios? (
-# sys-devel/dev86
-# dev-lang/perl
-# sys-power/iasl
-# )
-DEPEND="${RDEPEND}
- gnutls? ( dev-util/pkgconfig )
- app-text/texi2html"
-
-QA_TEXTRELS="usr/bin/kvm"
-
-pkg_setup() {
- # check kernel version
- if use havekernel ; then
- ewarn "You have the 'havekernel' use flag set. This means you"
- ewarn "must ensure you have a compatible kernel on your own."
- elif kernel_is lt 2 6 22; then
- eerror "the kvm in your kernel requires an older version of"
- eerror "kvm as shown in :"
- eerror " http://kvm.qumranet.com/kvmwiki/Downloads"
- die "kvm version not compatible"
- fi
-
- # check for kvm support
- if use havekernel ; then
- ewarn "You have the 'havekernel' use flag set. This means you"
- ewarn "must ensure your kernel has KVM support enable on your own"
- elif ! linux_chkconfig_present KVM; then
- eerror "Please enable KVM support in your kernel, found at:"
- eerror
- eerror " Virtualization"
- eerror " Kernel-based Virtual Machine (KVM) support"
- die "KVM support not detected!"
- fi
-
- enewgroup kvm
-}
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- # prevent docs to get automatically installed
- sed -i '/$(DESTDIR)$(docdir)/d' qemu/Makefile
- # Alter target makefiles to accept CFLAGS set via flag-o
- sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
- qemu/Makefile qemu/Makefile.target
- [[ -x /sbin/paxctl ]] && \
- sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
- qemu/Makefile.target
- # avoid strip
- sed -i 's/$(INSTALL) -m 755 -s/$(INSTALL) -m 755/' qemu/Makefile
-
- epatch \
- "${WORKDIR}/${PATCHSET}"/kvm-45-qemu-configure.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-61-qemu-kvm.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-57-qemu-kvm-cmdline.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-57-kernel-longmode.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-68-libkvm-no-kernel.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-69-qemu-no-blobs.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-69-qemu-ifup_ifdown.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-70-block-rw-range-check.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-71-qemu-kvm-doc.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-71-qemu-configure.patch
-}
-
-src_compile() {
- local mycc conf_opts audio_opts
-
- audio_opts="oss"
- use gnutls || conf_opts="$conf_opts --disable-vnc-tls"
- use ncurses || conf_opts="$conf_opts --disable-curses"
- use sdl || conf_opts="$conf_opts --disable-gfx-check --disable-sdl"
- use alsa && audio_opts="alsa $audio_opts"
- use esd && audio_opts="esd $audio_opts"
- use pulseaudio && audio_opts="pa $audio_opts"
- use sdl && audio_opts="sdl $audio_opts"
- conf_opts="$conf_opts --disable-gcc-check"
- conf_opts="$conf_opts --prefix=/usr"
- #conf_opts="$conf_opts --audio-drv-list=\"$audio_opts\""
-
- ./configure ${conf_opts} --audio-drv-list="$audio_opts" || die "econf failed"
-
- emake libkvm || die "emake libkvm failed"
-
- if use test; then
- emake user || die "emake user failed"
- fi
-
- mycc=$(cat qemu/config-host.mak | egrep "^CC=" | cut -d "=" -f 2)
-
- filter-flags -fpie -fstack-protector
-
- # If using gentoo's compiler set the SPEC to non-hardened
- if [ ! -z ${GCC_SPECS} -a -f ${GCC_SPECS} ]; then
- local myccver=$(${mycc} -dumpversion)
- local gccver=$($(tc-getBUILD_CC) -dumpversion)
-
- #Is this a SPEC for the right compiler version?
- myspec="${GCC_SPECS/${gccver}/${myccver}}"
- if [ "${myspec}" == "${GCC_SPECS}" ]; then
- shopt -s extglob
- GCC_SPECS="${GCC_SPECS/%hardened*specs/vanilla.specs}"
- shopt -u extglob
- else
- unset GCC_SPECS
- fi
- fi
-
-# if use bios; then
-# emake bios || die "emake bios failed"
-# emake vgabios || die "emake vgabios failed"
-# fi
-
- emake qemu || die "emake qemu failed"
-}
-
-src_install() {
- # kcmd so we don't install kernel modules which weren't build
- emake DESTDIR="${D}" kcmd='#' install || die "make install failed"
-
- exeinto /usr/bin/
- doexe "${S}/kvm_stat"
-
- mv "${D}"/usr/share/man/man1/qemu.1 "${D}"/usr/share/man/man1/kvm.1
- mv "${D}"/usr/share/man/man1/qemu-img.1 "${D}"/usr/share/man/man1/kvm-img.1
- mv "${D}"/usr/share/man/man8/qemu-nbd.8 "${D}"/usr/share/man/man8/kvm-nbd.8
- mv "${D}"/usr/bin/qemu-img "${D}"/usr/bin/kvm-img
- mv "${D}"/usr/bin/qemu-nbd "${D}"/usr/bin/kvm-nbd
-
- insinto /etc/udev/rules.d/
- doins scripts/65-kvm.rules
-
- insinto /etc/kvm/
- insopts -m0755
- newins scripts/qemu-ifup kvm-ifup
- newins scripts/qemu-ifdown kvm-ifdown
-
- dodoc qemu/pc-bios/README
- newdoc qemu/qemu-doc.html kvm-doc.html
- newdoc qemu/qemu-tech.html kvm-tech.html
-}
-
-pkg_postinst() {
- elog "If you don't have kvm compiled into the kernel, make sure you have"
- elog "the kernel module loaded before running kvm. The easiest way to"
- elog "ensure that the kernel module is loaded is to load it on boot."
- elog "For AMD CPUs the module is called 'kvm-amd'"
- elog "For Intel CPUs the module is called 'kvm-intel'"
- elog "Please review /etc/conf.d/modules for how to load these"
- elog
- elog "Make sure your user is in the 'kvm' group"
- elog "Just run 'gpasswd -a <USER> kvm', then have <USER> re-login."
- elog
- elog "You will need the Universal TUN/TAP driver compiled into your"
- elog "kernel or loaded as a module to use the virtual network device"
- elog "if using -net tap. You will also need support for 802.1d"
- elog "Ethernet Bridging and a configured bridge if using the provided"
- elog "kvm-ifup script from /etc/kvm."
- echo
-}
diff --git a/app-emulation/kvm/kvm-72-r1.ebuild b/app-emulation/kvm/kvm-72-r1.ebuild
deleted file mode 100644
index 231eb138017f..000000000000
--- a/app-emulation/kvm/kvm-72-r1.ebuild
+++ /dev/null
@@ -1,192 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm/kvm-72-r1.ebuild,v 1.1 2008/08/07 14:37:12 dang Exp $
-
-inherit eutils flag-o-matic toolchain-funcs linux-mod
-
-# Patchset git repo is at http://github.com/dang/kvm-patches/tree/master
-PATCHSET="kvm-patches-20080716"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- mirror://gentoo/${PATCHSET}.tar.gz"
-
-DESCRIPTION="Kernel-based Virtual Machine userland tools"
-HOMEPAGE="http://kvm.qumranet.com/kvmwiki"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-# Add bios back when it builds again
-IUSE="alsa esd gnutls havekernel ncurses pulseaudio sdl test vde"
-RESTRICT="test"
-
-RDEPEND="sys-libs/zlib
- alsa? ( >=media-libs/alsa-lib-1.0.13 )
- esd? ( media-sound/esound )
- pulseaudio? ( media-sound/pulseaudio )
- gnutls? ( net-libs/gnutls )
- ncurses? ( sys-libs/ncurses )
- sdl? ( >=media-libs/libsdl-1.2.11 )
- vde? ( net-misc/vde )"
-
-# bios? (
-# sys-devel/dev86
-# dev-lang/perl
-# sys-power/iasl
-# )
-DEPEND="${RDEPEND}
- gnutls? ( dev-util/pkgconfig )
- app-text/texi2html"
-
-QA_TEXTRELS="usr/bin/kvm"
-
-pkg_setup() {
- # check kernel version
- if use havekernel ; then
- ewarn "You have the 'havekernel' use flag set. This means you"
- ewarn "must ensure you have a compatible kernel on your own."
- elif kernel_is lt 2 6 22; then
- eerror "the kvm in your kernel requires an older version of"
- eerror "kvm as shown in :"
- eerror " http://kvm.qumranet.com/kvmwiki/Downloads"
- die "kvm version not compatible"
- fi
-
- # check for kvm support
- if use havekernel ; then
- ewarn "You have the 'havekernel' use flag set. This means you"
- ewarn "must ensure your kernel has KVM support enable on your own"
- elif ! linux_chkconfig_present KVM; then
- eerror "Please enable KVM support in your kernel, found at:"
- eerror
- eerror " Virtualization"
- eerror " Kernel-based Virtual Machine (KVM) support"
- die "KVM support not detected!"
- fi
-
- enewgroup kvm
-}
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- # prevent docs to get automatically installed
- sed -i '/$(DESTDIR)$(docdir)/d' qemu/Makefile
- # Alter target makefiles to accept CFLAGS set via flag-o
- sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
- qemu/Makefile qemu/Makefile.target
- [[ -x /sbin/paxctl ]] && \
- sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
- qemu/Makefile.target
- # avoid strip
- sed -i 's/$(INSTALL) -m 755 -s/$(INSTALL) -m 755/' qemu/Makefile
-
- epatch \
- "${WORKDIR}/${PATCHSET}"/kvm-45-qemu-configure.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-61-qemu-kvm.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-57-qemu-kvm-cmdline.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-57-kernel-longmode.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-68-libkvm-no-kernel.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-69-qemu-no-blobs.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-69-qemu-ifup_ifdown.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-70-block-rw-range-check.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-71-qemu-kvm-doc.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-71-qemu-configure.patch
-}
-
-src_compile() {
- local mycc conf_opts audio_opts
-
- audio_opts="oss"
- use gnutls || conf_opts="$conf_opts --disable-vnc-tls"
- use ncurses || conf_opts="$conf_opts --disable-curses"
- use sdl || conf_opts="$conf_opts --disable-gfx-check --disable-sdl"
- use vde && conf_opts="$conf_opts --enable-vde"
- use alsa && audio_opts="alsa $audio_opts"
- use esd && audio_opts="esd $audio_opts"
- use pulseaudio && audio_opts="pa $audio_opts"
- use sdl && audio_opts="sdl $audio_opts"
- conf_opts="$conf_opts --disable-gcc-check"
- conf_opts="$conf_opts --prefix=/usr"
- #conf_opts="$conf_opts --audio-drv-list=\"$audio_opts\""
-
- ./configure ${conf_opts} --audio-drv-list="$audio_opts" || die "econf failed"
-
- emake libkvm || die "emake libkvm failed"
-
- if use test; then
- emake user || die "emake user failed"
- fi
-
- mycc=$(cat qemu/config-host.mak | egrep "^CC=" | cut -d "=" -f 2)
-
- filter-flags -fpie -fstack-protector
-
- # If using gentoo's compiler set the SPEC to non-hardened
- if [ ! -z ${GCC_SPECS} -a -f ${GCC_SPECS} ]; then
- local myccver=$(${mycc} -dumpversion)
- local gccver=$($(tc-getBUILD_CC) -dumpversion)
-
- #Is this a SPEC for the right compiler version?
- myspec="${GCC_SPECS/${gccver}/${myccver}}"
- if [ "${myspec}" == "${GCC_SPECS}" ]; then
- shopt -s extglob
- GCC_SPECS="${GCC_SPECS/%hardened*specs/vanilla.specs}"
- shopt -u extglob
- else
- unset GCC_SPECS
- fi
- fi
-
-# if use bios; then
-# emake bios || die "emake bios failed"
-# emake vgabios || die "emake vgabios failed"
-# fi
-
- emake qemu || die "emake qemu failed"
-}
-
-src_install() {
- # kcmd so we don't install kernel modules which weren't build
- emake DESTDIR="${D}" kcmd='#' install || die "make install failed"
-
- exeinto /usr/bin/
- doexe "${S}/kvm_stat"
-
- mv "${D}"/usr/share/man/man1/qemu.1 "${D}"/usr/share/man/man1/kvm.1
- mv "${D}"/usr/share/man/man1/qemu-img.1 "${D}"/usr/share/man/man1/kvm-img.1
- mv "${D}"/usr/share/man/man8/qemu-nbd.8 "${D}"/usr/share/man/man8/kvm-nbd.8
- mv "${D}"/usr/bin/qemu-img "${D}"/usr/bin/kvm-img
- mv "${D}"/usr/bin/qemu-nbd "${D}"/usr/bin/kvm-nbd
-
- insinto /etc/udev/rules.d/
- doins scripts/65-kvm.rules
-
- insinto /etc/kvm/
- insopts -m0755
- newins scripts/qemu-ifup kvm-ifup
- newins scripts/qemu-ifdown kvm-ifdown
-
- dodoc qemu/pc-bios/README
- newdoc qemu/qemu-doc.html kvm-doc.html
- newdoc qemu/qemu-tech.html kvm-tech.html
-}
-
-pkg_postinst() {
- elog "If you don't have kvm compiled into the kernel, make sure you have"
- elog "the kernel module loaded before running kvm. The easiest way to"
- elog "ensure that the kernel module is loaded is to load it on boot."
- elog "For AMD CPUs the module is called 'kvm-amd'"
- elog "For Intel CPUs the module is called 'kvm-intel'"
- elog "Please review /etc/conf.d/modules for how to load these"
- elog
- elog "Make sure your user is in the 'kvm' group"
- elog "Just run 'gpasswd -a <USER> kvm', then have <USER> re-login."
- elog
- elog "You will need the Universal TUN/TAP driver compiled into your"
- elog "kernel or loaded as a module to use the virtual network device"
- elog "if using -net tap. You will also need support for 802.1d"
- elog "Ethernet Bridging and a configured bridge if using the provided"
- elog "kvm-ifup script from /etc/kvm."
- echo
-}
diff --git a/app-emulation/kvm/kvm-72.ebuild b/app-emulation/kvm/kvm-72.ebuild
deleted file mode 100644
index 43d13ad58f2d..000000000000
--- a/app-emulation/kvm/kvm-72.ebuild
+++ /dev/null
@@ -1,190 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kvm/kvm-72.ebuild,v 1.1 2008/08/04 21:08:00 dang Exp $
-
-inherit eutils flag-o-matic toolchain-funcs linux-mod
-
-# Patchset git repo is at http://github.com/dang/kvm-patches/tree/master
-PATCHSET="kvm-patches-20080716"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- mirror://gentoo/${PATCHSET}.tar.gz"
-
-DESCRIPTION="Kernel-based Virtual Machine userland tools"
-HOMEPAGE="http://kvm.qumranet.com/kvmwiki"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
-# Add bios back when it builds again
-IUSE="alsa esd gnutls havekernel ncurses pulseaudio sdl test"
-RESTRICT="test"
-
-RDEPEND="sys-libs/zlib
- alsa? ( >=media-libs/alsa-lib-1.0.13 )
- esd? ( media-sound/esound )
- pulseaudio? ( media-sound/pulseaudio )
- gnutls? ( net-libs/gnutls )
- ncurses? ( sys-libs/ncurses )
- sdl? ( >=media-libs/libsdl-1.2.11 )"
-
-# bios? (
-# sys-devel/dev86
-# dev-lang/perl
-# sys-power/iasl
-# )
-DEPEND="${RDEPEND}
- gnutls? ( dev-util/pkgconfig )
- app-text/texi2html"
-
-QA_TEXTRELS="usr/bin/kvm"
-
-pkg_setup() {
- # check kernel version
- if use havekernel ; then
- ewarn "You have the 'havekernel' use flag set. This means you"
- ewarn "must ensure you have a compatible kernel on your own."
- elif kernel_is lt 2 6 22; then
- eerror "the kvm in your kernel requires an older version of"
- eerror "kvm as shown in :"
- eerror " http://kvm.qumranet.com/kvmwiki/Downloads"
- die "kvm version not compatible"
- fi
-
- # check for kvm support
- if use havekernel ; then
- ewarn "You have the 'havekernel' use flag set. This means you"
- ewarn "must ensure your kernel has KVM support enable on your own"
- elif ! linux_chkconfig_present KVM; then
- eerror "Please enable KVM support in your kernel, found at:"
- eerror
- eerror " Virtualization"
- eerror " Kernel-based Virtual Machine (KVM) support"
- die "KVM support not detected!"
- fi
-
- enewgroup kvm
-}
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- # prevent docs to get automatically installed
- sed -i '/$(DESTDIR)$(docdir)/d' qemu/Makefile
- # Alter target makefiles to accept CFLAGS set via flag-o
- sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
- qemu/Makefile qemu/Makefile.target
- [[ -x /sbin/paxctl ]] && \
- sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
- qemu/Makefile.target
- # avoid strip
- sed -i 's/$(INSTALL) -m 755 -s/$(INSTALL) -m 755/' qemu/Makefile
-
- epatch \
- "${WORKDIR}/${PATCHSET}"/kvm-45-qemu-configure.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-61-qemu-kvm.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-57-qemu-kvm-cmdline.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-57-kernel-longmode.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-68-libkvm-no-kernel.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-69-qemu-no-blobs.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-69-qemu-ifup_ifdown.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-70-block-rw-range-check.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-71-qemu-kvm-doc.patch \
- "${WORKDIR}/${PATCHSET}"/kvm-71-qemu-configure.patch
-}
-
-src_compile() {
- local mycc conf_opts audio_opts
-
- audio_opts="oss"
- use gnutls || conf_opts="$conf_opts --disable-vnc-tls"
- use ncurses || conf_opts="$conf_opts --disable-curses"
- use sdl || conf_opts="$conf_opts --disable-gfx-check --disable-sdl"
- use alsa && audio_opts="alsa $audio_opts"
- use esd && audio_opts="esd $audio_opts"
- use pulseaudio && audio_opts="pa $audio_opts"
- use sdl && audio_opts="sdl $audio_opts"
- conf_opts="$conf_opts --disable-gcc-check"
- conf_opts="$conf_opts --prefix=/usr"
- #conf_opts="$conf_opts --audio-drv-list=\"$audio_opts\""
-
- ./configure ${conf_opts} --audio-drv-list="$audio_opts" || die "econf failed"
-
- emake libkvm || die "emake libkvm failed"
-
- if use test; then
- emake user || die "emake user failed"
- fi
-
- mycc=$(cat qemu/config-host.mak | egrep "^CC=" | cut -d "=" -f 2)
-
- filter-flags -fpie -fstack-protector
-
- # If using gentoo's compiler set the SPEC to non-hardened
- if [ ! -z ${GCC_SPECS} -a -f ${GCC_SPECS} ]; then
- local myccver=$(${mycc} -dumpversion)
- local gccver=$($(tc-getBUILD_CC) -dumpversion)
-
- #Is this a SPEC for the right compiler version?
- myspec="${GCC_SPECS/${gccver}/${myccver}}"
- if [ "${myspec}" == "${GCC_SPECS}" ]; then
- shopt -s extglob
- GCC_SPECS="${GCC_SPECS/%hardened*specs/vanilla.specs}"
- shopt -u extglob
- else
- unset GCC_SPECS
- fi
- fi
-
-# if use bios; then
-# emake bios || die "emake bios failed"
-# emake vgabios || die "emake vgabios failed"
-# fi
-
- emake qemu || die "emake qemu failed"
-}
-
-src_install() {
- # kcmd so we don't install kernel modules which weren't build
- emake DESTDIR="${D}" kcmd='#' install || die "make install failed"
-
- exeinto /usr/bin/
- doexe "${S}/kvm_stat"
-
- mv "${D}"/usr/share/man/man1/qemu.1 "${D}"/usr/share/man/man1/kvm.1
- mv "${D}"/usr/share/man/man1/qemu-img.1 "${D}"/usr/share/man/man1/kvm-img.1
- mv "${D}"/usr/share/man/man8/qemu-nbd.8 "${D}"/usr/share/man/man8/kvm-nbd.8
- mv "${D}"/usr/bin/qemu-img "${D}"/usr/bin/kvm-img
- mv "${D}"/usr/bin/qemu-nbd "${D}"/usr/bin/kvm-nbd
-
- insinto /etc/udev/rules.d/
- doins scripts/65-kvm.rules
-
- insinto /etc/kvm/
- insopts -m0755
- newins scripts/qemu-ifup kvm-ifup
- newins scripts/qemu-ifdown kvm-ifdown
-
- dodoc qemu/pc-bios/README
- newdoc qemu/qemu-doc.html kvm-doc.html
- newdoc qemu/qemu-tech.html kvm-tech.html
-}
-
-pkg_postinst() {
- elog "If you don't have kvm compiled into the kernel, make sure you have"
- elog "the kernel module loaded before running kvm. The easiest way to"
- elog "ensure that the kernel module is loaded is to load it on boot."
- elog "For AMD CPUs the module is called 'kvm-amd'"
- elog "For Intel CPUs the module is called 'kvm-intel'"
- elog "Please review /etc/conf.d/modules for how to load these"
- elog
- elog "Make sure your user is in the 'kvm' group"
- elog "Just run 'gpasswd -a <USER> kvm', then have <USER> re-login."
- elog
- elog "You will need the Universal TUN/TAP driver compiled into your"
- elog "kernel or loaded as a module to use the virtual network device"
- elog "if using -net tap. You will also need support for 802.1d"
- elog "Ethernet Bridging and a configured bridge if using the provided"
- elog "kvm-ifup script from /etc/kvm."
- echo
-}