summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2006-10-24 10:14:00 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2006-10-24 10:14:00 +0000
commit6f51df2630a8e32608c62f9613cd3fb7289f0f06 (patch)
treec92dc6b333a85503e92fc1bb57741b7d26d5ab38 /app-emulation
parentAdded ~sparc-fbsd keyword. (diff)
downloadgentoo-2-6f51df2630a8e32608c62f9613cd3fb7289f0f06.tar.gz
gentoo-2-6f51df2630a8e32608c62f9613cd3fb7289f0f06.tar.bz2
gentoo-2-6f51df2630a8e32608c62f9613cd3fb7289f0f06.zip
Fixed X USE dependencies.
(Portage version: 2.1.2_pre3-r4)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/gxemul/ChangeLog5
-rw-r--r--app-emulation/gxemul/gxemul-0.4.2.ebuild8
2 files changed, 8 insertions, 5 deletions
diff --git a/app-emulation/gxemul/ChangeLog b/app-emulation/gxemul/ChangeLog
index 2100f7ece4b8..5877da9c191d 100644
--- a/app-emulation/gxemul/ChangeLog
+++ b/app-emulation/gxemul/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/gxemul
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/ChangeLog,v 1.3 2006/10/20 20:05:11 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/ChangeLog,v 1.4 2006/10/24 10:14:00 drizzt Exp $
+
+ 24 Oct 2006; Timothy Redaelli <drizzt@gentoo.org> gxemul-0.4.2.ebuild:
+ Fixed X USE dependencies.
*gxemul-0.4.2 (20 Oct 2006)
diff --git a/app-emulation/gxemul/gxemul-0.4.2.ebuild b/app-emulation/gxemul/gxemul-0.4.2.ebuild
index 9cc45ac26c90..40af2302004c 100644
--- a/app-emulation/gxemul/gxemul-0.4.2.ebuild
+++ b/app-emulation/gxemul/gxemul-0.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/gxemul-0.4.2.ebuild,v 1.1 2006/10/20 20:05:11 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/gxemul-0.4.2.ebuild,v 1.2 2006/10/24 10:14:00 drizzt Exp $
inherit eutils
@@ -13,14 +13,14 @@ SLOT="0"
KEYWORDS="~amd64 ~mips ~sparc ~x86 ~ppc"
IUSE="X"
-RDEPEND="|| ( ( x11-libs/libX11
+RDEPEND="X? ( || ( ( x11-libs/libX11
x11-libs/libXaw
x11-libs/libXdmcp
)
- virtual/x11 )"
+ virtual/x11 ) )"
DEPEND="${RDEPEND}
- || ( x11-proto/xproto virtual/x11 )"
+ X? ( || ( x11-proto/xproto virtual/x11 ) )"
src_compile() {
local myconf=""