summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2004-03-21 23:07:32 +0000
committerLars Weiler <pylon@gentoo.org>2004-03-21 23:07:32 +0000
commit6b7496a871efdb0dba9922b8da76cf837a8d6c49 (patch)
treed874ccaef990d84cd9c90803014a155096b778b0 /app-emulation
parentMOL 0.9.70 has been finally released. Hooray\! (Manifest recommit) (diff)
downloadgentoo-2-6b7496a871efdb0dba9922b8da76cf837a8d6c49.tar.gz
gentoo-2-6b7496a871efdb0dba9922b8da76cf837a8d6c49.tar.bz2
gentoo-2-6b7496a871efdb0dba9922b8da76cf837a8d6c49.zip
tidy up
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/mol/files/digest-mol-0.9.69_pre71
-rw-r--r--app-emulation/mol/files/digest-mol-0.9.70_rc21
-rw-r--r--app-emulation/mol/mol-0.9.69_pre7.ebuild93
-rw-r--r--app-emulation/mol/mol-0.9.70_rc2.ebuild106
4 files changed, 0 insertions, 201 deletions
diff --git a/app-emulation/mol/files/digest-mol-0.9.69_pre7 b/app-emulation/mol/files/digest-mol-0.9.69_pre7
deleted file mode 100644
index dadc0200ab3d..000000000000
--- a/app-emulation/mol/files/digest-mol-0.9.69_pre7
+++ /dev/null
@@ -1 +0,0 @@
-MD5 44624610420c96f92f835788fcfe8154 mol-0.9.69_pre7.tar.bz2 2344729
diff --git a/app-emulation/mol/files/digest-mol-0.9.70_rc2 b/app-emulation/mol/files/digest-mol-0.9.70_rc2
deleted file mode 100644
index 88253e9d77d9..000000000000
--- a/app-emulation/mol/files/digest-mol-0.9.70_rc2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 214bb38bb3702c2483429fe9e5ca50ed mol-0.9.70-rc2.tgz 1717319
diff --git a/app-emulation/mol/mol-0.9.69_pre7.ebuild b/app-emulation/mol/mol-0.9.69_pre7.ebuild
deleted file mode 100644
index 9028689d08b2..000000000000
--- a/app-emulation/mol/mol-0.9.69_pre7.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.69_pre7.ebuild,v 1.2 2004/03/09 01:31:46 pylon Exp $
-
-inherit flag-o-matic
-
-S=${WORKDIR}/${P}
-DESCRIPTION="MOL (Mac-on-Linux) lets PPC users run MacOS (X) under Linux (rsync snapshot)"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-HOMEPAGE="http://www.maconlinux.net/"
-
-DEPEND=">=sys-apps/sed-4"
-RDEPEND="net-misc/dhcp
- net-firewall/iptables
- alsa? ( virtual/alsa )
- esd? ( media-sound/esound )
- X? ( virtual/x11 )"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~ppc -x86 -sparc -alpha -mips"
-IUSE="alsa esd debug oldworld X"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/26-arch-fix.patch || die
-}
-
-src_compile() {
-
- local myconf
- use alsa || myconf="${myconf} --disable-alsa"
- use debug || myconf="${myconf} --disable-debugger"
- use esd && myconf="${myconf} --enable-esd"
- use oldworld || myconf="${myconf} --disable-oldworld"
- use X && myconf="${myconf} --with-x"
-
- einfo "MOL will be build with the following options:"
- einfo "${myconf}"
-
- filter-flags -fsigned-char
-
- # dhcp config fix and show dchpd messages on starting mol
- cd ${S}
- sed -i "s:#ddns-update-style:ddns-update-style:g" Doc/config/dhcpd-mol.conf || die
- sed -i "s:DHCPD\ -q\ -cf:DHCPD\ -cf:g" Doc/config/tunconfig || die
- export KERNEL_SOURCE="/usr/src/linux"
- ./autogen.sh
- ./configure ${myconf} --prefix=/usr || die "This is a ppc-only package (time to buy that iBook, no?)"
-
- addwrite "/usr/src/${FK}"
-
- emake || die
-}
-
-src_install() {
-
- # MOL needs write access to some .depend-files in the kernel-dir
- # (at least arch/ppc/) to build the kernel-modules. With
- # sandboxing enabled this would result in an access violation.
-
- addwrite "/usr/src/${FK}"
- emake DESTDIR=${D} install || die "Failed to install MOL."
-
- dodoc 0README BUILDING COPYRIGHT CREDITS Doc/*
-
-}
-
-pkg_postinst() {
- echo
- einfo "Mac-on-Linux is now installed. To run, use the command startmol."
- einfo "You might want to configure video modes first with molvconfig."
- einfo "Other configuration is in /etc/molrc. For more info see:"
- einfo " http://www.maconlinux.net"
- einfo "Also try man molrc, man molvconfig, man startmol"
- echo
- ewarn "For networking and sound you might install the drivers in the"
- ewarn "folder \"MOL-Install\" on your Mac OS X-Desktop."
- echo
- ewarn "If errors with networking occur, make sure you have the following"
- ewarn "kernel functions enabled:"
- einfo "For the dhcp server:"
- einfo " Socket Filtering (CONFIG_FILTER)"
- einfo " Packet Socket (CONFIG_PACKET)"
- einfo "For NAT:"
- einfo " Network packet filtering (CONFIG_NETFILTER)"
- einfo " Connection tracking (CONFIG_IP_NF_CONNTRACK)"
- einfo " IP tables support (CONFIG_IP_NF_IPTABLES)"
- einfo " Packet filtering (CONFIG_IP_NF_FILTER)"
- einfo " Full NAT (CONFIG_IP_NF_NAT)"
- einfo " MASQUERADE target support (CONFIG_IP_NF_TARGET_MASQUERADE)"
- echo
-}
diff --git a/app-emulation/mol/mol-0.9.70_rc2.ebuild b/app-emulation/mol/mol-0.9.70_rc2.ebuild
deleted file mode 100644
index 80fe61107ff6..000000000000
--- a/app-emulation/mol/mol-0.9.70_rc2.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.70_rc2.ebuild,v 1.3 2004/03/09 01:31:46 pylon Exp $
-
-inherit flag-o-matic
-
-S=${WORKDIR}/${P/_rc2/}
-DESCRIPTION="MOL (Mac-on-Linux) lets PPC users run MacOS (X) under Linux (rsync snapshot)"
-SRC_URI="ftp://ftp.nada.kth.se/pub/home/f95-sry/Public/mac-on-linux/${P/_/-}.tgz"
-HOMEPAGE="http://www.maconlinux.net/"
-
-DEPEND=""
-RDEPEND="net-misc/dhcp
- net-firewall/iptables
- alsa? ( virtual/alsa )
- esd? ( media-sound/esound )
- X? ( virtual/x11 )"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~ppc -x86 -sparc -alpha -mips"
-IUSE="alsa oss debug fbcon X oldworld"
-
-pkg_setup() {
- echo
- einfo "If you want to use MOL fullscreen on a virtual console"
- einfo "be sure to have the USE-flag \"fbcon\" set!"
- echo
-}
-
-src_unpack() {
- unpack ${A}
-
- # dhcp config fix and show dchpd messages on starting mol
- cd ${S}
- sed -i "s:#ddns-update-style:ddns-update-style:g" Doc/config/dhcpd-mol.conf || die
- sed -i "s:DHCPD\ -q\ -cf:DHCPD\ -cf:g" Doc/config/tunconfig || die
-
- sed -i "s:prefix = /usr/local:prefix = /usr:" Makefile.top || die
- sed -i "s#VENDOR :=#VENDOR := -gentoo#" Makefile.top || die
-
-}
-
-src_compile() {
- filter-flags -fsigned-char
-
- export KERNEL_SOURCE="/usr/src/${FK}"
-
- # initialize all needed build-files
- ./autogen.sh
-
- emake defconfig || die "This is a ppc-only package (time to buy that iBook, no?)"
-
- sed -i "s:CONFIG_XDGA=y:# CONFIG_XDGA is not set:" .config
- sed -i "s:CONFIG_TAP=y:# CONFIG_TAP is not set:" .config
- use alsa || sed -i "s:CONFIG_ALSA=y:# CONFIG_ALSA is not set:" .config
- use debug && sed -i "s:# CONFIG_DEBUGGER is not set:CONFIG_DEBUGGER=y:" .config
- use oss || sed -i "s:CONFIG_OSS=y:# CONFIG_OSS is not set:" .config
- use oldworld || sed -i "s:CONFIG_OLDWORLD=y:# CONFIG_OLDWORLD is not set:" .config
- use oldworld || sed -i "s:CONFIG_SHEEP=y:# CONFIG_SHEEP is not set:" .config
- use X || sed -i "s:CONFIG_X11=y:# CONFIG_X11 is not set:" .config
- use fbcon || sed -i "s:CONFIG_FBDEV=y:# CONFIG_FBDEV is not set:" .config
-
- einfo "The configuration has been altered according to your USE-flags."
- # reinitialize our changed configuration
- emake oldconfig
-
- addwrite "/usr/src/${FK}"
- emake || die "mol can't build with FEATURES 'userpriv' and 'strict' set."
-}
-
-src_install() {
- # MOL needs write access to some .depend-files in the kernel-dir
- # (at least arch/ppc/) to build the kernel-modules. With
- # sandboxing enabled this would result in an access violation.
-
- addwrite "/usr/src/${FK}"
- emake DESTDIR=${D} install || die "Failed to install MOL."
-
- dodoc 0README BUILDING COPYRIGHT CREDITS Doc/*
-}
-
-pkg_postinst() {
- echo
- einfo "Mac-on-Linux is now installed. To run, use the command startmol."
- einfo "You might want to configure video modes first with molvconfig."
- einfo "Other configuration is in /etc/molrc. For more info see:"
- einfo " http://www.maconlinux.net"
- einfo "Also try man molrc, man molvconfig, man startmol"
- echo
- ewarn "For networking and sound you might install the drivers in the"
- ewarn "folder \"MOL-Install\" on your Mac OS X-Desktop."
- echo
- ewarn "If errors with networking occur, make sure you have the following"
- ewarn "kernel functions enabled:"
- einfo "For the dhcp server:"
- einfo " Socket Filtering (CONFIG_FILTER)"
- einfo " Packet Socket (CONFIG_PACKET)"
- einfo "For NAT:"
- einfo " Network packet filtering (CONFIG_NETFILTER)"
- einfo " Connection tracking (CONFIG_IP_NF_CONNTRACK)"
- einfo " IP tables support (CONFIG_IP_NF_IPTABLES)"
- einfo " Packet filtering (CONFIG_IP_NF_FILTER)"
- einfo " Full NAT (CONFIG_IP_NF_NAT)"
- einfo " MASQUERADE target support (CONFIG_IP_NF_TARGET_MASQUERADE)"
- echo
-}