summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-03-29 16:29:47 +0000
committerDan Armak <danarmak@gentoo.org>2002-03-29 16:29:47 +0000
commit6a6de3377346279a1878c4db4497904b9dd12d70 (patch)
tree6d957e28db20e776c66219b509579985356e4e7f /app-emulation
parentflip side of yesterday's kde3-cvs/autoconf trouble: add an autoconf-2.1 and a... (diff)
downloadgentoo-2-6a6de3377346279a1878c4db4497904b9dd12d70.tar.gz
gentoo-2-6a6de3377346279a1878c4db4497904b9dd12d70.tar.bz2
gentoo-2-6a6de3377346279a1878c4db4497904b9dd12d70.zip
new revision: fix bug #1373 - disable custom CXXFLAGS optimizations
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog7
-rw-r--r--app-emulation/wine/files/digest-wine-20020310-r11
-rw-r--r--app-emulation/wine/wine-20020310-r1.ebuild93
3 files changed, 100 insertions, 1 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index a07a231c1bdf..bc1938130ab0 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for app-emulation/wine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.5 2002/03/28 01:41:12 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.6 2002/03/29 16:29:47 danarmak Exp $
+*wine-20020310-r1 (29 Mar 2002)
+
+ 29 Mar 2002; Dan Armak <danarmak@gentoo.org>: fix bug #1373: disable custom optimizations,
+ or the resulting wine won't work properly and will make the hardworking folks at #winehq
+ really really angry
*wine-20020310 (27 Mar 2002)
diff --git a/app-emulation/wine/files/digest-wine-20020310-r1 b/app-emulation/wine/files/digest-wine-20020310-r1
new file mode 100644
index 000000000000..defd038feebd
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20020310-r1
@@ -0,0 +1 @@
+MD5 a3c4cac20b4336d99671594707a5fff1 Wine-20020310.tar.gz 7076073
diff --git a/app-emulation/wine/wine-20020310-r1.ebuild b/app-emulation/wine/wine-20020310-r1.ebuild
new file mode 100644
index 000000000000..2703bd3faea6
--- /dev/null
+++ b/app-emulation/wine/wine-20020310-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20020310-r1.ebuild,v 1.1 2002/03/29 16:29:47 danarmak Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Wine is a free implementation of Windows on Unix."
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-${PV}.tar.gz"
+HOMEPAGE="http://www.winehq.com/"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ dev-lang/tcl dev-lang/tk"
+
+src_compile() {
+
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ # there's no configure flag for cups, it's supposed to be autodetected
+
+ # the folks at #winehq were really angry about custom optimization
+ export CFLAGS=""
+ export CXXFLAGS=""
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/wine \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
+
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ cd ${S}
+ make depend all manpages || die
+ cd programs && emake || die
+
+}
+
+src_install () {
+
+ cd ${S}
+ make prefix=${D}/usr mandir=${D}/usr/share/man install || die
+ cd ${S}/programs
+ make prefix=${D}/usr mandir=${D}/usr/share/man install || die
+
+ # these .so's are strange. they are from the make in programs/ above,
+ # and are for apps built with winelib (windows sources built directly
+ # against wine). Apparently the sources go into a <program name>.so file
+ # and you run it via a symlink <program name> -> wine. Unfortunately both
+ # the symlink and the .so apparently must reside in /usr/bin.
+ cd ${D}/usr/bin
+ chmod a-x *.so
+
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ cd ${S}/documentation
+ doman man3w/*
+ doman *.man
+ dohtml *.sgml
+
+ insinto /etc/wine
+ doins samples/*
+ doins ${S}/winedefault.reg
+
+ dodir /etc/skel/.wine
+ dosym /etc/wine/config /etc/skel/.wine/config
+
+}
+
+pkg_postinst() {
+
+ einfo "If you are installing wine for the first time,
+copy /etc/wine/config (global configuration) to ~/.wine/config
+and edit that for per-user configuration. Otherwise, wine will
+not run.
+Also, run \"regapi setValue < /etc/wine/winedefault.reg\" to setup
+per-user registry for using wine. More info in /usr/share/doc/wine-${PV}."
+
+}