summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2012-02-08 15:57:30 +0000
committerTiziano Müller <dev-zero@gentoo.org>2012-02-08 15:57:30 +0000
commit69cf7d45bf0b8d6b035e762f034c1e91a9754417 (patch)
tree285c22a4b36ecdc178fcc31d5753928d7869aee3 /app-emulation
parentInitial commit (ebuild written by me), optional requirement for spice. (diff)
downloadgentoo-2-69cf7d45bf0b8d6b035e762f034c1e91a9754417.tar.gz
gentoo-2-69cf7d45bf0b8d6b035e762f034c1e91a9754417.tar.bz2
gentoo-2-69cf7d45bf0b8d6b035e762f034c1e91a9754417.zip
Version bump. Added patch to disable -Werror (bug #390615, thanks to Alphat-PC). Added flag to enable smartcard support based on app-emulation/libcacard.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/spice/ChangeLog11
-rw-r--r--app-emulation/spice/files/0.10.1-disable-werror.patch16
-rw-r--r--app-emulation/spice/metadata.xml1
-rw-r--r--app-emulation/spice/spice-0.10.1.ebuild62
4 files changed, 88 insertions, 2 deletions
diff --git a/app-emulation/spice/ChangeLog b/app-emulation/spice/ChangeLog
index 0481af828331..8e799242428b 100644
--- a/app-emulation/spice/ChangeLog
+++ b/app-emulation/spice/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/spice
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.19 2011/11/14 14:02:14 dev-zero Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.20 2012/02/08 15:57:30 dev-zero Exp $
+
+*spice-0.10.1 (08 Feb 2012)
+
+ 08 Feb 2012; Tiziano Müller <dev-zero@gentoo.org>
+ +files/0.10.1-disable-werror.patch, +spice-0.10.1.ebuild, metadata.xml:
+ Version bump. Added patch to disable -Werror (bug #390615, thanks to Alphat-
+ PC). Added flag to enable smartcard support based on app-emulation/libcacard.
14 Nov 2011; Tiziano Müller <dev-zero@gentoo.org> spice-0.10.0.ebuild:
Updated dep to require spice-protocol >=0.10.0 (unfortunately spice and spice-
diff --git a/app-emulation/spice/files/0.10.1-disable-werror.patch b/app-emulation/spice/files/0.10.1-disable-werror.patch
new file mode 100644
index 000000000000..da42b38f7479
--- /dev/null
+++ b/app-emulation/spice/files/0.10.1-disable-werror.patch
@@ -0,0 +1,16 @@
+ configure.ac | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 861e939..8fab1a1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -405,7 +405,7 @@ dnl MAYBE_WARN="-Wall -Wno-sign-compare -Werror -Wno-deprecated-declarations"
+ if test "$red_target" = "windows"; then
+ MAYBE_WARN="-Wall -Wno-sign-compare -Wno-deprecated-declarations"
+ else
+- MAYBE_WARN="-Wall -Wno-sign-compare -Werror -Wno-deprecated-declarations"
++ MAYBE_WARN="-Wall -Wno-sign-compare -Wno-deprecated-declarations"
+ fi
+
+ AC_ARG_ENABLE(werror,
diff --git a/app-emulation/spice/metadata.xml b/app-emulation/spice/metadata.xml
index 05fa93d12a4a..3d1186820856 100644
--- a/app-emulation/spice/metadata.xml
+++ b/app-emulation/spice/metadata.xml
@@ -8,5 +8,6 @@
<use>
<flag name="client">Build the spicec client app (does not reduce dependencies at the moment).</flag>
<flag name="gui">Build some GUI components (inside the guest window).</flag>
+ <flag name="smartcard">Enable smartcard remoting using <pkg>app-emulation/libcacard</pkg></flag>
</use>
</pkgmetadata>
diff --git a/app-emulation/spice/spice-0.10.1.ebuild b/app-emulation/spice/spice-0.10.1.ebuild
new file mode 100644
index 000000000000..39fca5e41458
--- /dev/null
+++ b/app-emulation/spice/spice-0.10.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.10.1.ebuild,v 1.1 2012/02/08 15:57:30 dev-zero Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="SPICE server and client."
+HOMEPAGE="http://spice-space.org/"
+SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+client +gui sasl smartcard static static-libs"
+
+RDEPEND=">=app-emulation/spice-protocol-0.10.1
+ >=x11-libs/pixman-0.17.7
+ media-libs/alsa-lib
+ media-libs/celt:0.5.1
+ dev-libs/openssl
+ >=x11-libs/libXrandr-1.2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXinerama
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ virtual/jpeg
+ sys-libs/zlib
+ client? ( gui? ( =dev-games/cegui-0.6* ) )
+ sasl? ( dev-libs/cyrus-sasl )
+ smartcard? ( >=app-emulation/libcacard-0.1.2 )"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+# maintainer notes:
+# * opengl support is currently broken
+# * TODO: add slirp for tunnel-support
+
+src_prepare() {
+ epatch "${FILESDIR}/0.10.1-disable-werror.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local gui="$(use_enable gui)"
+ use client || gui="--disable-gui"
+ econf \
+ $(use_enable static-libs static) \
+ --disable-tunnel \
+ ${gui} \
+ $(use_enable client) \
+ $(use_enable static static-linkage) \
+ $(use_with sasl) \
+ $(use_enable smartcard)
+}
+
+src_install() {
+ default
+ use static-libs || rm "${D}"/usr/lib*/*.la
+}