summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-02 05:06:04 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-02 05:06:04 +0000
commit5b5725ea784811a26edd3fd24500eb18a927d420 (patch)
treecbba4960c13c4f1d38c097fb9d5d592a4d4a06fe /app-emulation
parentmodernised (diff)
downloadgentoo-2-5b5725ea784811a26edd3fd24500eb18a927d420.tar.gz
gentoo-2-5b5725ea784811a26edd3fd24500eb18a927d420.tar.bz2
gentoo-2-5b5725ea784811a26edd3fd24500eb18a927d420.zip
modernised
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/bochs/bochs-1.4.1.ebuild8
-rw-r--r--app-emulation/bochs/bochs-1.4.ebuild6
-rw-r--r--app-emulation/mol/mol-0.9.63.ebuild10
-rw-r--r--app-emulation/mol/mol-0.9.64.ebuild10
-rw-r--r--app-emulation/xmame/xmame-0.60.1-r2.ebuild6
-rw-r--r--app-emulation/xtrs/xtrs-4.9.ebuild22
-rw-r--r--app-emulation/zsnes/zsnes-1.337-r2.ebuild30
7 files changed, 46 insertions, 46 deletions
diff --git a/app-emulation/bochs/bochs-1.4.1.ebuild b/app-emulation/bochs/bochs-1.4.1.ebuild
index cb636e177086..a71bdc4bb679 100644
--- a/app-emulation/bochs/bochs-1.4.1.ebuild
+++ b/app-emulation/bochs/bochs-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-1.4.1.ebuild,v 1.1 2002/07/22 21:41:22 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-1.4.1.ebuild,v 1.2 2002/08/02 05:06:04 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Bochs is a pc emulator.
@@ -13,14 +13,14 @@ LICENSE="LGPL-2.1"
SLOT="0"
DEPEND=">=sys-libs/glibc-2.1.3
- >=x11-base/xfree-4.0.1"
+ >=x11-base/xfree-4.0.1"
RDEPEND="${DEPEND}"
KEYWORDS="x86 ppc"
src_unpack() {
unpack ${P}.tar.gz
-
+
cd $S
cp Makefile.in Makefile.in.orig
sed -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
@@ -28,7 +28,7 @@ src_unpack() {
-e 's: $(bindir): $(DESTDIR)$(bindir):g' \
-e 's:BOCHSDIR=:BOCHSDIR=/usr/lib/bochs#:' \
-e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in.orig > Makefile.in
-
+
}
src_compile() {
diff --git a/app-emulation/bochs/bochs-1.4.ebuild b/app-emulation/bochs/bochs-1.4.ebuild
index cb6a87084b24..ff311f3a0dbb 100644
--- a/app-emulation/bochs/bochs-1.4.ebuild
+++ b/app-emulation/bochs/bochs-1.4.ebuild
@@ -15,21 +15,21 @@ SLOT="0"
#build-time dependencies
DEPEND=">=sys-libs/glibc-2.1.3
- >=x11-base/xfree-4.0.1"
+ >=x11-base/xfree-4.0.1"
RDEPEND="${DEPEND}"
KEYWORDS="x86 ppc"
src_unpack() {
unpack ${PN}.tar.gz
-
+
cd $S
cp Makefile.in Makefile.in.orig
sed -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
-e 's: $(prefix): $(DESTDIR)$(prefix):g' \
-e 's: $(bindir): $(DESTDIR)$(bindir):g' \
-e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in.orig > Makefile.in
-
+
}
src_compile() {
diff --git a/app-emulation/mol/mol-0.9.63.ebuild b/app-emulation/mol/mol-0.9.63.ebuild
index 26e3c9229a50..d5ef2d049f86 100644
--- a/app-emulation/mol/mol-0.9.63.ebuild
+++ b/app-emulation/mol/mol-0.9.63.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.63.ebuild,v 1.7 2002/07/21 01:01:13 sunflare Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.63.ebuild,v 1.8 2002/08/02 05:06:04 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="MOL (Mac-on-Linux) is a PPC-only program to run Mac OS <=9.2 natively within Linux"
@@ -14,10 +14,10 @@ LICENSE="GPL"
KEYWORDS="ppc -x86 -sparc -sparc64"
pkg_setup() {
- if [ ${ARCH} != "ppc" ] ; then
- eerror "Sorry, this is a PPC only package."
- die "Sorry, this as a PPC only pacakge."
- fi
+ if [ ${ARCH} != "ppc" ] ; then
+ eerror "Sorry, this is a PPC only package."
+ die "Sorry, this as a PPC only pacakge."
+ fi
}
src_compile() {
diff --git a/app-emulation/mol/mol-0.9.64.ebuild b/app-emulation/mol/mol-0.9.64.ebuild
index 158728cd773f..7bbd341ce1b8 100644
--- a/app-emulation/mol/mol-0.9.64.ebuild
+++ b/app-emulation/mol/mol-0.9.64.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.64.ebuild,v 1.2 2002/07/21 01:01:13 sunflare Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.64.ebuild,v 1.3 2002/08/02 05:06:04 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="MOL (Mac-on-Linux) is a PPC-only program to run Mac OS <=9.2 natively within Linux"
@@ -14,10 +14,10 @@ LICENSE="GPL"
KEYWORDS="ppc -x86 -sparc -sparc64"
pkg_setup() {
- if [ ${ARCH} != "ppc" ] ; then
- eerror "Sorry, this is a PPC only package."
- die "Sorry, this as a PPC only pacakge."
- fi
+ if [ ${ARCH} != "ppc" ] ; then
+ eerror "Sorry, this is a PPC only package."
+ die "Sorry, this as a PPC only pacakge."
+ fi
}
src_compile() {
diff --git a/app-emulation/xmame/xmame-0.60.1-r2.ebuild b/app-emulation/xmame/xmame-0.60.1-r2.ebuild
index 93526c2de3f7..0cc09ecbbe33 100644
--- a/app-emulation/xmame/xmame-0.60.1-r2.ebuild
+++ b/app-emulation/xmame/xmame-0.60.1-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Based on the 0.59.1 ebuild by Ben Lutgens <blutgens@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xmame/xmame-0.60.1-r2.ebuild,v 1.4 2002/07/24 03:10:38 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xmame/xmame-0.60.1-r2.ebuild,v 1.5 2002/08/02 05:06:04 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Multiple Arcade Machine Emulator for X11"
@@ -42,7 +42,7 @@ src_unpack() {
then
sed -e "s:MY_CPU = i386:\#MY_CPU = i386:g" -e \
"s:\# MY_CPU = risc$:MY_CPU = risc:" makefile.unix > makefile.unix.tmp
- mv makefile.unix.tmp makefile.unix
+ mv makefile.unix.tmp makefile.unix
fi
if [ "`use dga`" ]; then
@@ -65,7 +65,7 @@ src_unpack() {
}
src_compile() {
- local MYFLAGS
+ local MYFLAGS
MYFLAGS=""
if [ ${ARCH} = "ppc" ] ; then
diff --git a/app-emulation/xtrs/xtrs-4.9.ebuild b/app-emulation/xtrs/xtrs-4.9.ebuild
index fe7b296b7e63..fb94aa973baf 100644
--- a/app-emulation/xtrs/xtrs-4.9.ebuild
+++ b/app-emulation/xtrs/xtrs-4.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xtrs/xtrs-4.9.ebuild,v 1.4 2002/07/27 15:47:42 stubear Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xtrs/xtrs-4.9.ebuild,v 1.5 2002/08/02 05:06:04 seemant Exp $
DESCRIPTION="XTRS 4.9.0 - RadioShack TRS80 Emulator, inc. FreeWare ROM & LDOS Image"
HOMEPAGE="http://www.tim-mann.org/trs80.html"
@@ -18,9 +18,9 @@ S=${WORKDIR}/xtrs-4.9
src_unpack () {
- ### make doesn't play nicely with the usual ${PREFIX} behaviour, but relies
- ### on an external Makefile.local to set compiletime options, and default
- ### behavious. we'll patch it here, to make our install sane.
+ ### make doesn't play nicely with the usual ${PREFIX} behaviour, but relies
+ ### on an external Makefile.local to set compiletime options, and default
+ ### behavious. we'll patch it here, to make our install sane.
unpack ${A}
cd ${WORKDIR}
@@ -29,27 +29,27 @@ src_unpack () {
src_compile() {
- ### As we mentioned, make ignores any/all prefixes so it's just a standard
- ### make here, the install prefixes were taken care of by our patch above
+ ### As we mentioned, make ignores any/all prefixes so it's just a standard
+ ### make here, the install prefixes were taken care of by our patch above
emake || die "XTRS Make Failed"
}
src_install () {
- ### make install, isn't really a 'make install' but a set of 'cp x y' commands
- ### which fails miserablly if the directories dont exist, we'll create them
- ### first to keep everthing smiley happy
+ ### make install, isn't really a 'make install' but a set of 'cp x y' commands
+ ### which fails miserablly if the directories dont exist, we'll create them
+ ### first to keep everthing smiley happy
mkdir -p ${D}/usr/bin
mkdir -p ${D}/usr/share/xtrs
mkdir -p ${D}/usr/share/man/man1
- ### and now run the make install script
+ ### and now run the make install script
make install || die "XTRS Make Install Failed"
- ### and finally, move the OSS rom images & extract an lsdos image
+ ### and finally, move the OSS rom images & extract an lsdos image
cp *.hex ${D}/usr/share/xtrs
cp *.dsk ${D}/usr/share/xtrs/disks
diff --git a/app-emulation/zsnes/zsnes-1.337-r2.ebuild b/app-emulation/zsnes/zsnes-1.337-r2.ebuild
index d6ffb5e26598..74cbc7c4f559 100644
--- a/app-emulation/zsnes/zsnes-1.337-r2.ebuild
+++ b/app-emulation/zsnes/zsnes-1.337-r2.ebuild
@@ -12,27 +12,27 @@ SLOT="0"
KEYWORDS="x86 -sparc -sparc64 -ppc"
RDEPEND="opengl? ( virtual/opengl )
- virtual/x11
- >=media-libs/libsdl-1.2.0
- sys-libs/zlib
- media-libs/libpng"
+ virtual/x11
+ >=media-libs/libsdl-1.2.0
+ sys-libs/zlib
+ media-libs/libpng"
DEPEND="${RDEPEND}
>=dev-lang/nasm-0.98"
src_compile() {
- patch -p1 < ${FILESDIR}/${P}-gentoo.patch
- cd ${S}/src
- use opengl || myconf="--without-opengl"
- ./configure --prefix=/usr --host=${CHOST} $myconf || die
- make || die
+ patch -p1 < ${FILESDIR}/${P}-gentoo.patch
+ cd ${S}/src
+ use opengl || myconf="--without-opengl"
+ ./configure --prefix=/usr --host=${CHOST} $myconf || die
+ make || die
}
src_install () {
- cd ${S}/src
- into /usr
- dobin zsnes
- doman linux/zsnes.man
- cd ${S}
- dodoc *.txt linux/*
+ cd ${S}/src
+ into /usr
+ dobin zsnes
+ doman linux/zsnes.man
+ cd ${S}
+ dodoc *.txt linux/*
}