summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-01-25 17:38:35 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-01-25 17:38:35 +0000
commit56588eb5769b8d139a39d2d553a468d7916b8c31 (patch)
tree67aab4adf4bc3bb66a47a9d174365e7c85b3b172 /app-emulation
parentStable on alpha, bug #255979 (diff)
downloadgentoo-2-56588eb5769b8d139a39d2d553a468d7916b8c31.tar.gz
gentoo-2-56588eb5769b8d139a39d2d553a468d7916b8c31.tar.bz2
gentoo-2-56588eb5769b8d139a39d2d553a468d7916b8c31.zip
actually add the patch
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libspectrum/ChangeLog7
-rw-r--r--app-emulation/libspectrum/files/libspectrum-0.5.0.1-without-bzip2_zlib.patch52
-rw-r--r--app-emulation/libspectrum/libspectrum-0.5.0.1.ebuild5
3 files changed, 61 insertions, 3 deletions
diff --git a/app-emulation/libspectrum/ChangeLog b/app-emulation/libspectrum/ChangeLog
index f52c0258fd48..f927a32e7ab8 100644
--- a/app-emulation/libspectrum/ChangeLog
+++ b/app-emulation/libspectrum/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/libspectrum
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libspectrum/ChangeLog,v 1.25 2009/01/25 02:40:51 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libspectrum/ChangeLog,v 1.26 2009/01/25 17:38:35 darkside Exp $
+
+ 25 Jan 2009; Jeremy Olexa <darkside@gentoo.org>
+ +files/libspectrum-0.5.0.1-without-bzip2_zlib.patch,
+ libspectrum-0.5.0.1.ebuild:
+ actually add the patch
25 Jan 2009; Jeremy Olexa <darkside@gentoo.org>
+files/libspectrum-0.5.0.1-without-bzip2_zlib.patch:
diff --git a/app-emulation/libspectrum/files/libspectrum-0.5.0.1-without-bzip2_zlib.patch b/app-emulation/libspectrum/files/libspectrum-0.5.0.1-without-bzip2_zlib.patch
new file mode 100644
index 000000000000..3eac75b9b842
--- /dev/null
+++ b/app-emulation/libspectrum/files/libspectrum-0.5.0.1-without-bzip2_zlib.patch
@@ -0,0 +1,52 @@
+--- libspectrum-0.5.0.1/configure.in 2009-01-14 20:50:55.000000000 +0100
++++ configure.in 2009-01-24 16:10:53.000000000 +0100
+@@ -65,11 +65,19 @@
+ CPPFLAGS="$CPPFLAGS -I$prefix/include"; LDFLAGS="$LDFLAGS -L$prefix/lib"
+ fi)
+
+-dnl Check for zlib (the UNIX version is called z, Win32 zdll)
+-AC_CHECK_HEADERS(
+- zlib.h,
+- AC_SEARCH_LIBS(compress2, z zdll)
+-)
++dnl Check whether to use zlib (the UNIX version is called z, Win32 zdll)
++AC_MSG_CHECKING(whether to use zlib)
++AC_ARG_WITH(zlib,
++[ --without-zlib don't use zlib],
++if test "$withval" = no; then zlib=no; else zlib=yes; fi,
++zlib=yes)
++AC_MSG_RESULT($zlib)
++if test "$zlib" = yes; then
++ AC_CHECK_HEADERS(
++ zlib.h,
++ AC_SEARCH_LIBS(compress2, z zdll)
++ )
++fi
+
+ dnl Check whether to use libgcrypt
+ AC_MSG_CHECKING(whether to use libgcrypt)
+@@ -82,11 +90,19 @@
+ AC_CHECK_HEADERS(gcrypt.h,LIBS="$LIBS -lgcrypt")
+ fi
+
+-dnl Check for libbz2 1.0 or greater
+-AC_CHECK_HEADER(
+- bzlib.h,
+- AC_CHECK_LIB(bz2,BZ2_bzDecompressInit)
+-)
++dnl Check whether to use libbz2 (1.0 or greater)
++AC_MSG_CHECKING(whether to use libbz2)
++AC_ARG_WITH(bzip2,
++[ --without-bzip2 don't use libbz2],
++if test "$withval" = no; then bzip2=no; else bzip2=yes; fi,
++bzip2=yes)
++AC_MSG_RESULT($bzip2)
++if test "$bzip2" = yes; then
++ AC_CHECK_HEADER(
++ bzlib.h,
++ AC_CHECK_LIB(bz2,BZ2_bzDecompressInit)
++ )
++fi
+
+ dnl Either find glib or use the replacement
+ AC_MSG_CHECKING(whether to use glib)
diff --git a/app-emulation/libspectrum/libspectrum-0.5.0.1.ebuild b/app-emulation/libspectrum/libspectrum-0.5.0.1.ebuild
index 6d5ceada60e0..d32040ccfece 100644
--- a/app-emulation/libspectrum/libspectrum-0.5.0.1.ebuild
+++ b/app-emulation/libspectrum/libspectrum-0.5.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libspectrum/libspectrum-0.5.0.1.ebuild,v 1.1 2009/01/25 02:35:58 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libspectrum/libspectrum-0.5.0.1.ebuild,v 1.2 2009/01/25 17:38:35 darkside Exp $
inherit eutils autotools
@@ -24,7 +24,8 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
- #submitted upstream, see bug #0000000000000000000000000000000000000000000000
+ #submitted upstream at:
+ # http://sf.net/tracker/index.php?func=detail&aid=2533274&group_id=91293&atid=596650
epatch "${FILESDIR}/${P}-without-bzip2_zlib.patch"
eautoreconf
}