summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2011-09-19 10:04:46 +0000
committerTiziano Müller <dev-zero@gentoo.org>2011-09-19 10:04:46 +0000
commit4e1bc4670b3837d9dc13e37977cf45a3ccd28b01 (patch)
tree533bf7a220b02050bf2074434874279a7440e131 /app-emulation
parentRevbump to bump icedtea-web to 1.1.2 and provide libpng-1.5 ABI variant, sele... (diff)
downloadgentoo-2-4e1bc4670b3837d9dc13e37977cf45a3ccd28b01.tar.gz
gentoo-2-4e1bc4670b3837d9dc13e37977cf45a3ccd28b01.tar.bz2
gentoo-2-4e1bc4670b3837d9dc13e37977cf45a3ccd28b01.zip
Added patch from upstream git to fix pkg-config file (bug #378907).
(Portage version: 2.1.10.15/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/spice/ChangeLog9
-rw-r--r--app-emulation/spice/files/54c660470a5aea19f799c5574cc0d4a707696712.patch36
-rw-r--r--app-emulation/spice/spice-0.8.2-r1.ebuild56
3 files changed, 100 insertions, 1 deletions
diff --git a/app-emulation/spice/ChangeLog b/app-emulation/spice/ChangeLog
index cc52a34b148f..4aaadc01f8bc 100644
--- a/app-emulation/spice/ChangeLog
+++ b/app-emulation/spice/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/spice
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.16 2011/09/04 10:18:18 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.17 2011/09/19 10:04:46 dev-zero Exp $
+
+*spice-0.8.2-r1 (19 Sep 2011)
+
+ 19 Sep 2011; Tiziano Müller <dev-zero@gentoo.org>
+ +files/54c660470a5aea19f799c5574cc0d4a707696712.patch,
+ +spice-0.8.2-r1.ebuild:
+ Added patch from upstream git to fix pkg-config file (bug #378907).
04 Sep 2011; Markus Meier <maekke@gentoo.org> spice-0.8.1.ebuild:
x86 stable, bug #369601
diff --git a/app-emulation/spice/files/54c660470a5aea19f799c5574cc0d4a707696712.patch b/app-emulation/spice/files/54c660470a5aea19f799c5574cc0d4a707696712.patch
new file mode 100644
index 000000000000..11191b91ef1c
--- /dev/null
+++ b/app-emulation/spice/files/54c660470a5aea19f799c5574cc0d4a707696712.patch
@@ -0,0 +1,36 @@
+From 54c660470a5aea19f799c5574cc0d4a707696712 Mon Sep 17 00:00:00 2001
+From: Hans de Goede <hdegoede@redhat.com>
+Date: Fri, 21 Jan 2011 14:16:11 +0000
+Subject: Drop unnecessary X11 and alsa requires from spice-server.pc
+
+---
+diff --git a/configure.ac b/configure.ac
+index 5828a70..3a86515 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -219,7 +219,6 @@ if test "$os_linux" = yes; then
+ PKG_CHECK_MODULES(ALSA, alsa)
+ AC_SUBST(ALSA_CFLAGS)
+ AC_SUBST(ALSA_LIBS)
+- SPICE_REQUIRES+=" alsa"
+ fi
+
+ PKG_CHECK_MODULES(SSL, openssl)
+@@ -253,7 +252,6 @@ if test "$red_target" = "x11"; then
+ PKG_CHECK_MODULES(XFIXES, xfixes)
+ AC_SUBST(XRANDR_CFLAGS)
+ AC_SUBST(XRANDR_LIBS)
+- SPICE_REQUIRES+=" xrandr xfixes"
+
+ PKG_CHECK_MODULES(XRANDR12,
+ xrandr >= 1.2,
+@@ -272,7 +270,6 @@ if test "$red_target" = "x11"; then
+ PKG_CHECK_MODULES(MISC_X, x11 xext xrender)
+ AC_SUBST(MISC_X_CFLAGS)
+ AC_SUBST(MISC_X_LIBS)
+- SPICE_REQUIRES+=" x11 xext xrender"
+ fi
+
+ # Add parameter for (partial) static linkage of spice client.
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/app-emulation/spice/spice-0.8.2-r1.ebuild b/app-emulation/spice/spice-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..8ac453b43ac7
--- /dev/null
+++ b/app-emulation/spice/spice-0.8.2-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.8.2-r1.ebuild,v 1.1 2011/09/19 10:04:46 dev-zero Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="SPICE server and client."
+HOMEPAGE="http://spice-space.org/"
+SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gui sasl static-libs"
+
+RDEPEND=">=app-emulation/spice-protocol-0.8.1
+ >=x11-libs/pixman-0.17.7
+ media-libs/alsa-lib
+ media-libs/celt:0.5.1
+ dev-libs/openssl
+ >=x11-libs/libXrandr-1.2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXfixes
+ virtual/jpeg
+ sys-libs/zlib
+ gui? ( =dev-games/cegui-0.6* )
+ sasl? ( dev-libs/cyrus-sasl )"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+# maintainer notes:
+# * opengl support is currently broken
+# * add slirp for tunnel-support
+# * add libcacard for smartcard support
+
+src_prepare() {
+ epatch "${FILESDIR}/54c660470a5aea19f799c5574cc0d4a707696712.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=""
+ use gui && myconf+="--enable-gui "
+ econf ${myconf} \
+ $(use_enable static-libs static) \
+ $(use_with sasl)
+}
+
+src_install() {
+ default
+ use static-libs || rm "${D}"/usr/lib*/*.la
+}