summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-01-19 19:22:52 +0000
committerMike Gilbert <floppym@gentoo.org>2014-01-19 19:22:52 +0000
commit475fe568915a693264515ab7f0a2ffc585df9694 (patch)
treef29db8cacc346370cd9fa61aca80ccfbc4fb95ed /app-emulation
parentAdding cachefilesd SELinux policy to the tree (diff)
downloadgentoo-2-475fe568915a693264515ab7f0a2ffc585df9694.tar.gz
gentoo-2-475fe568915a693264515ab7f0a2ffc585df9694.tar.bz2
gentoo-2-475fe568915a693264515ab7f0a2ffc585df9694.zip
Make modules and PAM optional, bug 484360.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/open-vm-tools/ChangeLog10
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-2013.09.16.1328054-r2.ebuild123
2 files changed, 131 insertions, 2 deletions
diff --git a/app-emulation/open-vm-tools/ChangeLog b/app-emulation/open-vm-tools/ChangeLog
index 1db3add46afe..ee5a4e216ab5 100644
--- a/app-emulation/open-vm-tools/ChangeLog
+++ b/app-emulation/open-vm-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/open-vm-tools
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.79 2013/10/31 20:08:41 floppym Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.80 2014/01/19 19:22:52 floppym Exp $
+
+*open-vm-tools-2013.09.16.1328054-r2 (19 Jan 2014)
+
+ 19 Jan 2014; Mike Gilbert <floppym@gentoo.org>
+ +open-vm-tools-2013.09.16.1328054-r2.ebuild:
+ Make modules and PAM optional, bug 484360.
*open-vm-tools-2013.09.16.1328054-r1 (31 Oct 2013)
diff --git a/app-emulation/open-vm-tools/open-vm-tools-2013.09.16.1328054-r2.ebuild b/app-emulation/open-vm-tools/open-vm-tools-2013.09.16.1328054-r2.ebuild
new file mode 100644
index 000000000000..e7098d4dfc2f
--- /dev/null
+++ b/app-emulation/open-vm-tools/open-vm-tools-2013.09.16.1328054-r2.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-2013.09.16.1328054-r2.ebuild,v 1.1 2014/01/19 19:22:52 floppym Exp $
+
+EAPI=5
+
+inherit eutils multilib pam user versionator flag-o-matic systemd toolchain-funcs
+
+MY_PV="$(replace_version_separator 3 '-')"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Opensourced tools for VMware guests"
+HOMEPAGE="http://open-vm-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X doc fuse icu modules pam +pic xinerama"
+
+COMMON_DEPEND="
+ dev-libs/glib:2
+ dev-libs/libdnet
+ sys-apps/ethtool
+ sys-process/procps
+ pam? ( virtual/pam )
+ X? (
+ dev-cpp/gtkmm:2.4
+ x11-base/xorg-server
+ x11-drivers/xf86-input-vmmouse
+ x11-drivers/xf86-video-vmware
+ x11-libs/gtk+:2
+ x11-libs/libnotify
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+ fuse? ( sys-fs/fuse )
+ icu? ( dev-libs/icu:= )
+ xinerama? ( x11-libs/libXinerama )
+"
+
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig
+ virtual/linux-sources
+ sys-apps/findutils
+"
+
+RDEPEND="${COMMON_DEPEND}
+ modules? ( app-emulation/open-vm-tools-kmod )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup vmware
+}
+
+src_prepare() {
+ # Do not filter out Werror
+ # Upstream Bug http://sourceforge.net/tracker/?func=detail&aid=2959749&group_id=204462&atid=989708
+ # sed -i -e 's/CFLAGS=.*Werror/#&/g' configure || die "sed comment out Werror failed"
+ sed -i -e 's:\(TEST_PLUGIN_INSTALLDIR=\).*:\1\$libdir/open-vm-tools/plugins/tests:g' configure || die "sed test_plugin_installdir failed"
+}
+
+src_configure() {
+ # http://bugs.gentoo.org/402279
+ if has_version '>=sys-process/procps-3.3.2'; then
+ export CUSTOM_PROCPS_NAME=procps
+ export CUSTOM_PROCPS_LIBS="$($(tc-getPKG_CONFIG) --libs libprocps)"
+ fi
+
+ local myeconfargs=(
+ --with-procps
+ --with-dnet
+ --without-kernel-modules
+ $(use_enable doc docs)
+ --docdir=/usr/share/doc/${PF}
+ $(use_with X x)
+ $(use_with X gtk2)
+ $(use_with X gtkmm)
+ $(use_with icu)
+ $(use_with pam)
+ $(use_with pic)
+ $(use_enable xinerama multimon)
+ )
+
+ econf "${myeconfargs[@]}"
+
+ # Bugs 260878, 326761
+ find ./ -name Makefile | xargs sed -i -e 's/-Werror//g' || die "sed out Werror failed"
+}
+
+src_install() {
+ default
+
+ rm "${D}"/etc/pam.d/vmtoolsd
+ pamd_mimic_system vmtoolsd auth account
+
+ rm "${D}"/usr/$(get_libdir)/*.la
+ rm "${D}"/usr/$(get_libdir)/open-vm-tools/plugins/common/*.la
+
+ newinitd "${FILESDIR}/open-vm-tools.initd" vmware-tools
+ newconfd "${FILESDIR}/open-vm-tools.confd" vmware-tools
+ systemd_dounit "${FILESDIR}"/vmtoolsd.service
+
+ exeinto /etc/vmware-tools/scripts/vmware/
+ doexe "${FILESDIR}"/network
+
+ if use X;
+ then
+ fperms 4755 "/usr/bin/vmware-user-suid-wrapper"
+
+ dobin "${S}"/scripts/common/vmware-xdg-detect-de
+
+ insinto /etc/xdg/autostart
+ doins "${FILESDIR}/open-vm-tools.desktop"
+
+ elog "To be able to use the drag'n'drop feature of VMware for file"
+ elog "exchange, please add the users to the 'vmware' group."
+ fi
+ elog "Add 'vmware-tools' service to the default runlevel."
+}