summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-11-03 14:40:38 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-11-03 14:40:38 +0000
commit4706ffc1f71c3ab46119a45d056ef02a8428a20e (patch)
tree509752d485b3ef997515528991c6e5817d7f0474 /app-emulation
parentenable only chipcard by default, skip ofx to match kmymoneys default (diff)
downloadgentoo-2-4706ffc1f71c3ab46119a45d056ef02a8428a20e.tar.gz
gentoo-2-4706ffc1f71c3ab46119a45d056ef02a8428a20e.tar.bz2
gentoo-2-4706ffc1f71c3ab46119a45d056ef02a8428a20e.zip
Fixed the non installation of binaries due to a bad variable declaration - bug 343951.
Updated dtc dep to fix the build failures on amd64 - bug 339044. Restricted parallel build until we fix it - bug 343175. Dropped old ebuilds and files. (Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu-kvm/ChangeLog17
-rw-r--r--app-emulation/qemu-kvm/files/qemu-kvm-0.12.2-virtio-large-iovecs.patch31
-rw-r--r--app-emulation/qemu-kvm/files/qemu-kvm-0.12.4-large-virtio-corruption.patch43
-rw-r--r--app-emulation/qemu-kvm/metadata.xml1
-rw-r--r--app-emulation/qemu-kvm/qemu-kvm-0.11.1-r1.ebuild189
-rw-r--r--app-emulation/qemu-kvm/qemu-kvm-0.12.3-r1.ebuild237
-rw-r--r--app-emulation/qemu-kvm/qemu-kvm-0.12.4-r1.ebuild237
-rw-r--r--app-emulation/qemu-kvm/qemu-kvm-0.13.0-r2.ebuild (renamed from app-emulation/qemu-kvm/qemu-kvm-0.13.0.ebuild)104
8 files changed, 72 insertions, 787 deletions
diff --git a/app-emulation/qemu-kvm/ChangeLog b/app-emulation/qemu-kvm/ChangeLog
index 1c465b2ba17f..03bedcbf325e 100644
--- a/app-emulation/qemu-kvm/ChangeLog
+++ b/app-emulation/qemu-kvm/ChangeLog
@@ -1,6 +1,21 @@
# ChangeLog for app-emulation/qemu-kvm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/ChangeLog,v 1.45 2010/11/02 16:29:19 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/ChangeLog,v 1.46 2010/11/03 14:40:38 jmbsvicetto Exp $
+
+*qemu-kvm-0.13.0-r2 (03 Nov 2010)
+
+ 03 Nov 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ -qemu-kvm-0.11.1-r1.ebuild,
+ -files/qemu-kvm-0.12.2-virtio-large-iovecs.patch,
+ -qemu-kvm-0.12.3-r1.ebuild, -qemu-kvm-0.12.4-r1.ebuild,
+ -files/qemu-kvm-0.12.4-large-virtio-corruption.patch,
+ -qemu-kvm-0.13.0.ebuild, qemu-kvm-0.13.0-r1.ebuild,
+ +qemu-kvm-0.13.0-r2.ebuild, metadata.xml:
+ Fixed the non installation of binaries due to a bad variable declaration -
+ bug 343951.
+ Updated dtc dep to fix the build failures on amd64 - bug 339044.
+ Restricted parallel build until we fix it - bug 343175.
+ Dropped old ebuilds and files.
*qemu-kvm-0.13.0-r1 (02 Nov 2010)
diff --git a/app-emulation/qemu-kvm/files/qemu-kvm-0.12.2-virtio-large-iovecs.patch b/app-emulation/qemu-kvm/files/qemu-kvm-0.12.2-virtio-large-iovecs.patch
deleted file mode 100644
index cb7b8b57bcc4..000000000000
--- a/app-emulation/qemu-kvm/files/qemu-kvm-0.12.2-virtio-large-iovecs.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Index: qemu/block.c
-===================================================================
---- qemu.orig/block.c 2010-01-26 10:59:39.757004445 +0100
-+++ qemu/block.c 2010-01-26 11:01:38.056023231 +0100
-@@ -1689,6 +1689,10 @@ static int multiwrite_merge(BlockDriverS
- merge = bs->drv->bdrv_merge_requests(bs, &reqs[outidx], &reqs[i]);
- }
-
-+ if (reqs[outidx].qiov->niov + reqs[i].qiov->niov + 1 > IOV_MAX) {
-+ merge = 0;
-+ }
-+
- if (merge) {
- size_t size;
- QEMUIOVector *qiov = qemu_mallocz(sizeof(*qiov));
-Index: qemu/qemu-common.h
-===================================================================
---- qemu.orig/qemu-common.h 2010-01-26 14:41:40.894254285 +0100
-+++ qemu/qemu-common.h 2010-01-26 14:42:27.267275698 +0100
-@@ -54,6 +54,10 @@ struct iovec {
- void *iov_base;
- size_t iov_len;
- };
-+/*
-+ * Use the same value as Linux for now.
-+ */
-+#define IOV_MAX 1024
- #else
- #include <sys/uio.h>
- #endif
-
diff --git a/app-emulation/qemu-kvm/files/qemu-kvm-0.12.4-large-virtio-corruption.patch b/app-emulation/qemu-kvm/files/qemu-kvm-0.12.4-large-virtio-corruption.patch
deleted file mode 100644
index 81a44cbf341e..000000000000
--- a/app-emulation/qemu-kvm/files/qemu-kvm-0.12.4-large-virtio-corruption.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From: Christoph Hellwig <hch@lst.de>
-
-The difference between the start sectors of two requests can be larger
-than the size of the "int" type, which can lead to a not correctly
-sorted multiwrite array and thus spurious I/O errors and filesystem
-corruption due to incorrect request merges.
-
-So instead of doing the cute sector arithmetics trick spell out the
-exact comparisms.
-
-Spotted by Kevin Wolf based on a testcase from Michael Tokarev.
-
-Signed-off-by: Christoph Hellwig <hch@lst.de>
-Signed-off-by: Kevin Wolf <kwolf@redhat.com>
----
- block.c | 14 +++++++++++++-
- 1 files changed, 13 insertions(+), 1 deletions(-)
-
-diff --git a/block.c b/block.c
-index bfe46e3..89eece7 100644
---- a/block.c
-+++ b/block.c
-@@ -1929,7 +1929,19 @@ static void multiwrite_cb(void *opaque, int ret)
-
- static int multiwrite_req_compare(const void *a, const void *b)
- {
-- return (((BlockRequest*) a)->sector - ((BlockRequest*) b)->sector);
-+ const BlockRequest *req1 = a, *req2 = b;
-+
-+ /*
-+ * Note that we can't simply subtract req2->sector from req1->sector
-+ * here as that could overflow the return value.
-+ */
-+ if (req1->sector > req2->sector) {
-+ return 1;
-+ } else if (req1->sector < req2->sector) {
-+ return -1;
-+ } else {
-+ return 0;
-+ }
- }
-
- /*
diff --git a/app-emulation/qemu-kvm/metadata.xml b/app-emulation/qemu-kvm/metadata.xml
index 01e94421a2da..958396a7435e 100644
--- a/app-emulation/qemu-kvm/metadata.xml
+++ b/app-emulation/qemu-kvm/metadata.xml
@@ -8,7 +8,6 @@
<flag name='brltty'>Adds support for braille displays using brltty</flag>
<flag name='esd'>Enable esound output for sound emulation</flag>
<flag name='fdt'>Enables firmware device tree support</flag>
- <flag name='gnutls'>Enable TLS support for the VNC console server</flag>
<flag name='jpeg'>Enable JPEG compression for the VNC console server</flag>
<flag name='kvm-trace'>Allows you to use KVM tracing</flag>
<flag name='ncurses'>Enable the ncurses-based console</flag>
diff --git a/app-emulation/qemu-kvm/qemu-kvm-0.11.1-r1.ebuild b/app-emulation/qemu-kvm/qemu-kvm-0.11.1-r1.ebuild
deleted file mode 100644
index edee63055a94..000000000000
--- a/app-emulation/qemu-kvm/qemu-kvm-0.11.1-r1.ebuild
+++ /dev/null
@@ -1,189 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/qemu-kvm-0.11.1-r1.ebuild,v 1.4 2010/08/12 08:49:51 dev-zero Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic toolchain-funcs linux-info
-
-SRC_URI="mirror://sourceforge/kvm/${P}.tar.gz"
-
-DESCRIPTION="QEMU + Kernel-based Virtual Machine userland tools"
-HOMEPAGE="http://www.linux-kvm.org"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="alsa bluetooth esd gnutls ncurses pulseaudio sasl +sdl vde"
-
-COMMON_TARGETS="i386 x86_64 arm cris m68k mips mipsel mips64 mips64el ppc \
-ppc64 sh4 sh4eb sparc"
-
-IUSE_SOFTMMU_TARGETS="${COMMON_TARGETS} ppcemb"
-IUSE_USER_TARGETS="${COMMON_TARGETS} alpha armeb ppc64abi32 sparc64 sparc32plus"
-
-for target in ${IUSE_SOFTMMU_TARGETS}; do
- IUSE="${IUSE} +qemu_softmmu_targets_${target}"
-done
-
-for target in ${IUSE_USER_TARGETS}; do
- IUSE="${IUSE} +qemu_user_targets_${target}"
-done
-
-RESTRICT="test"
-
-RDEPEND="sys-libs/zlib
- net-misc/bridge-utils
- sys-apps/iproute2
- sys-apps/pciutils
- alsa? ( >=media-libs/alsa-lib-1.0.13 )
- bluetooth? ( net-wireless/bluez )
- esd? ( media-sound/esound )
- gnutls? ( net-libs/gnutls )
- ncurses? ( sys-libs/ncurses )
- pulseaudio? ( media-sound/pulseaudio )
- sasl? ( dev-libs/cyrus-sasl )
- sdl? ( >=media-libs/libsdl-1.2.11[X] )
- vde? ( net-misc/vde )
- !app-emulation/qemu-softmmu
- !app-emulation/qemu-user
- !app-emulation/qemu
- !app-emulation/kqemu
- !app-emulation/qemu-kvm-spice"
-
-DEPEND="${RDEPEND}
- app-text/texi2html
- >=sys-kernel/linux-headers-2.6.29
- gnutls? ( dev-util/pkgconfig )"
-
-pkg_setup() {
- if kernel_is lt 2 6 25; then
- eerror "This version of KVM requres a host kernel of 2.6.25 or higher."
- eerror "Either upgrade your kernel"
- die "qemu-kvm version not compatible"
- elif ! linux_chkconfig_present KVM; then
- eerror "Please enable KVM support in your kernel, found at:"
- eerror
- eerror " Virtualization"
- eerror " Kernel-based Virtual Machine (KVM) support"
- eerror
- eerror "or enable the 'modules' USE flag."
- die "KVM support not detected!"
- fi
-
- enewgroup kvm
-}
-
-src_prepare() {
- # avoid fdt till an updated release appears
- sed -i -e 's:fdt="yes":fdt="no":' configure
- # prevent docs to get automatically installed
- sed -i '/$(DESTDIR)$(docdir)/d' Makefile
- # Alter target makefiles to accept CFLAGS set via flag-o
- sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
- Makefile Makefile.target
- [[ -x /sbin/paxctl ]] && \
- sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
- Makefile.target
- # append CFLAGS while linking
- sed -i 's/$(LDFLAGS)/$(QEMU_CFLAGS) $(CFLAGS) $(LDFLAGS)/' rules.mak
-
- # remove part to make udev happy
- sed -e 's~NAME="%k", ~~' -i kvm/scripts/65-kvm.rules
-
- epatch "${FILESDIR}/qemu-0.11.0-mips64-user-fix.patch"
-}
-
-src_configure() {
- local conf_opts audio_opts softmmu_targets user_targets
-
- #works fine for me without, drop with next version, if there are
- #no complains
- #Thomas Sachau <tommy@gentoo.org
- #filter-flags -fpie -fstack-protector
-
- for target in ${IUSE_SOFTMMU_TARGETS} ; do
- use "qemu_softmmu_targets_${target}" && \
- softmmu_targets="${softmmu_targets} ${target}-softmmu"
- done
-
- for target in ${IUSE_USER_TARGETS} ; do
- use "qemu_user_targets_${target}" && \
- user_targets="${user_targets} ${target}-linux-user"
- done
-
- if [ ! -z "${softmmu_targets}" ]; then
- einfo "Building the following softmmu targets: ${softmmu_targets}"
- fi
-
- if [ ! -z "${user_targets}" ]; then
- einfo "Building the following user targets: ${user_targets}"
- conf_opts="${conf_opts} --enable-linux-user"
- else
- conf_opts="${conf_opts} --disable-linux-user"
- fi
-
- #config options
- use gnutls || conf_opts="$conf_opts --disable-vnc-tls"
- use ncurses || conf_opts="$conf_opts --disable-curses"
- use sdl || conf_opts="$conf_opts --disable-sdl"
- use vde || conf_opts="$conf_opts --disable-vde"
- use bluetooth || conf_opts="$conf_opts --disable-bluez"
- use sasl || conf_opts="$conf_opts --disable-vnc-sasl"
- conf_opts="--disable-darwin-user --disable-bsd-user"
-
- # audio options
- audio_opts="oss"
- use alsa && audio_opts="alsa $audio_opts"
- use esd && audio_opts="esd $audio_opts"
- use pulseaudio && audio_opts="pa $audio_opts"
- use sdl && audio_opts="sdl $audio_opts"
-
- ./configure --prefix=/usr \
- --disable-strip \
- --disable-xen \
- ${conf_opts} \
- --audio-drv-list="$audio_opts" \
- --target-list="${softmmu_targets} ${user_targets}" \
- --cc="$(tc-getCC)" \
- --host-cc="$(tc-getCC)" \
- || die "configure failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-
- insinto /etc/udev/rules.d/
- doins kvm/scripts/65-kvm.rules
-
- insinto /etc/qemu/
- insopts -m0755
- doins kvm/scripts/qemu-ifup
- doins kvm/scripts/qemu-ifdown
-
- dodoc Changelog MAINTAINERS TODO pci-ids.txt || die
- newdoc pc-bios/README README.pc-bios || die
- dohtml qemu-doc.html qemu-tech.html
-
- dobin "${FILESDIR}"/qemu-kvm
- dosym /usr/bin/qemu-kvm /usr/bin/kvm
-}
-
-pkg_postinst() {
- elog "If you don't have kvm compiled into the kernel, make sure you have"
- elog "the kernel module loaded before running kvm. The easiest way to"
- elog "ensure that the kernel module is loaded is to load it on boot."
- elog "For AMD CPUs the module is called 'kvm-amd'"
- elog "For Intel CPUs the module is called 'kvm-intel'"
- elog "Please review /etc/conf.d/modules for how to load these"
- elog
- elog "Make sure your user is in the 'kvm' group"
- elog "Just run 'gpasswd -a <USER> kvm', then have <USER> re-login."
- elog
- elog "You will need the Universal TUN/TAP driver compiled into your"
- elog "kernel or loaded as a module to use the virtual network device"
- elog "if using -net tap. You will also need support for 802.1d"
- elog "Ethernet Bridging and a configured bridge if using the provided"
- elog "kvm-ifup script from /etc/kvm."
- echo
-}
diff --git a/app-emulation/qemu-kvm/qemu-kvm-0.12.3-r1.ebuild b/app-emulation/qemu-kvm/qemu-kvm-0.12.3-r1.ebuild
deleted file mode 100644
index 80d5f7827a82..000000000000
--- a/app-emulation/qemu-kvm/qemu-kvm-0.12.3-r1.ebuild
+++ /dev/null
@@ -1,237 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/qemu-kvm-0.12.3-r1.ebuild,v 1.3 2010/08/12 08:49:51 dev-zero Exp $
-
-EAPI="2"
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="git://git.kernel.org/pub/scm/virt/kvm/qemu-kvm.git"
- GIT_ECLASS="git"
-fi
-
-inherit eutils flag-o-matic ${GIT_ECLASS} linux-info toolchain-funcs
-
-if [[ ${PV} = *9999* ]]; then
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="mirror://sourceforge/kvm/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-fi
-
-DESCRIPTION="QEMU + Kernel-based Virtual Machine userland tools"
-HOMEPAGE="http://www.linux-kvm.org"
-
-LICENSE="GPL-2"
-SLOT="0"
-# xen is disabled until the deps are fixed
-IUSE="+aio alsa bluetooth curl esd gnutls fdt hardened kvm-trace ncurses \
-pulseaudio qemu-ifup sasl sdl static vde"
-
-COMMON_TARGETS="i386 x86_64 arm cris m68k microblaze mips mipsel ppc ppc64 sh4 sh4eb sparc sparc64"
-IUSE_SOFTMMU_TARGETS="${COMMON_TARGETS} mips64 mips64el ppcemb"
-IUSE_USER_TARGETS="${COMMON_TARGETS} alpha armeb ppc64abi32 sparc32plus"
-
-for target in ${IUSE_SOFTMMU_TARGETS}; do
- IUSE="${IUSE} +qemu_softmmu_targets_${target}"
-done
-
-for target in ${IUSE_USER_TARGETS}; do
- IUSE="${IUSE} +qemu_user_targets_${target}"
-done
-
-RESTRICT="test"
-
-RDEPEND="
- !app-emulation/kqemu
- !app-emulation/qemu
- !app-emulation/qemu-softmmu
- !app-emulation/qemu-user
- !app-emulation/qemu-kvm-spice
- sys-apps/pciutils
- >=sys-apps/util-linux-2.16.0
- sys-libs/zlib
- aio? ( dev-libs/libaio )
- alsa? ( >=media-libs/alsa-lib-1.0.13 )
- bluetooth? ( net-wireless/bluez )
- curl? ( net-misc/curl )
- esd? ( media-sound/esound )
- fdt? ( sys-apps/dtc )
- gnutls? ( net-libs/gnutls )
- ncurses? ( sys-libs/ncurses )
- pulseaudio? ( media-sound/pulseaudio )
- qemu-ifup? ( sys-apps/iproute2 net-misc/bridge-utils )
- sasl? ( dev-libs/cyrus-sasl )
- sdl? ( >=media-libs/libsdl-1.2.11[X] )
- vde? ( net-misc/vde )
-"
-
-DEPEND="${RDEPEND}
- app-text/texi2html
- >=sys-kernel/linux-headers-2.6.29
- gnutls? ( dev-util/pkgconfig )"
-
-kvm_kern_warn() {
- eerror "Please enable KVM support in your kernel, found at:"
- eerror
- eerror " Virtualization"
- eerror " Kernel-based Virtual Machine (KVM) support"
- eerror
-}
-
-pkg_setup() {
-
- local counter="0" check
- use qemu_softmmu_targets_x86_64 || ewarn "You disabled default target QEMU_SOFTMMU_TARGETS=x86_64"
- for check in ${IUSE_SOFTMMU_TARGETS} ; do
- use "qemu_softmmu_targets_${check}" && counter="1"
- done
- [[ ${counter} == 0 ]] && die "You need to set at least 1 target in QEMU_SOFTMMU_TARGETS"
-
- if kernel_is lt 2 6 25; then
- eerror "This version of KVM requres a host kernel of 2.6.25 or higher."
- eerror "Either upgrade your kernel"
- else
- if ! linux_config_exists; then
- eerror "Unable to check your kernel for KVM support"
- kvm_kern_warn
- elif ! linux_chkconfig_present KVM; then
- kvm_kern_warn
- fi
- fi
-
- enewgroup kvm
-}
-
-src_prepare() {
- # prevent docs to get automatically installed
- sed -i '/$(DESTDIR)$(docdir)/d' Makefile || die
- # Alter target makefiles to accept CFLAGS set via flag-o
- sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
- Makefile Makefile.target || die
- # append CFLAGS while linking
- sed -i 's/$(LDFLAGS)/$(QEMU_CFLAGS) $(CFLAGS) $(LDFLAGS)/' rules.mak || die
-
- # remove part to make udev happy
- sed -e 's~NAME="%k", ~~' -i kvm/scripts/65-kvm.rules || die
-
- epatch "${FILESDIR}"/qemu-0.11.0-mips64-user-fix.patch \
- "${FILESDIR}"/${P}-fix-crash-with-sdl.patch \
- "${FILESDIR}"/${PN}-0.12.2-virtio-large-iovecs.patch \
- "${FILESDIR}"/${P}-include-madvise-defines.patch
-}
-
-src_configure() {
- local conf_opts audio_opts softmmu_targets user_targets
-
- for target in ${IUSE_SOFTMMU_TARGETS} ; do
- use "qemu_softmmu_targets_${target}" && \
- softmmu_targets="${softmmu_targets} ${target}-softmmu"
- done
-
- for target in ${IUSE_USER_TARGETS} ; do
- use "qemu_user_targets_${target}" && \
- user_targets="${user_targets} ${target}-linux-user"
- done
-
- if [ ! -z "${softmmu_targets}" ]; then
- einfo "Building the following softmmu targets: ${softmmu_targets}"
- fi
-
- if [ ! -z "${user_targets}" ]; then
- einfo "Building the following user targets: ${user_targets}"
- conf_opts="${conf_opts} --enable-linux-user"
- else
- conf_opts="${conf_opts} --disable-linux-user"
- fi
-
- # Fix QA issues. QEMU needs executable heaps and we need to mark it as such
- conf_opts="${conf_opts} --extra-ldflags=-Wl,-z,execheap"
-
- # Add support for static builds
- use static && conf_opts="${conf_opts} --static"
-
- #config options
- conf_opts="${conf_opts} $(use_enable aio linux-aio)"
- use bluetooth || conf_opts="${conf_opts} --disable-bluez"
- conf_opts="${conf_opts} $(use_enable curl)"
- use gnutls || conf_opts="${conf_opts} --disable-vnc-tls"
- conf_opts="${conf_opts} $(use_enable fdt)"
- use hardened && conf_opts="${conf_opts} --enable-user-pie"
- use kvm-trace && conf_opts="${conf_opts} --with-kvm-trace"
- use ncurses || conf_opts="${conf_opts} --disable-curses"
- use sasl || conf_opts="${conf_opts} --disable-vnc-sasl"
- use sdl || conf_opts="${conf_opts} --disable-sdl"
- use vde || conf_opts="${conf_opts} --disable-vde"
-# conf_opts="${conf_opts} $(use_enable xen)"
- conf_opts="${conf_opts} --disable-xen"
- conf_opts="${conf_opts} --disable-darwin-user --disable-bsd-user"
-
- # audio options
- audio_opts="oss"
- use alsa && audio_opts="alsa ${audio_opts}"
- use esd && audio_opts="esd ${audio_opts}"
- use pulseaudio && audio_opts="pa ${audio_opts}"
- use sdl && audio_opts="sdl ${audio_opts}"
- ./configure --prefix=/usr \
- --disable-strip \
- --enable-kvm \
- --enable-nptl \
- --enable-uuid \
- ${conf_opts} \
- --audio-drv-list="${audio_opts}" \
- --target-list="${softmmu_targets} ${user_targets}" \
- --cc="$(tc-getCC)" \
- --host-cc="$(tc-getBUILD_CC)" \
- || die "configure failed"
-
- # this is for qemu upstream's threaded support which is
- # in development and broken
- # the kvm project has its own support for threaded IO
- # which is always on and works
-# --enable-io-thread \
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-
- insinto /etc/udev/rules.d/
- doins kvm/scripts/65-kvm.rules || die
-
- if use qemu-ifup; then
- insinto /etc/qemu/
- insopts -m0755
- doins kvm/scripts/qemu-ifup || die
- fi
-
- dodoc Changelog MAINTAINERS TODO pci-ids.txt || die
- newdoc pc-bios/README README.pc-bios || die
- dohtml qemu-doc.html qemu-tech.html || die
-
- if use qemu_softmmu_targets_x86_64 ; then
- dobin "${FILESDIR}"/qemu-kvm
- dosym /usr/bin/qemu-kvm /usr/bin/kvm
- else
- elog "You disabled QEMU_SOFTMMU_TARGETS=x86_64, this disables install"
- elog "of /usr/bin/qemu-kvm and /usr/bin/kvm"
- fi
-}
-
-pkg_postinst() {
- elog "If you don't have kvm compiled into the kernel, make sure you have"
- elog "the kernel module loaded before running kvm. The easiest way to"
- elog "ensure that the kernel module is loaded is to load it on boot."
- elog "For AMD CPUs the module is called 'kvm-amd'"
- elog "For Intel CPUs the module is called 'kvm-intel'"
- elog "Please review /etc/conf.d/modules for how to load these"
- elog
- elog "Make sure your user is in the 'kvm' group"
- elog "Just run 'gpasswd -a <USER> kvm', then have <USER> re-login."
- elog
- elog "You will need the Universal TUN/TAP driver compiled into your"
- elog "kernel or loaded as a module to use the virtual network device"
- elog "if using -net tap. You will also need support for 802.1d"
- elog "Ethernet Bridging and a configured bridge if using the provided"
- elog "kvm-ifup script from /etc/kvm."
- echo
-}
diff --git a/app-emulation/qemu-kvm/qemu-kvm-0.12.4-r1.ebuild b/app-emulation/qemu-kvm/qemu-kvm-0.12.4-r1.ebuild
deleted file mode 100644
index acb36b645607..000000000000
--- a/app-emulation/qemu-kvm/qemu-kvm-0.12.4-r1.ebuild
+++ /dev/null
@@ -1,237 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/qemu-kvm-0.12.4-r1.ebuild,v 1.3 2010/08/12 08:49:50 dev-zero Exp $
-
-EAPI="2"
-
-if [[ ${PV} = *9999* ]]; then
- EGIT_REPO_URI="git://git.kernel.org/pub/scm/virt/kvm/qemu-kvm.git"
- GIT_ECLASS="git"
-fi
-
-inherit eutils flag-o-matic ${GIT_ECLASS} linux-info toolchain-funcs
-
-if [[ ${PV} = *9999* ]]; then
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="mirror://sourceforge/kvm/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-fi
-
-DESCRIPTION="QEMU + Kernel-based Virtual Machine userland tools"
-HOMEPAGE="http://www.linux-kvm.org"
-
-LICENSE="GPL-2"
-SLOT="0"
-# xen is disabled until the deps are fixed
-IUSE="+aio alsa bluetooth curl esd gnutls fdt hardened kvm-trace ncurses \
-pulseaudio qemu-ifup sasl sdl static vde"
-
-COMMON_TARGETS="i386 x86_64 arm cris m68k microblaze mips mipsel ppc ppc64 sh4 sh4eb sparc sparc64"
-IUSE_SOFTMMU_TARGETS="${COMMON_TARGETS} mips64 mips64el ppcemb"
-IUSE_USER_TARGETS="${COMMON_TARGETS} alpha armeb ppc64abi32 sparc32plus"
-
-for target in ${IUSE_SOFTMMU_TARGETS}; do
- IUSE="${IUSE} +qemu_softmmu_targets_${target}"
-done
-
-for target in ${IUSE_USER_TARGETS}; do
- IUSE="${IUSE} +qemu_user_targets_${target}"
-done
-
-RESTRICT="test"
-
-RDEPEND="
- !app-emulation/kqemu
- !app-emulation/qemu
- !app-emulation/qemu-softmmu
- !app-emulation/qemu-user
- !app-emulation/qemu-kvm-spice
- sys-apps/pciutils
- >=sys-apps/util-linux-2.16.0
- sys-libs/zlib
- aio? ( dev-libs/libaio )
- alsa? ( >=media-libs/alsa-lib-1.0.13 )
- bluetooth? ( net-wireless/bluez )
- curl? ( net-misc/curl )
- esd? ( media-sound/esound )
- fdt? ( sys-apps/dtc )
- gnutls? ( net-libs/gnutls )
- ncurses? ( sys-libs/ncurses )
- pulseaudio? ( media-sound/pulseaudio )
- qemu-ifup? ( sys-apps/iproute2 net-misc/bridge-utils )
- sasl? ( dev-libs/cyrus-sasl )
- sdl? ( >=media-libs/libsdl-1.2.11[X] )
- vde? ( net-misc/vde )
-"
-
-DEPEND="${RDEPEND}
- app-text/texi2html
- >=sys-kernel/linux-headers-2.6.29
- gnutls? ( dev-util/pkgconfig )"
-
-kvm_kern_warn() {
- eerror "Please enable KVM support in your kernel, found at:"
- eerror
- eerror " Virtualization"
- eerror " Kernel-based Virtual Machine (KVM) support"
- eerror
-}
-
-pkg_setup() {
-
- local counter="0" check
- use qemu_softmmu_targets_x86_64 || ewarn "You disabled default target QEMU_SOFTMMU_TARGETS=x86_64"
- for check in ${IUSE_SOFTMMU_TARGETS} ; do
- use "qemu_softmmu_targets_${check}" && counter="1"
- done
- [[ ${counter} == 0 ]] && die "You need to set at least 1 target in QEMU_SOFTMMU_TARGETS"
-
- if kernel_is lt 2 6 25; then
- eerror "This version of KVM requres a host kernel of 2.6.25 or higher."
- eerror "Either upgrade your kernel"
- else
- if ! linux_config_exists; then
- eerror "Unable to check your kernel for KVM support"
- kvm_kern_warn
- elif ! linux_chkconfig_present KVM; then
- kvm_kern_warn
- fi
- fi
-
- enewgroup kvm
-}
-
-src_prepare() {
- # prevent docs to get automatically installed
- sed -i '/$(DESTDIR)$(docdir)/d' Makefile || die
- # Alter target makefiles to accept CFLAGS set via flag-o
- sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
- Makefile Makefile.target || die
- # append CFLAGS while linking
- sed -i 's/$(LDFLAGS)/$(QEMU_CFLAGS) $(CFLAGS) $(LDFLAGS)/' rules.mak || die
-
- # remove part to make udev happy
- sed -e 's~NAME="%k", ~~' -i kvm/scripts/65-kvm.rules || die
-
- epatch "${FILESDIR}"/qemu-0.11.0-mips64-user-fix.patch \
- "${FILESDIR}"/${PN}-0.12.3-fix-crash-with-sdl.patch \
- "${FILESDIR}"/${PN}-0.12.3-include-madvise-defines.patch \
- "${FILESDIR}"/${P}-large-virtio-corruption.patch
-}
-
-src_configure() {
- local conf_opts audio_opts softmmu_targets user_targets
-
- for target in ${IUSE_SOFTMMU_TARGETS} ; do
- use "qemu_softmmu_targets_${target}" && \
- softmmu_targets="${softmmu_targets} ${target}-softmmu"
- done
-
- for target in ${IUSE_USER_TARGETS} ; do
- use "qemu_user_targets_${target}" && \
- user_targets="${user_targets} ${target}-linux-user"
- done
-
- if [ ! -z "${softmmu_targets}" ]; then
- einfo "Building the following softmmu targets: ${softmmu_targets}"
- fi
-
- if [ ! -z "${user_targets}" ]; then
- einfo "Building the following user targets: ${user_targets}"
- conf_opts="${conf_opts} --enable-linux-user"
- else
- conf_opts="${conf_opts} --disable-linux-user"
- fi
-
- # Fix QA issues. QEMU needs executable heaps and we need to mark it as such
- conf_opts="${conf_opts} --extra-ldflags=-Wl,-z,execheap"
-
- # Add support for static builds
- use static && conf_opts="${conf_opts} --static"
-
- #config options
- conf_opts="${conf_opts} $(use_enable aio linux-aio)"
- use bluetooth || conf_opts="${conf_opts} --disable-bluez"
- conf_opts="${conf_opts} $(use_enable curl)"
- use gnutls || conf_opts="${conf_opts} --disable-vnc-tls"
- conf_opts="${conf_opts} $(use_enable fdt)"
- use hardened && conf_opts="${conf_opts} --enable-user-pie"
- use kvm-trace && conf_opts="${conf_opts} --with-kvm-trace"
- use ncurses || conf_opts="${conf_opts} --disable-curses"
- use sasl || conf_opts="${conf_opts} --disable-vnc-sasl"
- use sdl || conf_opts="${conf_opts} --disable-sdl"
- use vde || conf_opts="${conf_opts} --disable-vde"
-# conf_opts="${conf_opts} $(use_enable xen)"
- conf_opts="${conf_opts} --disable-xen"
- conf_opts="${conf_opts} --disable-darwin-user --disable-bsd-user"
-
- # audio options
- audio_opts="oss"
- use alsa && audio_opts="alsa ${audio_opts}"
- use esd && audio_opts="esd ${audio_opts}"
- use pulseaudio && audio_opts="pa ${audio_opts}"
- use sdl && audio_opts="sdl ${audio_opts}"
- ./configure --prefix=/usr \
- --disable-strip \
- --enable-kvm \
- --enable-nptl \
- --enable-uuid \
- ${conf_opts} \
- --audio-drv-list="${audio_opts}" \
- --target-list="${softmmu_targets} ${user_targets}" \
- --cc="$(tc-getCC)" \
- --host-cc="$(tc-getBUILD_CC)" \
- || die "configure failed"
-
- # this is for qemu upstream's threaded support which is
- # in development and broken
- # the kvm project has its own support for threaded IO
- # which is always on and works
-# --enable-io-thread \
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-
- insinto /etc/udev/rules.d/
- doins kvm/scripts/65-kvm.rules || die
-
- if use qemu-ifup; then
- insinto /etc/qemu/
- insopts -m0755
- doins kvm/scripts/qemu-ifup || die
- fi
-
- dodoc Changelog MAINTAINERS TODO pci-ids.txt || die
- newdoc pc-bios/README README.pc-bios || die
- dohtml qemu-doc.html qemu-tech.html || die
-
- if use qemu_softmmu_targets_x86_64 ; then
- dobin "${FILESDIR}"/qemu-kvm
- dosym /usr/bin/qemu-kvm /usr/bin/kvm
- else
- elog "You disabled QEMU_SOFTMMU_TARGETS=x86_64, this disables install"
- elog "of /usr/bin/qemu-kvm and /usr/bin/kvm"
- fi
-}
-
-pkg_postinst() {
- elog "If you don't have kvm compiled into the kernel, make sure you have"
- elog "the kernel module loaded before running kvm. The easiest way to"
- elog "ensure that the kernel module is loaded is to load it on boot."
- elog "For AMD CPUs the module is called 'kvm-amd'"
- elog "For Intel CPUs the module is called 'kvm-intel'"
- elog "Please review /etc/conf.d/modules for how to load these"
- elog
- elog "Make sure your user is in the 'kvm' group"
- elog "Just run 'gpasswd -a <USER> kvm', then have <USER> re-login."
- elog
- elog "You will need the Universal TUN/TAP driver compiled into your"
- elog "kernel or loaded as a module to use the virtual network device"
- elog "if using -net tap. You will also need support for 802.1d"
- elog "Ethernet Bridging and a configured bridge if using the provided"
- elog "kvm-ifup script from /etc/kvm."
- echo
-}
diff --git a/app-emulation/qemu-kvm/qemu-kvm-0.13.0.ebuild b/app-emulation/qemu-kvm/qemu-kvm-0.13.0-r2.ebuild
index 7a70d8099d78..d1dd91682be2 100644
--- a/app-emulation/qemu-kvm/qemu-kvm-0.13.0.ebuild
+++ b/app-emulation/qemu-kvm/qemu-kvm-0.13.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/qemu-kvm-0.13.0.ebuild,v 1.1 2010/10/28 09:54:24 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/qemu-kvm-0.13.0-r2.ebuild,v 1.1 2010/11/03 14:40:38 jmbsvicetto Exp $
EAPI="2"
@@ -25,8 +25,8 @@ HOMEPAGE="http://www.linux-kvm.org"
LICENSE="GPL-2"
SLOT="0"
# xen is disabled until the deps are fixed
-IUSE="+aio alsa bluetooth brltty curl esd fdt hardened kvm-trace \
-ncurses pulseaudio qemu-ifup sasl sdl ssl static vde"
+IUSE="+aio alsa bluetooth brltty curl esd fdt hardened jpeg ncurses \
+png pulseaudio qemu-ifup sasl sdl ssl static vde"
COMMON_TARGETS="i386 x86_64 arm cris m68k microblaze mips mipsel ppc ppc64 sh4 sh4eb sparc sparc64"
IUSE_SOFTMMU_TARGETS="${COMMON_TARGETS} mips64 mips64el ppcemb"
@@ -57,8 +57,10 @@ RDEPEND="
brltty? ( app-accessibility/brltty )
curl? ( net-misc/curl )
esd? ( media-sound/esound )
- fdt? ( sys-apps/dtc )
+ fdt? ( >=sys-apps/dtc-1.2.0 )
+ jpeg? ( media-libs/jpeg )
ncurses? ( sys-libs/ncurses )
+ png? ( media-libs/libpng )
pulseaudio? ( media-sound/pulseaudio )
qemu-ifup? ( sys-apps/iproute2 net-misc/bridge-utils )
sasl? ( dev-libs/cyrus-sasl )
@@ -82,20 +84,6 @@ kvm_kern_warn() {
}
pkg_setup() {
- for target in ${IUSE_SOFTMMU_TARGETS} ; do
- use "qemu_softmmu_targets_${target}" && \
- softmmu_targets="${softmmu_targets} ${target}-softmmu"
- done
-
- for target in ${IUSE_USER_TARGETS} ; do
- use "qemu_user_targets_${target}" && \
- user_targets="${user_targets} ${target}-linux-user"
- done
-
- if [ -z "${softmmu_targets}" ]; then
- return
- fi
-
use qemu_softmmu_targets_x86_64 || ewarn "You disabled default target QEMU_SOFTMMU_TARGETS=x86_64"
if kernel_is lt 2 6 25; then
@@ -125,17 +113,30 @@ src_prepare() {
# remove part to make udev happy
sed -e 's~NAME="%k", ~~' -i kvm/scripts/65-kvm.rules || die
- epatch "${FILESDIR}"/qemu-0.11.0-mips64-user-fix.patch \
- "${FILESDIR}"/${PN}-0.12.3-include-madvise-defines.patch
+ # ${PN}-guest-hang-on-usb-add.patch was sent by Timothy Jones
+ # to the qemu-devel ml - bug 337988
+ epatch "${FILESDIR}/qemu-0.11.0-mips64-user-fix.patch" \
+ "${FILESDIR}/${PN}-0.12.3-include-madvise-defines.patch"
+# "${FILESDIR}/${PN}-guest-hang-on-usb-add.patch"
}
src_configure() {
- local conf_opts audio_opts
+ local conf_opts audio_opts user_targets
- if [ ! -z "${softmmu_targets}" ]; then
- einfo "Building the following softmmu targets: ${softmmu_targets}"
- else
+ for target in ${IUSE_SOFTMMU_TARGETS} ; do
+ use "qemu_softmmu_targets_${target}" && \
+ softmmu_targets="${softmmu_targets} ${target}-softmmu"
+ done
+
+ for target in ${IUSE_USER_TARGETS} ; do
+ use "qemu_user_targets_${target}" && \
+ user_targets="${user_targets} ${target}-linux-user"
+ done
+
+ if [ -z "${softmmu_targets}" ]; then
conf_opts="${conf_opts} --disable-system"
+ else
+ einfo "Building the following softmmu targets: ${softmmu_targets}"
fi
if [ ! -z "${user_targets}" ]; then
@@ -151,6 +152,9 @@ src_configure() {
# Add support for static builds
use static && conf_opts="${conf_opts} --static"
+ # Fix the $(prefix)/etc issue
+ conf_opts="${conf_opts} --sysconfdir=/etc"
+
#config options
conf_opts="${conf_opts} $(use_enable aio linux-aio)"
conf_opts="${conf_opts} $(use_enable bluetooth bluez)"
@@ -158,8 +162,9 @@ src_configure() {
conf_opts="${conf_opts} $(use_enable curl)"
conf_opts="${conf_opts} $(use_enable fdt)"
conf_opts="${conf_opts} $(use_enable hardened user-pie)"
- use kvm-trace && conf_opts="${conf_opts} --with-kvm-trace"
+ conf_opts="${conf_opts} $(use_enable jpeg vnc-jpeg)"
conf_opts="${conf_opts} $(use_enable ncurses curses)"
+ conf_opts="${conf_opts} $(use_enable png vnc-png)"
conf_opts="${conf_opts} $(use_enable sasl vnc-sasl)"
conf_opts="${conf_opts} $(use_enable sdl)"
conf_opts="${conf_opts} $(use_enable ssl vnc-tls)"
@@ -191,7 +196,12 @@ src_configure() {
# in development and broken
# the kvm project has its own support for threaded IO
# which is always on and works
-# --enable-io-thread \
+ # --enable-io-thread \
+}
+
+src_compile() {
+ # Restricting parallel build until we get a patch to fix this
+ emake -j1 || die
}
src_install() {
@@ -211,8 +221,7 @@ src_install() {
dobin "${FILESDIR}"/qemu-kvm
dosym /usr/bin/qemu-kvm /usr/bin/kvm
else
- elog "You disabled QEMU_SOFTMMU_TARGETS=x86_64,"\
- " this disables install"
+ elog "You disabled QEMU_SOFTMMU_TARGETS=x86_64, this disables install"
elog "of /usr/bin/qemu-kvm and /usr/bin/kvm"
fi
fi
@@ -223,25 +232,24 @@ src_install() {
}
pkg_postinst() {
- if [ -z "${softmmu_targets}" ]; then
- return
+
+ if [ ! -z "${softmmu_targets}" ]; then
+ elog "If you don't have kvm compiled into the kernel, make sure you have"
+ elog "the kernel module loaded before running kvm. The easiest way to"
+ elog "ensure that the kernel module is loaded is to load it on boot."
+ elog "For AMD CPUs the module is called 'kvm-amd'"
+ elog "For Intel CPUs the module is called 'kvm-intel'"
+ elog "Please review /etc/conf.d/modules for how to load these"
+ elog
+ elog "Make sure your user is in the 'kvm' group"
+ elog "Just run 'gpasswd -a <USER> kvm', then have <USER> re-login."
+ elog
+ elog "You will need the Universal TUN/TAP driver compiled into your"
+ elog "kernel or loaded as a module to use the virtual network device"
+ elog "if using -net tap. You will also need support for 802.1d"
+ elog "Ethernet Bridging and a configured bridge if using the provided"
+ elog "kvm-ifup script from /etc/kvm."
+ elog
+ elog "The gnutls use flag was renamed to ssl, so adjust your use flags."
fi
- elog "If you don't have kvm compiled into the kernel, make sure you have"
- elog "the kernel module loaded before running kvm. The easiest way to"
- elog "ensure that the kernel module is loaded is to load it on boot."
- elog "For AMD CPUs the module is called 'kvm-amd'"
- elog "For Intel CPUs the module is called 'kvm-intel'"
- elog "Please review /etc/conf.d/modules for how to load these"
- elog
- elog "Make sure your user is in the 'kvm' group"
- elog "Just run 'gpasswd -a <USER> kvm', then have <USER> re-login."
- elog
- elog "You will need the Universal TUN/TAP driver compiled into your"
- elog "kernel or loaded as a module to use the virtual network device"
- elog "if using -net tap. You will also need support for 802.1d"
- elog "Ethernet Bridging and a configured bridge if using the provided"
- elog "kvm-ifup script from /etc/kvm."
- elog
- elog "The gnutls use flag was renamed to ssl, so adjust your use flags."
- echo
}