summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-09-27 10:51:49 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-09-27 10:51:49 +0000
commit45960d175059b23f064528046ca2ff9da12a0921 (patch)
tree355b021cf685892f7d52d257926eb5c0c196394d /app-emulation
parentresolv.conf permissions (Manifest recommit) (diff)
downloadgentoo-2-45960d175059b23f064528046ca2ff9da12a0921.tar.gz
gentoo-2-45960d175059b23f064528046ca2ff9da12a0921.tar.bz2
gentoo-2-45960d175059b23f064528046ca2ff9da12a0921.zip
Patches to fix with gcc-3.4 by fn_x@hotmail.com in bug #65444
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/basiliskII-jit/ChangeLog6
-rw-r--r--app-emulation/basiliskII-jit/basiliskII-jit-1.0.0-r1.ebuild5
-rw-r--r--app-emulation/basiliskII-jit/files/basiliskII-jit-gcc34.patch29
-rw-r--r--app-emulation/basiliskII/ChangeLog7
-rw-r--r--app-emulation/basiliskII/basiliskII-0.9.0.ebuild77
-rw-r--r--app-emulation/basiliskII/basiliskII-1.0.0_pre20020115.ebuild14
-rw-r--r--app-emulation/basiliskII/files/basiliskII-gcc34.patch81
-rw-r--r--app-emulation/basiliskII/files/digest-basiliskII-0.9.01
8 files changed, 134 insertions, 86 deletions
diff --git a/app-emulation/basiliskII-jit/ChangeLog b/app-emulation/basiliskII-jit/ChangeLog
index 05306943bf68..bf8f8069045d 100644
--- a/app-emulation/basiliskII-jit/ChangeLog
+++ b/app-emulation/basiliskII-jit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/basiliskII-jit
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII-jit/ChangeLog,v 1.3 2004/09/02 15:47:46 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII-jit/ChangeLog,v 1.4 2004/09/27 10:51:49 dragonheart Exp $
+
+ 27 Sep 2004; Daniel Black <dragonheart@gentoo.org>
+ +files/basiliskII-jit-gcc34.patch, basiliskII-jit-1.0.0-r1.ebuild:
+ Patches to fix with gcc-3.4 by fn_x@hotmail.com in bug #65444
*basiliskII-jit-1.0.0-r1 (02 Sep 2004)
diff --git a/app-emulation/basiliskII-jit/basiliskII-jit-1.0.0-r1.ebuild b/app-emulation/basiliskII-jit/basiliskII-jit-1.0.0-r1.ebuild
index 6cab80362fdf..83543ac470d1 100644
--- a/app-emulation/basiliskII-jit/basiliskII-jit-1.0.0-r1.ebuild
+++ b/app-emulation/basiliskII-jit/basiliskII-jit-1.0.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII-jit/basiliskII-jit-1.0.0-r1.ebuild,v 1.1 2004/09/02 15:47:46 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII-jit/basiliskII-jit-1.0.0-r1.ebuild,v 1.2 2004/09/27 10:51:49 dragonheart Exp $
inherit flag-o-matic
@@ -23,12 +23,13 @@ IUSE="X gtk xv esd dga"
### gtk and esd support are compile time options, we'll check the usual
### use variables here and set ./configure options accordingly
-DEPEND="gtk? ( x11-libs/gtk+ )
+DEPEND="gtk? ( =x11-libs/gtk+-1.2* )
esd? ( media-sound/esound )
>=sys-apps/sed-4"
src_unpack() {
unpack ${A}
+ epatch ${FILESDIR}/basiliskII-jit-gcc34.patch
# Fix up the vendor (bug 35352)
sed -i \
diff --git a/app-emulation/basiliskII-jit/files/basiliskII-jit-gcc34.patch b/app-emulation/basiliskII-jit/files/basiliskII-jit-gcc34.patch
new file mode 100644
index 000000000000..6e80d647edb4
--- /dev/null
+++ b/app-emulation/basiliskII-jit/files/basiliskII-jit-gcc34.patch
@@ -0,0 +1,29 @@
+--- BasiliskII-jit-1.0.orig/src/uae_cpu/compiler/compemu_atraps.cpp
++++ BasiliskII-jit-1.0/src/uae_cpu/compiler/compemu_atraps.cpp
+@@ -69,12 +69,12 @@
+ sync_m68k_pc();
+ }
+
+-void REGPARAM2 op_block_move_data_comp_ff(uae_u32 opcode)
++void REGPARAM op_block_move_data_comp_ff(uae_u32 opcode)
+ {
+ comp_block_move_data(opcode, false);
+ }
+
+-void REGPARAM2 op_block_move_data_comp_nf(uae_u32 opcode)
++void REGPARAM op_block_move_data_comp_nf(uae_u32 opcode)
+ {
+ comp_block_move_data(opcode, true);
+ }
+--- BasiliskII-jit-1.0.orig/src/uae_cpu/newcpu.cpp
++++ BasiliskII-jit-1.0/src/uae_cpu/newcpu.cpp
+@@ -1331,7 +1331,7 @@
+ #ifdef X86_ASSEMBLY
+ ASM_VOLATILE("\tpushl %%ebp\n\tcall *%%ebx\n\tpopl %%ebp" /* FIXME */
+ : : "b" (cpufunctbl[opcode]), "a" (opcode)
+- : "%edx", "%ecx", "%esi", "%edi", "%ebp", "memory", "cc");
++ : "%edx", "%ecx", "%esi", "%edi", "memory", "cc");
+ #else
+ (*cpufunctbl[opcode])(opcode);
+ #endif
+
diff --git a/app-emulation/basiliskII/ChangeLog b/app-emulation/basiliskII/ChangeLog
index 57330d7d305a..7961ac4b9002 100644
--- a/app-emulation/basiliskII/ChangeLog
+++ b/app-emulation/basiliskII/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/basiliskII
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII/ChangeLog,v 1.12 2004/06/24 22:29:52 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII/ChangeLog,v 1.13 2004/09/27 10:50:38 dragonheart Exp $
+
+ 27 Sep 2004; Daniel Black <dragonheart@gentoo.org>
+ +files/basiliskII-gcc34.patch,
+ -basiliskII-0.9.0.ebuild, basiliskII-1.0.0_pre20020115.ebuild:
+ Patches to fix with gcc-3.4 by fn_x@hotmail.com in bug #65444
07 Jun 2004; Daniel Black <dragonheart@gentoo.org>
basiliskII-1.0.0_pre20020115.ebuild:
diff --git a/app-emulation/basiliskII/basiliskII-0.9.0.ebuild b/app-emulation/basiliskII/basiliskII-0.9.0.ebuild
deleted file mode 100644
index 7a42a687ad30..000000000000
--- a/app-emulation/basiliskII/basiliskII-0.9.0.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII/basiliskII-0.9.0.ebuild,v 1.15 2004/06/27 23:01:16 vapier Exp $
-
-inherit flag-o-matic
-
-### This package requires a Mac II/Classic ROM, A Mac OS Image
-### Mac OS 7.5.3r2 is available freely from the Apple Homepage
-### System ROMS can be retreived from a 'real' Mac, See info/man pages
-
-DESCRIPTION="BasiliskII-0.9.0 Macintosh Emulator (Stable Release)"
-HOMEPAGE="http://www.uni-mainz.de/~bauec002/B2Main.html"
-SRC_URI="http://iphcip1.physik.uni-mainz.de/~cbauer/BasiliskII_src_31052001.tar.gz"
-
-LICENSE="GPL-2 | LGPL-2.1"
-SLOT="0"
-KEYWORDS="x86 -ppc"
-IUSE="X gtk xv esd dga"
-
-### We'll set $S Manually, it's version dependant, and nested strangely.
-S=${WORKDIR}/BasiliskII-0.9/src/Unix
-
-### fbdev support in the stable release... the cvs branch is broken, period!
-### gtk and esd support are compile time options, we'll check the usual
-### use variables here and set ./configure options accordingly
-
-DEPEND="gtk? ( x11-libs/gtk+ )
- esd? ( media-sound/esound )"
-
-src_compile() {
- #fpu_x86 doesnt compile properly if -O3 or greater :(
- replace-flags -O[3-9] -O2
-
- local myflags
-
-### Default ./configure options are all =yes by default. we'll check for
-### and use -values and switch them accordingly
-
- use X || myflags="${myflags} --with-x=no"
- use esd || myflags="${myflags} --with-esd=no"
- use gtk || myflags="${myflags} --with-gtk=no"
- use dga || myflags="${myflags} --with-dga=no"
- use xv || myflags="${myflags} --enable-xf86-vidmode=no"
-
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myflags} || die "BasiliskII ./configure Failed"
-
- #hack to link against libstdc++ for gcc3.x compatibility
- cp Makefile Makefile.old
- sed -e 's:-o $(OBJ_DIR)/gencpu:-lstdc++ -o $(OBJ_DIR)/gencpu:' \
- Makefile.old > Makefile
-
- emake || die "BasiliskII Make Failed"
-}
-
-src_install() {
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die "BasiliskII Make Install Failed"
-
-### Networking is _disabled_ in this revision, hopefully -r2 will
-### resolve the permissions issue / linux src compilation problem
-### that prevents it's inclusion
-
-### Uncomment the following, and read the manual _carefully_ if you really
-### need networking, this will create a sheep_net.o kernel module that
-### provides (effectivly) an ethernet bridge between basliskII and the kernel
-
-# make modules
-
-}
diff --git a/app-emulation/basiliskII/basiliskII-1.0.0_pre20020115.ebuild b/app-emulation/basiliskII/basiliskII-1.0.0_pre20020115.ebuild
index ae8b7556a81a..fa9e9d57485b 100644
--- a/app-emulation/basiliskII/basiliskII-1.0.0_pre20020115.ebuild
+++ b/app-emulation/basiliskII/basiliskII-1.0.0_pre20020115.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII/basiliskII-1.0.0_pre20020115.ebuild,v 1.5 2004/06/27 23:01:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII/basiliskII-1.0.0_pre20020115.ebuild,v 1.6 2004/09/27 10:50:38 dragonheart Exp $
-inherit flag-o-matic
+inherit flag-o-matic eutils
### This package requires a Mac II/Classic ROM, A Mac OS Image
### Mac OS 7.5.3r2 is available freely from the Apple Homepage
@@ -24,8 +24,14 @@ S=${WORKDIR}/BasiliskII-1.0/src/Unix
### gtk and esd support are compile time options, we'll check the usual
### use variables here and set ./configure options accordingly
-DEPEND="gtk? ( x11-libs/gtk+ )
- esd? ( media-sound/esound )"
+DEPEND="esd? ( media-sound/esound )
+ gtk? ( =x11-libs/gtk+-1.2* )"
+
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/basiliskII-gcc34.patch || die
+}
src_compile() {
#fpu_x86 doesnt compile properly if -O3 or greater :(
diff --git a/app-emulation/basiliskII/files/basiliskII-gcc34.patch b/app-emulation/basiliskII/files/basiliskII-gcc34.patch
new file mode 100644
index 000000000000..be98091ee733
--- /dev/null
+++ b/app-emulation/basiliskII/files/basiliskII-gcc34.patch
@@ -0,0 +1,81 @@
+--- BasiliskII-1.0.orig/src/uae_cpu/fpu/fpu_x86.cpp
++++ BasiliskII-1.0/src/uae_cpu/fpu/fpu_x86.cpp
+@@ -146,6 +146,9 @@
+ #define _ASM __asm__ __volatile__
+ #define min(a, b) (((a) < (b)) ? (a) : (b))
+
++#define STR(x) STR_(x)
++#define STR_(x) #x
++
+ /* ---------------------------- Configuration ---------------------------- */
+
+ /*
+@@ -1056,8 +1059,8 @@
+ } */
+
+ _ASM( "fstcw %0\n"
+- "andl $(~X86_ROUND_CONTROL_MASK), %0\n"
++ "andl $(~" STR(X86_ROUND_CONTROL_MASK) "), %0\n"
+- "orl $CW_RC_ZERO, %0\n"
++ "orl $" STR(CW_RC_ZERO) ", %0\n"
+ "fldcw %0\n"
+ "fldt %3\n"
+ "frndint\n"
+@@ -1645,7 +1648,7 @@
+ "0:\n" // partial_loop
+ "fprem \n"
+ "fnstsw %2\n" // %2: status (read/write)
+- "testl $SW_C2, %2\n"
++ "testl $" STR(SW_C2) ", %2\n"
+ "jne 0b\n"
+ "fxam \n"
+ "fnstsw %3\n" // %3: sw (write)
+@@ -1663,7 +1666,7 @@
+ "0:\n" // partial_loop
+ "fprem \n"
+ "fnstsw %0\n" // %0: status (read/write)
+- "testl $SW_C2, %0\n"
++ "testl $" STR(SW_C2) ", %0\n"
+ "jne 0b\n"
+ "fxam \n"
+ "fnstsw %1\n" // %1: sw (write)
+@@ -1765,7 +1768,7 @@
+ "0:\n" // partial_loop
+ "fprem1 \n"
+ "fnstsw %2\n" // %2: status (read/write)
+- "testl $SW_C2, %2\n"
++ "testl $" STR(SW_C2) ", %2\n"
+ "jne 0b\n"
+ "fxam \n"
+ "fnstsw %3\n" // %3: sw (write)
+@@ -1783,7 +1786,7 @@
+ "0:\n" // partial_loop
+ "fprem1 \n"
+ "fnstsw %0\n" // %0: status (read/write)
+- "testl $SW_C2, %0\n"
++ "testl $" STR(SW_C2) ", %0\n"
+ "jne 0b\n"
+ "fxam \n"
+ "fnstsw %1\n" // %1: sw (write)
+@@ -1999,8 +2002,8 @@
+ FLDCW cw
+ } */
+ _ASM( "fstcw %0\n"
+- "andl $(~X86_PRECISION_CONTROL_MASK), %0\n"
++ "andl $(~" STR(X86_PRECISION_CONTROL_MASK) "), %0\n"
+- "orl $PRECISION_CONTROL_SINGLE, %0\n"
++ "orl $" STR(PRECISION_CONTROL_SINGLE) ", %0\n"
+ "fldcw %0\n"
+ "fldt %3\n"
+ "fldt %2\n"
+@@ -2079,8 +2082,8 @@
+ FLDCW cw
+ } */
+ _ASM( "fstcw %0\n"
+- "andl $(~X86_PRECISION_CONTROL_MASK), %0\n"
++ "andl $(~" STR(X86_PRECISION_CONTROL_MASK) "), %0\n"
+- "orl $PRECISION_CONTROL_SINGLE, %0\n"
++ "orl $" STR(PRECISION_CONTROL_SINGLE) ", %0\n"
+ "fldcw %0\n"
+ "fldt %3\n"
+ "fldt %2\n"
diff --git a/app-emulation/basiliskII/files/digest-basiliskII-0.9.0 b/app-emulation/basiliskII/files/digest-basiliskII-0.9.0
deleted file mode 100644
index 4162d32bbfbe..000000000000
--- a/app-emulation/basiliskII/files/digest-basiliskII-0.9.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5017e21226c27a4a029da0486dcf04e1 BasiliskII_src_31052001.tar.gz 465882