summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2008-07-06 19:41:28 +0000
committerMike Auty <ikelos@gentoo.org>2008-07-06 19:41:28 +0000
commit408bf86508f46742b1121ac70d7ddf1c18380446 (patch)
tree02507562a34dbc246eb29bfdcb0468d40741f359 /app-emulation
parentStable on sparc, bug #214731 (diff)
downloadgentoo-2-408bf86508f46742b1121ac70d7ddf1c18380446.tar.gz
gentoo-2-408bf86508f46742b1121ac70d7ddf1c18380446.tar.bz2
gentoo-2-408bf86508f46742b1121ac70d7ddf1c18380446.zip
Version bump.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r4 i686)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/open-vm-tools/files/default-scripts.patch139
-rw-r--r--app-emulation/open-vm-tools/files/disable-toolbox.patch53
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-0.0.20080123.74039.ebuild4
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-0.0.20080515.93241.ebuild (renamed from app-emulation/open-vm-tools/open-vm-tools-0.0.20071121.64693.ebuild)60
4 files changed, 167 insertions, 89 deletions
diff --git a/app-emulation/open-vm-tools/files/default-scripts.patch b/app-emulation/open-vm-tools/files/default-scripts.patch
new file mode 100644
index 000000000000..2136dad71d90
--- /dev/null
+++ b/app-emulation/open-vm-tools/files/default-scripts.patch
@@ -0,0 +1,139 @@
+diff --git a/scripts/linux/resume-vm-default b/scripts/linux/resume-vm-default
+index cebbba0..dbd38a6 100644
+--- a/scripts/linux/resume-vm-default
++++ b/scripts/linux/resume-vm-default
+@@ -25,41 +25,10 @@
+ echo `date` ": Executing '$0'"
+ echo
+
+-find_networking_script() {
+- local script="error"
+- for dir in "/etc/init.d" "/sbin/init.d" "/etc" "/etc/rc.d" ; do
+- if [ -d "$dir/rc0.d" ] &&
+- [ -d "$dir/rc1.d" ] &&
+- [ -d "$dir/rc2.d" ] &&
+- [ -d "$dir/rc3.d" ] &&
+- [ -d "$dir/rc4.d" ] &&
+- [ -d "$dir/rc5.d" ] &&
+- [ -d "$dir/rc6.d" ]; then
+-
+- # Now find the appropriate networking script.
+- if [ -d "$dir/init.d" ]; then
+- if [ -x "$dir/init.d/network" ]; then
+- script="$dir/init.d/network"
+- elif [ -x "$dir/init.d/networking" ]; then
+- script="$dir/init.d/networking"
+- fi
+- else
+- if [ -x "$dir/network" ]; then
+- script="$dir/network"
+- elif [ -x "$dir/networking" ]; then
+- script="$dir/networking"
+- fi
+- fi
+- fi
+- done
+-
+- echo "$script"
+-}
+-
+ rescue_NIC() {
+ niclist="/var/run/vmware-active-nics"
+
+- ifup_path=`which ifup 2>/dev/null`;
++ ifup_path="/etc/init.d/net.";
+ if [ $? -ne 0 ]; then
+ return 1;
+ fi
+@@ -76,7 +45,7 @@ rescue_NIC() {
+ else
+ echo `date` "[rescue_nic] activating $nic ..."
+
+- $ifup_path $nic
++ $ifup_path$nic restart
+ fi
+ done < $niclist
+
+@@ -95,15 +64,8 @@ if [ -d "$scriptsdir" ]; then
+ done
+ fi
+
+-network=`find_networking_script`
+-if [ "$network" != "error" ]; then
+- "$network" restart
+- # Continue even if the networking init script wasn't successful.
+- status=0
+-else
+- echo "networking script not found"
+- status=1
+-fi
++# Continue even if the networking init script wasn't successful.
++status=0
+
+ if [ $status -eq 0 ]; then
+ rescue_NIC
+diff --git a/scripts/linux/suspend-vm-default b/scripts/linux/suspend-vm-default
+index 80bf5b9..f590194 100644
+--- a/scripts/linux/suspend-vm-default
++++ b/scripts/linux/suspend-vm-default
+@@ -25,37 +25,6 @@
+ echo `date` ": Executing '$0'"
+ echo
+
+-find_networking_script() {
+- local script="error"
+- for dir in "/etc/init.d" "/sbin/init.d" "/etc" "/etc/rc.d" ; do
+- if [ -d "$dir/rc0.d" ] &&
+- [ -d "$dir/rc1.d" ] &&
+- [ -d "$dir/rc2.d" ] &&
+- [ -d "$dir/rc3.d" ] &&
+- [ -d "$dir/rc4.d" ] &&
+- [ -d "$dir/rc5.d" ] &&
+- [ -d "$dir/rc6.d" ]; then
+-
+- # Now find the appropriate networking script.
+- if [ -d "$dir/init.d" ]; then
+- if [ -x "$dir/init.d/network" ]; then
+- script="$dir/init.d/network"
+- elif [ -x "$dir/init.d/networking" ]; then
+- script="$dir/init.d/networking"
+- fi
+- else
+- if [ -x "$dir/network" ]; then
+- script="$dir/network"
+- elif [ -x "$dir/networking" ]; then
+- script="$dir/networking"
+- fi
+- fi
+- fi
+- done
+-
+- echo "$script"
+-}
+-
+ save_active_NIC_list() {
+ ifconfig_path=`which ifconfig 2>/dev/null`
+ if [ $? ]; then
+@@ -76,15 +45,12 @@ fi
+
+ save_active_NIC_list
+
+-network=`find_networking_script`
+-if [ "$network" != "error" ]; then
+- "$network" stop
+- # If the network is down, this may fail but that's not a good reason
+- # to prevent the suspend.
+- status=0
+-else
+- echo "networking script not found"
+- status=1
+-fi
++for network in `ls /etc/init.d/net.*`;
++do
++ "$network" stop
++done
++# If the network is down, this may fail but that's not a good reason
++# to prevent the suspend.
++status=0
+
+ exit "$status"
diff --git a/app-emulation/open-vm-tools/files/disable-toolbox.patch b/app-emulation/open-vm-tools/files/disable-toolbox.patch
deleted file mode 100644
index 84f97bc65f04..000000000000
--- a/app-emulation/open-vm-tools/files/disable-toolbox.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-diff -ruN open-vm-tools-2007.09.04-56574.orig/configure open-vm-tools-2007.09.04-56574/configure
---- open-vm-tools-2007.09.04-56574.orig/configure 2007-09-07 09:05:19.000000000 +0200
-+++ open-vm-tools-2007.09.04-56574/configure 2007-09-14 22:26:20.000000000 +0200
-@@ -25442,7 +25442,7 @@
- ###
- ### Create the Makefiles
- ###
--ac_config_files="$ac_config_files Makefile lib/Makefile lib/atomic/Makefile lib/atomic/shared/Makefile lib/auth/Makefile lib/backdoor/Makefile lib/backdoor/shared/Makefile lib/conf/Makefile lib/dict/Makefile lib/dnd/Makefile lib/err/Makefile lib/eventManager/Makefile lib/file/Makefile lib/fileUtf8/Makefile lib/foundryMsg/Makefile lib/guestApp/Makefile lib/guestInfo/Makefile lib/hgfs/Makefile lib/hgfsBd/Makefile lib/hgfsServer/Makefile lib/hgfsServerManagerGuest/Makefile lib/hgfsServerPolicyGuest/Makefile lib/deployPkg/Makefile lib/impersonate/Makefile lib/message/Makefile lib/message/shared/Makefile lib/misc/Makefile lib/misc/shared/Makefile lib/netUtil/Makefile lib/panic/Makefile lib/panicDefault/Makefile lib/printer/Makefile lib/procMgr/Makefile lib/rpcIn/Makefile lib/rpcOut/Makefile lib/rpcOut/shared/Makefile lib/rpcVmx/Makefile lib/SLPv2Parser/Makefile lib/socketMgr/Makefile lib/strUtil/Makefile lib/string/Makefile lib/string/shared/Makefile lib/sync/Makefile lib/sync/shared/Makefile lib/syncDriver/Makefile lib/system/Makefile lib/toolsLogger/Makefile lib/user/Makefile lib/vixTools/Makefile lib/vmBackupLib/Makefile lib/vmCheck/Makefile lib/vmSignal/Makefile lib/wiper/Makefile guestd/Makefile vmware-user/Makefile toolbox/Makefile hgfsclient/Makefile hgfsmounter/Makefile checkvm/Makefile libguestlib/Makefile"
-+ac_config_files="$ac_config_files Makefile lib/Makefile lib/atomic/Makefile lib/atomic/shared/Makefile lib/auth/Makefile lib/backdoor/Makefile lib/backdoor/shared/Makefile lib/conf/Makefile lib/dict/Makefile lib/dnd/Makefile lib/err/Makefile lib/eventManager/Makefile lib/file/Makefile lib/fileUtf8/Makefile lib/foundryMsg/Makefile lib/guestApp/Makefile lib/guestInfo/Makefile lib/hgfs/Makefile lib/hgfsBd/Makefile lib/hgfsServer/Makefile lib/hgfsServerManagerGuest/Makefile lib/hgfsServerPolicyGuest/Makefile lib/deployPkg/Makefile lib/impersonate/Makefile lib/message/Makefile lib/message/shared/Makefile lib/misc/Makefile lib/misc/shared/Makefile lib/netUtil/Makefile lib/panic/Makefile lib/panicDefault/Makefile lib/printer/Makefile lib/procMgr/Makefile lib/rpcIn/Makefile lib/rpcOut/Makefile lib/rpcOut/shared/Makefile lib/rpcVmx/Makefile lib/SLPv2Parser/Makefile lib/socketMgr/Makefile lib/strUtil/Makefile lib/string/Makefile lib/string/shared/Makefile lib/sync/Makefile lib/sync/shared/Makefile lib/syncDriver/Makefile lib/system/Makefile lib/toolsLogger/Makefile lib/user/Makefile lib/vixTools/Makefile lib/vmBackupLib/Makefile lib/vmCheck/Makefile lib/vmSignal/Makefile lib/wiper/Makefile guestd/Makefile vmware-user/Makefile hgfsclient/Makefile hgfsmounter/Makefile checkvm/Makefile libguestlib/Makefile"
-
-
- ###
-@@ -26131,7 +26131,7 @@
- "lib/wiper/Makefile") CONFIG_FILES="$CONFIG_FILES lib/wiper/Makefile" ;;
- "guestd/Makefile") CONFIG_FILES="$CONFIG_FILES guestd/Makefile" ;;
- "vmware-user/Makefile") CONFIG_FILES="$CONFIG_FILES vmware-user/Makefile" ;;
-- "toolbox/Makefile") CONFIG_FILES="$CONFIG_FILES toolbox/Makefile" ;;
-+ "") CONFIG_FILES="$CONFIG_FILES " ;;
- "hgfsclient/Makefile") CONFIG_FILES="$CONFIG_FILES hgfsclient/Makefile" ;;
- "hgfsmounter/Makefile") CONFIG_FILES="$CONFIG_FILES hgfsmounter/Makefile" ;;
- "checkvm/Makefile") CONFIG_FILES="$CONFIG_FILES checkvm/Makefile" ;;
-diff -ruN open-vm-tools-2007.09.04-56574.orig/Makefile.am open-vm-tools-2007.09.04-56574/Makefile.am
---- open-vm-tools-2007.09.04-56574.orig/Makefile.am 2007-09-07 09:05:07.000000000 +0200
-+++ open-vm-tools-2007.09.04-56574/Makefile.am 2007-09-14 22:26:12.000000000 +0200
-@@ -22,7 +22,6 @@
- SUBDIRS += lib
- SUBDIRS += guestd
- SUBDIRS += vmware-user
--SUBDIRS += toolbox
- SUBDIRS += hgfsclient
- # hgfsmounter is only needed on Linux.
- if LINUX
-diff -ruN open-vm-tools-2007.09.04-56574.orig/Makefile.in open-vm-tools-2007.09.04-56574/Makefile.in
---- open-vm-tools-2007.09.04-56574.orig/Makefile.in 2007-09-07 09:05:23.000000000 +0200
-+++ open-vm-tools-2007.09.04-56574/Makefile.in 2007-09-14 22:26:01.000000000 +0200
-@@ -79,7 +79,7 @@
- distclean-recursive maintainer-clean-recursive
- ETAGS = etags
- CTAGS = ctags
--DIST_SUBDIRS = lib guestd vmware-user toolbox hgfsclient hgfsmounter \
-+DIST_SUBDIRS = lib guestd vmware-user hgfsclient hgfsmounter \
- checkvm libguestlib
- DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
- distdir = $(PACKAGE)-$(VERSION)
-@@ -220,7 +220,7 @@
- target_alias = @target_alias@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
--SUBDIRS = lib guestd vmware-user toolbox hgfsclient $(am__append_1) \
-+SUBDIRS = lib guestd vmware-user hgfsclient $(am__append_1) \
- checkvm libguestlib
- MODULES = vmblock vmhgfs vmmemctl vmxnet
- all: all-recursive
diff --git a/app-emulation/open-vm-tools/open-vm-tools-0.0.20080123.74039.ebuild b/app-emulation/open-vm-tools/open-vm-tools-0.0.20080123.74039.ebuild
index c43ad31fcdf2..e3a893052eb2 100644
--- a/app-emulation/open-vm-tools/open-vm-tools-0.0.20080123.74039.ebuild
+++ b/app-emulation/open-vm-tools/open-vm-tools-0.0.20080123.74039.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20080123.74039.ebuild,v 1.1 2008/01/30 14:08:32 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20080123.74039.ebuild,v 1.2 2008/07/06 19:41:28 ikelos Exp $
-inherit pam eutils linux-mod autotools versionator
+inherit pam eutils linux-mod versionator
MY_DATE="$(get_version_component_range 3)"
MY_BUILD="$(get_version_component_range 4)"
diff --git a/app-emulation/open-vm-tools/open-vm-tools-0.0.20071121.64693.ebuild b/app-emulation/open-vm-tools/open-vm-tools-0.0.20080515.93241.ebuild
index 5a7a68a59a0b..6daa30a2087b 100644
--- a/app-emulation/open-vm-tools/open-vm-tools-0.0.20071121.64693.ebuild
+++ b/app-emulation/open-vm-tools/open-vm-tools-0.0.20080515.93241.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20071121.64693.ebuild,v 1.4 2008/04/26 14:04:22 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20080515.93241.ebuild,v 1.1 2008/07/06 19:41:28 ikelos Exp $
-inherit eutils linux-mod versionator
+inherit pam eutils linux-mod autotools versionator
MY_DATE="$(get_version_component_range 3)"
MY_BUILD="$(get_version_component_range 4)"
@@ -15,10 +15,10 @@ DESCRIPTION="Opensourced tools for VMware guests"
HOMEPAGE="http://open-vm-tools.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~x86 ~amd64"
-IUSE="pam X xinerama"
+IUSE="X xinerama icu"
DEPEND="
virtual/linux-sources
sys-apps/ethtool
@@ -32,14 +32,18 @@ DEPEND="
!app-emulation/vmware-workstation-tools
!app-emulation/vmware-server-tools
!app-emulation/vmware-esx-tools
+ sys-process/procps
+ dev-libs/libdnet
+ icu? ( dev-libs/icu )
"
RDEPEND="${DEPEND/virtual\/linux\-sources/}
- X? (
+ virtual/pam
+ X? (
x11-base/xorg-server
x11-drivers/xf86-video-vmware
x11-drivers/xf86-input-vmmouse
- )
+ )
"
VMWARE_MOD_DIR="modules/linux"
@@ -49,7 +53,7 @@ pkg_setup() {
linux-mod_pkg_setup
MODULE_NAMES=""
- BUILD_TARGETS="auto-build KERNEL_DIR=${KERNEL_DIR} KBUILD_OUTPUT=${KV_OUT_DIR}"
+ BUILD_TARGETS="auto-build HEADER_DIR=${KERNEL_DIR}/include BUILD_DIR=${KV_OUT_DIR}"
for mod in ${VMWARE_MODULE_LIST};
do
@@ -62,21 +66,25 @@ pkg_setup() {
MODULE_NAMES="${MODULE_NAMES} ${mod}(${MODTARGET}:${S}/${VMWARE_MOD_DIR}/${mod})"
done
+ ewarn "If you're compiling for a hardened target, please use the hardened"
+ ewarn "nopie compiler in the hardened profile (select it using gcc-config)."
+ ewarn "For more details please see bug #200376, comment 18."
+
enewgroup vmware
}
src_unpack() {
unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/default-scripts.patch"
+
+ eautoreconf
}
src_compile() {
- #if ! use X; then
- # epatch ${FILESDIR}/disable-toolbox.patch
- # rm -rf ${S}/toolbox
- #fi
-
econf \
+ $(use_with icu) \
$(use_with X x) \
$(use_enable xinerama multimon) \
|| die "Error: econf failed!"
@@ -90,23 +98,7 @@ src_install() {
linux-mod_src_install
- if use pam; then
- LIB="$(get_libdir)"
- PAMFILE="${D}/etc/pam.d/vmware-guestd"
- dodir "${ROOT}${LIB}"
- dodir "${ROOT}etc/pam.d"
- echo '#%PAM-1.0' > "${PAMFILE}"
- if [[ -e "${ROOT}${LIB}/security/pam_unix2.so" ]];
- then
- PAM_VER=2
- fi
-
- echo -e "auth\tsufficient\t${ROOT}${LIB}/security/pam_unix${PAM_VER}.so\tshadow\tnullok" >> "${PAMFILE}"
- echo -e "auth\trequired\t${ROOT}${LIB}/security/pam_unix_auth.so\tshadow\tnullok" >> "${PAMFILE}"
- echo -e "account\tsufficient\t${ROOT}${LIB}/security/pam_unix${PAM_VER}.so" >> "${PAMFILE}"
- echo -e "account\trequired\t${ROOT}${LIB}/security/pam_unix_acct.so" >> "${PAMFILE}"
-
- fi
+ pamd_mimic_system vmware-guestd auth account
# Install the various tools
cd "${S}"
@@ -128,15 +120,15 @@ src_install() {
dolib libguestlib/.libs/libguestlib.{so.0.0.0,a}
# Deal with the hgfsmounter
- into "${ROOT}"
+ into /
newsbin hgfsmounter/hgfsmounter mount.vmhgfs
- fperms u+s "${ROOT}sbin/mount.vmhgfs"
- ### FROM THIS POINT ON, into IS SET TO ${ROOT} not /usr !!!
+ fperms u+s /sbin/mount.vmhgfs
+ ### FROM THIS POINT ON, into IS SET TO ${ROOT}/ not ${ROOT}/usr !!!
# Install the /etc/ files
- exeinto "${ROOT}etc/vmware-tools"
+ exeinto /etc/vmware-tools
doexe scripts/linux/*
- insinto "${ROOT}etc/vmware-tools"
+ insinto /etc/vmware-tools
doins "${FILESDIR}/tools.conf"
# Only install this, when X is being used. Else it's useless waste of
# ressources when checking continuously for processes that will never appear