summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-09-04 05:51:44 +0000
committerNick Hadaway <raker@gentoo.org>2002-09-04 05:51:44 +0000
commit3c79412ff9ed0598374f3d555ee9d39f9c5295c2 (patch)
tree0f49856d4c62f5aea352f3884cbec404649e92dd /app-emulation
parentNew package. (diff)
downloadgentoo-2-3c79412ff9ed0598374f3d555ee9d39f9c5295c2.tar.gz
gentoo-2-3c79412ff9ed0598374f3d555ee9d39f9c5295c2.tar.bz2
gentoo-2-3c79412ff9ed0598374f3d555ee9d39f9c5295c2.zip
Updated ebuild to econf and einstall. Added use variable support for
gnome and nls. Corrected some dependancies.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/XWine/ChangeLog7
-rw-r--r--app-emulation/XWine/XWine-0.2.2.ebuild48
2 files changed, 33 insertions, 22 deletions
diff --git a/app-emulation/XWine/ChangeLog b/app-emulation/XWine/ChangeLog
index f326ebf40240..71a92ba0337e 100644
--- a/app-emulation/XWine/ChangeLog
+++ b/app-emulation/XWine/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for app-emulation/XWine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/XWine/ChangeLog,v 1.1 2002/08/19 21:28:46 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/XWine/ChangeLog,v 1.2 2002/09/04 05:51:44 raker Exp $
*XWine-0.2.2.ebuild (17 Aug 2002)
+ 03 Sep 2002; Nick Hadaway <raker@gentoo.org> XWine-0.2.2.ebuild :
+ Changed to econf and einstall. Added myconf switches for gnome and
+ nls support. Changed dependancy from libgnome to gnome-libs and
+ ORBit.
+
19 Aug 2002; Nick Hadaway <raker@gentoo.org> XWine-0.2.2.ebuild :
Updated ebuild to not install /usr/share/doc/winex and associated
files. These are already taken care of by dodoc.
diff --git a/app-emulation/XWine/XWine-0.2.2.ebuild b/app-emulation/XWine/XWine-0.2.2.ebuild
index 740172ff9d39..ad7d1e9e09c9 100644
--- a/app-emulation/XWine/XWine-0.2.2.ebuild
+++ b/app-emulation/XWine/XWine-0.2.2.ebuild
@@ -1,39 +1,46 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/XWine/XWine-0.2.2.ebuild,v 1.1 2002/08/19 21:28:46 raker Exp $
-DESCRIPTION="Gtk frontend for Wine emulator"
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/XWine/XWine-0.2.2.ebuild,v 1.2 2002/09/04 05:51:44 raker Exp $
-MY_P=${P}_en
+S="${WORKDIR}/${P}_en"
+DESCRIPTION="GTK frontend for Wine"
HOMEPAGE="http://darken.tuxfamily.org/pages/xwine_en.html"
+SRC_URI="http://darken.tuxfamily.org/projets/${P}_en.tar.gz"
-SRC_URI="http://darken.tuxfamily.org/projets/${MY_P}.tar.gz"
-LICENSE="GPL-2"
+DEPEND=">=x11-libs/gtk+-1.2.10-r8
+ >=net-www/mozilla-1.0-r2
+ >=app-emulation/wine-20020710-r1
+ sys-devel/bison
+ gnome? ( >=gnome-base/gnome-libs-1.4.2
+ >=gnome-base/ORBit-0.5.17 )
+ nls? ( sys-devel/gettext )"
+RDEPEND="${DEPEND}
+ >=app-emulation/winesetuptk-0.6.0b-r2"
+LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 -ppc -sparc -sparc64"
-KEYWORDS="x86"
-DEPEND=">=x11-libs/gtk+-1.2.10-r8
- >=gnome-base/libgnome-2.0.1-r1
- >=net-www/mozilla-1.0-r2
- >=app-emulation/wine-20020710-r1"
+src_compile() {
-RDEPEND="${DEPEND}
- >=app-emulation/winesetuptk-0.6.0b-r2"
+ local myconf
+ use gnome && myconf="--with-gnome" \
+ || myconf="--without-gnome"
-S="${WORKDIR}/${MY_P}"
+ use nls && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die "configuration failed"
+
+ make || die
-src_compile() {
- ./configure \
- --prefix=/usr \
- emake || die
}
src_install () {
- make \
- prefix=${D}/usr \
- install || die
+
+ einstall || die "install failed"
# Don't need to install docs twice
rm -rf ${D}/usr/share/doc/xwine
@@ -43,7 +50,6 @@ src_install () {
pkg_postinst() {
- einfo
einfo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
einfo "! ${PN} requires a setup Wine to start....It is recommended !"
einfo "! that you run winesetuptk prior to running ${PN} to setup !"