summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-03-07 22:38:59 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-03-07 22:38:59 +0000
commit39582c03a51b96ce555a635a0ea70daa6881cc11 (patch)
tree0a85db58bec6cb8f585dfea081faf8f47835a160 /app-emulation
parentRemove older versions (diff)
downloadgentoo-2-39582c03a51b96ce555a635a0ea70daa6881cc11.tar.gz
gentoo-2-39582c03a51b96ce555a635a0ea70daa6881cc11.tar.bz2
gentoo-2-39582c03a51b96ce555a635a0ea70daa6881cc11.zip
Backport USE=fuse to prevent automagical depend on sys-fs/fuse.
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt/ChangeLog5
-rw-r--r--app-emulation/libvirt/libvirt-1.0.2-r2.ebuild7
2 files changed, 9 insertions, 3 deletions
diff --git a/app-emulation/libvirt/ChangeLog b/app-emulation/libvirt/ChangeLog
index 1ca4ac431742..241531997c7b 100644
--- a/app-emulation/libvirt/ChangeLog
+++ b/app-emulation/libvirt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/libvirt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.254 2013/03/07 22:36:55 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.255 2013/03/07 22:38:59 cardoe Exp $
+
+ 07 Mar 2013; Doug Goldstein <cardoe@gentoo.org> libvirt-1.0.2-r2.ebuild:
+ Backport USE=fuse to prevent automagical depend on sys-fs/fuse.
07 Mar 2013; Doug Goldstein <cardoe@gentoo.org> -libvirt-0.10.2.1.ebuild,
-libvirt-0.10.2.2.ebuild, -libvirt-1.0.1.ebuild:
diff --git a/app-emulation/libvirt/libvirt-1.0.2-r2.ebuild b/app-emulation/libvirt/libvirt-1.0.2-r2.ebuild
index 8fb44a6eece0..9363548d283a 100644
--- a/app-emulation/libvirt/libvirt-1.0.2-r2.ebuild
+++ b/app-emulation/libvirt/libvirt-1.0.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-1.0.2-r2.ebuild,v 1.3 2013/02/24 11:29:50 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-1.0.2-r2.ebuild,v 1.4 2013/03/07 22:38:59 cardoe Exp $
EAPI=5
@@ -34,7 +34,7 @@ DESCRIPTION="C toolkit to manipulate virtual machines"
HOMEPAGE="http://www.libvirt.org/"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="audit avahi +caps firewalld iscsi +libvirtd lvm +lxc +macvtap nfs \
+IUSE="audit avahi +caps firewalld fuse iscsi +libvirtd lvm +lxc +macvtap nfs \
nls numa openvz parted pcap phyp policykit python qemu rbd sasl \
selinux +udev uml +vepa virtualbox virt-network xen elibc_glibc"
REQUIRED_USE="libvirtd? ( || ( lxc openvz qemu uml virtualbox xen ) )
@@ -69,6 +69,7 @@ RDEPEND="sys-libs/readline
audit? ( sys-process/audit )
avahi? ( >=net-dns/avahi-0.6[dbus] )
caps? ( sys-libs/libcap-ng )
+ fuse? ( >=sys-fs/fuse-2.8.6 )
iscsi? ( sys-block/open-iscsi )
lxc? ( sys-power/pm-utils )
lvm? ( >=sys-fs/lvm2-2.02.48-r2 )
@@ -164,6 +165,7 @@ pkg_setup() {
LXC_CONFIG_CHECK+=" ~MEMCG"
CONFIG_CHECK=""
+ use fuse && CONFIG_CHECK+=" ~FUSE_FS"
use lxc && CONFIG_CHECK+="${LXC_CONFIG_CHECK}"
use macvtap && CONFIG_CHECK+="${MACVTAP}"
use virt-network && CONFIG_CHECK+="${VIRTNET_CONFIG_CHECK}"
@@ -253,6 +255,7 @@ src_configure() {
myconf="${myconf} $(use_with numa numactl)"
myconf="${myconf} $(use_with numa numad)"
myconf="${myconf} $(use_with selinux)"
+ myconf="${myconf} $(use_with fuse)"
# udev for device support details
myconf="${myconf} $(use_with udev)"