summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2007-02-21 09:29:52 +0000
committerSimon Stelling <blubb@gentoo.org>2007-02-21 09:29:52 +0000
commit393c4c8451e683e72ec0f8d7a4ef328c60e3fa16 (patch)
treee144220c5076b771c3c7e22ead382b71e4d9a95f /app-emulation
parentuse new emul-libs eclass (diff)
downloadgentoo-2-393c4c8451e683e72ec0f8d7a4ef328c60e3fa16.tar.gz
gentoo-2-393c4c8451e683e72ec0f8d7a4ef328c60e3fa16.tar.bz2
gentoo-2-393c4c8451e683e72ec0f8d7a4ef328c60e3fa16.zip
use the new emul-libs.eclass
(Portage version: 2.1.2-r9)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/emul-linux-x86-xlibs/ChangeLog6
-rw-r--r--app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-10.0.ebuild38
2 files changed, 8 insertions, 36 deletions
diff --git a/app-emulation/emul-linux-x86-xlibs/ChangeLog b/app-emulation/emul-linux-x86-xlibs/ChangeLog
index c8ef122da58b..bcb6a6c035e6 100644
--- a/app-emulation/emul-linux-x86-xlibs/ChangeLog
+++ b/app-emulation/emul-linux-x86-xlibs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/emul-linux-x86-xlibs
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-xlibs/ChangeLog,v 1.57 2007/02/19 21:57:34 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-xlibs/ChangeLog,v 1.58 2007/02/21 09:29:52 blubb Exp $
+
+ 21 Feb 2007; Simon Stelling <blubb@gentoo.org>
+ emul-linux-x86-xlibs-10.0.ebuild:
+ use the new emul-libs.eclass
19 Feb 2007; Simon Stelling <blubb@gentoo.org>
emul-linux-x86-xlibs-10.0.ebuild:
diff --git a/app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-10.0.ebuild b/app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-10.0.ebuild
index 5746bf6653c9..3a61c99a820d 100644
--- a/app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-10.0.ebuild
+++ b/app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-10.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-10.0.ebuild,v 1.2 2007/02/19 21:57:34 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-xlibs/emul-linux-x86-xlibs-10.0.ebuild,v 1.3 2007/02/21 09:29:52 blubb Exp $
+
+inherit emul-libs
-DESCRIPTION="Provides precompiled 32bit libraries"
-HOMEPAGE="http://amd64.gentoo.org/emul/content.xml"
SRC_URI="mirror://gentoo/fontconfig-2.4.2.tbz2
mirror://gentoo/freetype-2.1.10-r2.tbz2
mirror://gentoo/glut-3.7.1.tbz2
@@ -41,46 +41,14 @@ LICENSE="fontconfig FTL GPL-2 LGPL-2 glut libdrm libICE libSM libX11 libXau
libXaw libXcomposite libXcursor libXdamage libXdmcp libXext libXfixes libXft
libXi libXinerama libXmu libXp libXpm libXrandr libXrender libXScrnSaver libXt
libXtst libXv libXvMC libXxf86dga libXxf86dga libXxf86vm"
-SLOT="0"
KEYWORDS="-* ~amd64"
IUSE="opengl"
-RESTRICT="strip"
-S=${WORKDIR}
-
DEPEND=""
RDEPEND=">=app-emulation/emul-linux-x86-baselibs-10.0
x11-libs/libX11
opengl? ( app-admin/eselect-opengl )"
-pkg_setup() {
- einfo "Note: You can safely ignore the 'trailing garbage after EOF'"
- einfo " warnings below"
-}
-
-src_unpack() {
- unpack ${A}
-
- # we only want the libs
- ALLOWED="${S}/etc/env.d"
- find ${S} ! -type d ! -name '*.so*' | grep -v "${ALLOWED}" | xargs rm -f
-}
-
-src_install() {
- for dir in etc/env.d etc/revdep-rebuild ; do
- if [[ -d ${S}/${dir} ]] ; then
- for f in ${S}/${dir}/* ; do
- mv -f $f{,-emul}
- done
- fi
- done
-
- # remove void directories or portage will show weird output
- find ${S} -type d -depth | xargs rmdir 2&>/dev/null
-
- cp -a "${WORKDIR}"/* "${D}"/ || die "copying files failed!"
-}
-
pkg_postinst() {
#update GL symlinks
use opengl && eselect opengl set --use-old