summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-08-31 18:45:51 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-08-31 18:45:51 +0000
commit391fab6a37f810a9c7a93fd972c3f7807a920da2 (patch)
tree975ccf9114aa6b59243114de6b89be21b8053b24 /app-emulation
parentmedia-gfx/gimp: Update live ebuild (diff)
downloadgentoo-2-391fab6a37f810a9c7a93fd972c3f7807a920da2.tar.gz
gentoo-2-391fab6a37f810a9c7a93fd972c3f7807a920da2.tar.bz2
gentoo-2-391fab6a37f810a9c7a93fd972c3f7807a920da2.zip
[app-emulation/xen] Drop old version
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen/ChangeLog5
-rw-r--r--app-emulation/xen/xen-4.1.0.ebuild103
2 files changed, 4 insertions, 104 deletions
diff --git a/app-emulation/xen/ChangeLog b/app-emulation/xen/ChangeLog
index f16a2d61b251..2dab1c894683 100644
--- a/app-emulation/xen/ChangeLog
+++ b/app-emulation/xen/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/xen
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.77 2011/08/09 17:27:29 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.78 2011/08/31 18:45:51 alexxy Exp $
+
+ 31 Aug 2011; Alexey Shvetsov <alexxy@gentoo.org> -xen-4.1.0.ebuild:
+ Drop old version
09 Aug 2011; Alexey Shvetsov <alexxy@gentoo.org> xen-9999.ebuild:
Sync 9999 and 4.1.1
diff --git a/app-emulation/xen/xen-4.1.0.ebuild b/app-emulation/xen/xen-4.1.0.ebuild
deleted file mode 100644
index 55ac9912e4dd..000000000000
--- a/app-emulation/xen/xen-4.1.0.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-4.1.0.ebuild,v 1.2 2011/03/26 19:18:35 alexxy Exp $
-
-EAPI="3"
-
-inherit mount-boot flag-o-matic toolchain-funcs
-
-DESCRIPTION="The Xen virtual machine monitor"
-HOMEPAGE="http://xen.org/"
-SRC_URI="http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug custom-cflags pae acm flask xsm"
-
-RDEPEND="|| ( sys-boot/grub
- sys-boot/grub-static )"
-PDEPEND="~app-emulation/xen-tools-${PV}"
-
-RESTRICT="test"
-
-# Approved by QA team in bug #144032
-QA_WX_LOAD="boot/xen-syms-${PV}"
-
-pkg_setup() {
- if [[ -z ${XEN_TARGET_ARCH} ]]; then
- if use x86 && use amd64; then
- die "Confusion! Both x86 and amd64 are set in your use flags!"
- elif use x86; then
- export XEN_TARGET_ARCH="x86_32"
- elif use amd64; then
- export XEN_TARGET_ARCH="x86_64"
- else
- die "Unsupported architecture!"
- fi
- fi
-
- if use xsm ; then
- export "XSM_ENABLE=y"
- use acm && export "ACM_SECURITY=y"
- if use flask ; then
- ! use acm && export "FLASK_ENABLE=y"
- use acm && ewarn "Both acm and flask XSM specified, defaulting to acm."
- fi
- elif use acm || use flask ; then
- ewarn "acm and flask require USE=xsm to be set, dropping use flags"
- fi
-}
-
-src_prepare() {
- # Drop .config
- sed -e '/-include $(XEN_ROOT)\/.config/d' -i Config.mk || die "Couldn't drop"
- # if the user *really* wants to use their own custom-cflags, let them
- if use custom-cflags; then
- einfo "User wants their own CFLAGS - removing defaults"
- # try and remove all the default custom-cflags
- find "${S}" -name Makefile -o -name Rules.mk -o -name Config.mk -exec sed \
- -e 's/CFLAGS\(.*\)=\(.*\)-O3\(.*\)/CFLAGS\1=\2\3/' \
- -e 's/CFLAGS\(.*\)=\(.*\)-march=i686\(.*\)/CFLAGS\1=\2\3/' \
- -e 's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
- -e 's/CFLAGS\(.*\)=\(.*\)-g3*\s\(.*\)/CFLAGS\1=\2 \3/' \
- -e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
- -i {} \;
- fi
-}
-
-src_configure() {
- use debug && myopt="${myopt} debug=y"
- use pae && myopt="${myopt} pae=y"
-
- if use custom-cflags; then
- filter-flags -fPIE -fstack-protector
- replace-flags -O3 -O2
- else
- unset CFLAGS
- fi
-}
-
-src_compile() {
- # Send raw LDFLAGS so that --as-needed works
- emake CC="$(tc-getCC)" LDFLAGS="$(raw-ldflags)" -C xen ${myopt} || die "compile failed"
-}
-
-src_install() {
- local myopt
- use debug && myopt="${myopt} debug=y"
- use pae && myopt="${myopt} pae=y"
-
- emake LDFLAGS="$(raw-ldflags)" DESTDIR="${D}" -C xen ${myopt} install || die "install failed"
-}
-
-pkg_postinst() {
- elog "Official Xen Guide and the unoffical wiki page:"
- elog " http://www.gentoo.org/doc/en/xen-guide.xml"
- elog " http://en.gentoo-wiki.com/wiki/Xen/"
-
- if use pae; then
- echo
- ewarn "This is a PAE build of Xen. It will *only* boot PAE kernels!"
- fi
-}