summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2011-04-27 11:33:19 +0000
committerTiziano Müller <dev-zero@gentoo.org>2011-04-27 11:33:19 +0000
commit36a235fe47f136276b01e6013e06bdd4e4365003 (patch)
tree165d05ccf6c42cba3d2b129505157da4ebff5a57 /app-emulation
parentVersion bump. (diff)
downloadgentoo-2-36a235fe47f136276b01e6013e06bdd4e4365003.tar.gz
gentoo-2-36a235fe47f136276b01e6013e06bdd4e4365003.tar.bz2
gentoo-2-36a235fe47f136276b01e6013e06bdd4e4365003.zip
Added patch (from upstream) to add missing include and thus fix compilation with spice-gtk.
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/spice-protocol/ChangeLog10
-rw-r--r--app-emulation/spice-protocol/files/2ffbca210033be262fc75e6a73742e0f0e6d5242.patch21
-rw-r--r--app-emulation/spice-protocol/spice-protocol-0.8.0-r1.ebuild23
3 files changed, 53 insertions, 1 deletions
diff --git a/app-emulation/spice-protocol/ChangeLog b/app-emulation/spice-protocol/ChangeLog
index a8ab3075b919..1bce5ab4677d 100644
--- a/app-emulation/spice-protocol/ChangeLog
+++ b/app-emulation/spice-protocol/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/spice-protocol
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice-protocol/ChangeLog,v 1.6 2011/04/18 07:57:43 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice-protocol/ChangeLog,v 1.7 2011/04/27 11:33:19 dev-zero Exp $
+
+*spice-protocol-0.8.0-r1 (27 Apr 2011)
+
+ 27 Apr 2011; Tiziano Müller <dev-zero@gentoo.org>
+ +files/2ffbca210033be262fc75e6a73742e0f0e6d5242.patch,
+ +spice-protocol-0.8.0-r1.ebuild:
+ Added patch (from upstream) to add missing include and thus fix compilation
+ with spice-gtk.
*spice-protocol-0.8.0 (18 Apr 2011)
diff --git a/app-emulation/spice-protocol/files/2ffbca210033be262fc75e6a73742e0f0e6d5242.patch b/app-emulation/spice-protocol/files/2ffbca210033be262fc75e6a73742e0f0e6d5242.patch
new file mode 100644
index 000000000000..f23a212b3321
--- /dev/null
+++ b/app-emulation/spice-protocol/files/2ffbca210033be262fc75e6a73742e0f0e6d5242.patch
@@ -0,0 +1,21 @@
+From 2ffbca210033be262fc75e6a73742e0f0e6d5242 Mon Sep 17 00:00:00 2001
+From: Marc-André Lureau <marcandre.lureau@redhat.com>
+Date: Mon, 11 Apr 2011 10:44:10 +0000
+Subject: controller: add missing spice/types include
+
+---
+diff --git a/spice/controller_prot.h b/spice/controller_prot.h
+index 38329c5..697baa0 100644
+--- a/spice/controller_prot.h
++++ b/spice/controller_prot.h
+@@ -18,6 +18,8 @@
+ #ifndef _H_CONTROLLER_PROT
+ #define _H_CONTROLLER_PROT
+
++#include <spice/types.h>
++
+ #define CONTROLLER_MAGIC (*(uint32_t*)"CTRL")
+ #define CONTROLLER_VERSION 1
+
+--
+cgit v0.8.3-6-g21f6
diff --git a/app-emulation/spice-protocol/spice-protocol-0.8.0-r1.ebuild b/app-emulation/spice-protocol/spice-protocol-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..7f54dbab493e
--- /dev/null
+++ b/app-emulation/spice-protocol/spice-protocol-0.8.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice-protocol/spice-protocol-0.8.0-r1.ebuild,v 1.1 2011/04/27 11:33:19 dev-zero Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Headers defining the SPICE protocol."
+HOMEPAGE="http://spice-space.org/"
+SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/2ffbca210033be262fc75e6a73742e0f0e6d5242.patch"
+}