summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-12-24 07:35:36 +0000
committerMike Frysinger <vapier@gentoo.org>2012-12-24 07:35:36 +0000
commit358c1f71ba7962a407b8135985f693f37bb995a2 (patch)
tree03adc03ae74b8c8bcfed57cc3dfdf05fb3c111dd /app-emulation
parentVersion bump, lots of ebuild bug fixes (diff)
downloadgentoo-2-358c1f71ba7962a407b8135985f693f37bb995a2.tar.gz
gentoo-2-358c1f71ba7962a407b8135985f693f37bb995a2.tar.bz2
gentoo-2-358c1f71ba7962a407b8135985f693f37bb995a2.zip
Version bump.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/hercules/ChangeLog9
-rw-r--r--app-emulation/hercules/hercules-3.08.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/app-emulation/hercules/ChangeLog b/app-emulation/hercules/ChangeLog
index e99d4ebaddf6..26ea3f46029e 100644
--- a/app-emulation/hercules/ChangeLog
+++ b/app-emulation/hercules/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/hercules
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/ChangeLog,v 1.33 2010/10/24 15:54:21 ranger Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/ChangeLog,v 1.34 2012/12/24 07:35:36 vapier Exp $
+
+*hercules-3.08 (24 Dec 2012)
+
+ 24 Dec 2012; Mike Frysinger <vapier@gentoo.org> +hercules-3.08.ebuild:
+ Version bump.
24 Oct 2010; Brent Baude <ranger@gentoo.org> hercules-3.06.ebuild:
stable ppc, bug 335186
diff --git a/app-emulation/hercules/hercules-3.08.ebuild b/app-emulation/hercules/hercules-3.08.ebuild
new file mode 100644
index 000000000000..b7fa11c1a4e3
--- /dev/null
+++ b/app-emulation/hercules/hercules-3.08.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/hercules-3.08.ebuild,v 1.1 2012/12/24 07:35:36 vapier Exp $
+
+EAPI="4"
+
+inherit flag-o-matic
+
+DESCRIPTION="Hercules System/370, ESA/390 and zArchitecture Mainframe Emulator"
+HOMEPAGE="http://www.hercules-390.eu/"
+SRC_URI="http://downloads.hercules-390.eu/${P}.tar.gz"
+
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="bzip2 custom-cflags +suid"
+
+RDEPEND="bzip2? ( app-arch/bzip2 )
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ use custom-cflags || strip-flags
+ ac_cv_lib_bz2_BZ2_bzBuffToBuffDecompress=$(usex bzip2) \
+ econf \
+ $(use_enable bzip2 cckd-bzip2) \
+ $(use_enable bzip2 het-bzip2) \
+ $(use_enable suid setuid-hercifc) \
+ --enable-custom="Gentoo ${PF}.ebuild" \
+ --disable-optimization
+}
+
+src_install() {
+ default
+ insinto /usr/share/hercules
+ doins hercules.cnf
+ dodoc README.* RELEASE.NOTES
+ dohtml -r html
+}