summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-01-06 09:21:36 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-01-06 09:21:36 +0000
commit299dcc799d1ff1542150b2c5d40d3a8c075467e8 (patch)
tree4a9dcc858d9ae5850c095303d28fe7e66eb63f1d /app-emulation
parentmanual install; better X use support; use sed -i; skip test since it needs in... (diff)
downloadgentoo-2-299dcc799d1ff1542150b2c5d40d3a8c075467e8.tar.gz
gentoo-2-299dcc799d1ff1542150b2c5d40d3a8c075467e8.tar.bz2
gentoo-2-299dcc799d1ff1542150b2c5d40d3a8c075467e8.zip
manual install; better X use support; use sed -i; skip test since it needs installed files to work; use mirror://gentoo since the archive isn't versioned upstream.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/spim/ChangeLog7
-rw-r--r--app-emulation/spim/Manifest4
-rw-r--r--app-emulation/spim/files/digest-spim-6.52
-rw-r--r--app-emulation/spim/spim-6.5.ebuild63
4 files changed, 36 insertions, 40 deletions
diff --git a/app-emulation/spim/ChangeLog b/app-emulation/spim/ChangeLog
index e20b848a4c25..05ddc73ebada 100644
--- a/app-emulation/spim/ChangeLog
+++ b/app-emulation/spim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/spim
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spim/ChangeLog,v 1.5 2003/10/18 21:10:33 brandy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spim/ChangeLog,v 1.6 2004/01/06 09:21:29 mr_bones_ Exp $
+
+ 06 Jan 2004; Michael Sterrett <mr_bones_@gentoo.org> spim-6.5.ebuild:
+ manual install; better X use support; use sed -i; skip test since it needs
+ installed files to work; use mirror://gentoo since the archive isn't
+ versioned upstream.
19 Oct 2003; Brandy Westcott brandy@gentoo.org spim-6.5.ebuild:
Fixed typo in ebuild
diff --git a/app-emulation/spim/Manifest b/app-emulation/spim/Manifest
index 0294fd373e6b..f9561f3ab76e 100644
--- a/app-emulation/spim/Manifest
+++ b/app-emulation/spim/Manifest
@@ -1,3 +1,3 @@
-MD5 24df936068cedad3fb126ecf49c079a4 ChangeLog 799
-MD5 58d417a6a6a8617330456fa897be3e8e spim-6.5.ebuild 1329
+MD5 864218613c462a3b406ea14235810b50 ChangeLog 1045
+MD5 3260098f230fdc5df15866e2eb311509 spim-6.5.ebuild 1359
MD5 3962179c22e4349945b01edbadfac9a5 files/digest-spim-6.5 60
diff --git a/app-emulation/spim/files/digest-spim-6.5 b/app-emulation/spim/files/digest-spim-6.5
index 0a898f37eaea..97d43cc2f924 100644
--- a/app-emulation/spim/files/digest-spim-6.5
+++ b/app-emulation/spim/files/digest-spim-6.5
@@ -1 +1 @@
-MD5 be9cf6ff2798e507736d05eb5c70914f spim.tar.gz 444075
+MD5 be9cf6ff2798e507736d05eb5c70914f spim-6.5.tar.gz 444075
diff --git a/app-emulation/spim/spim-6.5.ebuild b/app-emulation/spim/spim-6.5.ebuild
index 79f3b1e4e202..02990cd4aac7 100644
--- a/app-emulation/spim/spim-6.5.ebuild
+++ b/app-emulation/spim/spim-6.5.ebuild
@@ -1,56 +1,47 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spim/spim-6.5.ebuild,v 1.5 2003/10/18 21:10:33 brandy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spim/spim-6.5.ebuild,v 1.6 2004/01/06 09:21:29 mr_bones_ Exp $
-IUSE="X"
-
-HOMEPAGE="http://www.cs.wisc.edu/~larus/spim.html"
-SRC_URI="http://www.cs.wisc.edu/~larus/SPIM/spim.tar.gz"
DESCRIPTION="MIPS Simulator"
-SLOT="0"
+HOMEPAGE="http://www.cs.wisc.edu/~larus/spim.html"
+# No version upstream
+#SRC_URI="http://www.cs.wisc.edu/~larus/SPIM/spim.tar.gz"
+SRC_URI="mirror://gentoo//${P}.tar.gz"
+
KEYWORDS="x86"
LICENSE="as-is"
-S=${WORKDIR}/${P}
+SLOT="0"
+
+DEPEND="X? ( virtual/x11 )
+ >=sys-apps/sed-4"
+
+IUSE="X"
src_compile() {
- pwd -P
./Configure || die "Configure script failed"
- sed -e "s:\(BIN_DIR = \).*$:\1/usr/bin:" \
+ sed -i \
+ -e 's/@make/@$(MAKE)/' \
+ -e "s:\(BIN_DIR = \).*$:\1/usr/bin:" \
-e "s:\(MAN_DIR = \).*$:\1/usr/share/bin:" \
- -e "s:\(TRAP_DIR = \).*$:\1/usr/sbin:" \
- Makefile > Makefile.comp
- cp Makefile.comp Makefile
+ -e "s:\(TRAP_DIR = \).*$:\1/usr/sbin:" Makefile \
+ || die "sed Makefile failed"
einfo "Making console spim"
emake spim || die "make spim failed"
if [ `use X` ]; then
einfo "Making xspim"
- emake xspim || die "make xspim failed"
- else
- sed -e "/install:: xspim/,+4d" \
- Makefile > Makefile.nox
- cp Makefile.nox Makefile
+ emake xspim || die "emake xspim failed"
fi
}
src_install() {
- sed -e "s:\(BIN_DIR = \).*$:\1${D}usr/bin:" \
- -e "s:\(MAN_DIR = \).*$:\1${D}usr/share/bin:" \
- -e "s:\(TRAP_DIR = \).*$:\1${D}usr/sbin:" \
- Makefile > Makefile.inst
- cp Makefile.inst Makefile
-
- dodir /usr/sbin
-
- dodoc BLURB README VERSION CangeLog Documentation/*
-
- make install || die "Install failed"
-}
-
-pkg_postinst() {
- cd ${S}
- cp Makefile.comp Makefile
- make test || die "Test failed"
-
+ dobin spim || die "dobin failed"
+ newman spim.man spim.1 || die "newman failed (spim)"
+ if [ `use X` ]; then
+ dobin xspim || die "dobin failed"
+ newman xspim.man xspim.1 || die "newman failed (xspim)"
+ fi
+ dosbin trap.handler || die "dosbin failed"
+ dodoc BLURB README VERSION ChangeLog Documentation/* || die "dodoc failed"
}