summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-04-30 20:24:54 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-04-30 20:24:54 +0000
commit23e80a53e2dd964c156a74f193852d654a8fa28c (patch)
tree1f99dde4b845d26df3f404f446985781da6a5c4b /app-emulation
parentold (diff)
downloadgentoo-2-23e80a53e2dd964c156a74f193852d654a8fa28c.tar.gz
gentoo-2-23e80a53e2dd964c156a74f193852d654a8fa28c.tar.bz2
gentoo-2-23e80a53e2dd964c156a74f193852d654a8fa28c.zip
Version bump
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt-glib/ChangeLog7
-rw-r--r--app-emulation/libvirt-glib/libvirt-glib-0.0.8.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/app-emulation/libvirt-glib/ChangeLog b/app-emulation/libvirt-glib/ChangeLog
index 5ac0ddd430d8..9a5a445db972 100644
--- a/app-emulation/libvirt-glib/ChangeLog
+++ b/app-emulation/libvirt-glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/libvirt-glib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/ChangeLog,v 1.10 2012/04/02 07:22:26 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/ChangeLog,v 1.11 2012/04/30 20:24:54 cardoe Exp $
+
+*libvirt-glib-0.0.8 (30 Apr 2012)
+
+ 30 Apr 2012; Doug Goldstein <cardoe@gentoo.org> +libvirt-glib-0.0.8.ebuild:
+ Version bump
*libvirt-glib-0.0.7 (02 Apr 2012)
diff --git a/app-emulation/libvirt-glib/libvirt-glib-0.0.8.ebuild b/app-emulation/libvirt-glib/libvirt-glib-0.0.8.ebuild
new file mode 100644
index 000000000000..e0c0ae571a42
--- /dev/null
+++ b/app-emulation/libvirt-glib/libvirt-glib-0.0.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt-glib/libvirt-glib-0.0.8.ebuild,v 1.1 2012/04/30 20:24:54 cardoe Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 python
+
+DESCRIPTION="GLib and GObject mappings for libvirt"
+HOMEPAGE="http://libvirt.org/git/?p=libvirt-glib.git"
+SRC_URI="ftp://libvirt.org/libvirt/glib/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +introspection python +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ >=app-emulation/libvirt-0.9.10
+ >=dev-libs/glib-2.10:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.10 )
+ vala? ( dev-lang/vala:0.14 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ G2CONF="--disable-test-coverage
+ VAPIGEN=$(type -P vapigen-0.14)
+ $(use_enable introspection)
+ $(use_enable vala)
+ $(use_with python)"
+
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_compile() {
+ emake -j1
+}
+