summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-06-20 20:29:21 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-06-20 20:29:21 +0000
commit129e2916890b89686ee76ce94ee91cdbddc01ae8 (patch)
treebe068bcd51e72ae7fafaa88f8102e14baa3dfc46 /app-emulation
parentalpha/arm/ia64/s390/sh/sparc stable wrt #323529 (diff)
downloadgentoo-2-129e2916890b89686ee76ce94ee91cdbddc01ae8.tar.gz
gentoo-2-129e2916890b89686ee76ce94ee91cdbddc01ae8.tar.bz2
gentoo-2-129e2916890b89686ee76ce94ee91cdbddc01ae8.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/lxc/ChangeLog7
-rw-r--r--app-emulation/lxc/lxc-0.7.0.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/app-emulation/lxc/ChangeLog b/app-emulation/lxc/ChangeLog
index e295fa5449db..4c88baa09876 100644
--- a/app-emulation/lxc/ChangeLog
+++ b/app-emulation/lxc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/lxc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/ChangeLog,v 1.11 2010/03/16 16:40:03 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/ChangeLog,v 1.12 2010/06/20 20:29:21 flameeyes Exp $
+
+*lxc-0.7.0 (20 Jun 2010)
+
+ 20 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org> +lxc-0.7.0.ebuild:
+ Version bump.
16 Mar 2010; Diego E. Pettenò <flameeyes@gentoo.org> lxc-0.6.5.ebuild:
Avoid testing for file capabilities support: we don't support the setcap
diff --git a/app-emulation/lxc/lxc-0.7.0.ebuild b/app-emulation/lxc/lxc-0.7.0.ebuild
new file mode 100644
index 000000000000..b6af9ce99ce9
--- /dev/null
+++ b/app-emulation/lxc/lxc-0.7.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/lxc/lxc-0.7.0.ebuild,v 1.1 2010/06/20 20:29:21 flameeyes Exp $
+
+EAPI="2"
+
+inherit eutils linux-info versionator base
+
+DESCRIPTION="LinuX Containers userspace utilities"
+HOMEPAGE="http://lxc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="doc examples"
+
+RDEPEND="sys-libs/libcap"
+
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook-sgml-utils )
+ >=sys-kernel/linux-headers-2.6.29"
+
+CONFIG_CHECK="~CGROUPS
+ ~CGROUP_NS ~CPUSETS ~CGROUP_CPUACCT
+ ~RESOURCE_COUNTERS ~CGROUP_MEM_RES_CTLR
+ ~CGROUP_SCHED
+
+ ~NAMESPACES
+ ~IPC_NS ~USER_NS ~PID_NS
+
+ ~DEVPTS_MULTIPLE_INSTANCES
+ ~CGROUP_FREEZER
+ ~UTS_NS ~NET_NS
+ ~VETH ~MACVLAN"
+
+ERROR_DEVPTS_MULTIPLE_INSTANCES="CONFIG_DEVPTS_MULTIPLE_INSTANCES: needed for pts inside container"
+
+ERROR_CGROUP_FREEZER="CONFIG_CGROUP_FREEZER: needed to freeze containers"
+
+ERROR_UTS_NS="CONFIG_UTS_NS: needed to unshare hostnames and uname info"
+ERROR_NET_NS="CONFIG_NET_NS: needed for unshared network"
+
+ERROR_VETH="CONFIG_VETH: needed for internal (inter-container) networking"
+ERROR_MACVLAN="CONFIG_MACVLAN: needed for internal (inter-container) networking"
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --bindir=/usr/sbin \
+ --docdir=/usr/share/doc/${PF} \
+ --with-config-path=/etc/lxc \
+ $(use_enable doc) \
+ $(use_enable examples) \
+ || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc AUTHORS CONTRIBUTING MAINTAINERS \
+ NEWS TODO README doc/FAQ.txt || die "dodoc failed"
+
+ # If the documentation is going to be rebuilt, the Makefiles will
+ # install the man pages themselves; if we're not going to, we
+ # still need to install them, as they are provided with the
+ # tarball in recent versions.
+ if ! use doc; then
+ doman doc/*.{1,5,7} || die
+ fi
+
+ rm -r "${D}"/usr/sbin/lxc-{setcap,ls} \
+ "${D}"/usr/share/man/man1/lxc-ls.1 \
+ || die "unable to remove extraenous content"
+
+ keepdir /etc/lxc
+
+ find "${D}" -name '*.la' -delete
+}