summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2011-09-01 13:55:10 +0000
committerVlastimil Babka <caster@gentoo.org>2011-09-01 13:55:10 +0000
commit0c431631a145e6a47a003cfcd51cff3280ce690c (patch)
tree192c39c6477e665b3cd3b423b061db9c1f0ac416 /app-emulation
parentChange version scheme (diff)
downloadgentoo-2-0c431631a145e6a47a003cfcd51cff3280ce690c.tar.gz
gentoo-2-0c431631a145e6a47a003cfcd51cff3280ce690c.tar.bz2
gentoo-2-0c431631a145e6a47a003cfcd51cff3280ce690c.zip
Version bump. Due to DLJ bundles no longer provided by Oracle, the package changes license to Oracle-BCLA-JavaSE and is fetch restricted again.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/emul-linux-x86-java/ChangeLog10
-rw-r--r--app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.24.ebuild112
-rw-r--r--app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.27.ebuild (renamed from app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.25.ebuild)36
3 files changed, 31 insertions, 127 deletions
diff --git a/app-emulation/emul-linux-x86-java/ChangeLog b/app-emulation/emul-linux-x86-java/ChangeLog
index 978675702056..a27ccce7dd44 100644
--- a/app-emulation/emul-linux-x86-java/ChangeLog
+++ b/app-emulation/emul-linux-x86-java/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/emul-linux-x86-java
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/ChangeLog,v 1.103 2011/06/18 11:50:01 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/ChangeLog,v 1.104 2011/09/01 13:55:10 caster Exp $
+
+*emul-linux-x86-java-1.6.0.27 (01 Sep 2011)
+
+ 01 Sep 2011; Vlastimil Babka <caster@gentoo.org>
+ -emul-linux-x86-java-1.6.0.24.ebuild, -emul-linux-x86-java-1.6.0.25.ebuild,
+ +emul-linux-x86-java-1.6.0.27.ebuild:
+ Version bump. Due to DLJ bundles no longer provided by Oracle, the package
+ changes license to Oracle-BCLA-JavaSE and is fetch restricted again.
18 Jun 2011; Markos Chandras <hwoarang@gentoo.org>
emul-linux-x86-java-1.6.0.26.ebuild:
diff --git a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.24.ebuild b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.24.ebuild
deleted file mode 100644
index 9200122bdaac..000000000000
--- a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.24.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.24.ebuild,v 1.3 2011/05/21 04:28:05 ssuominen Exp $
-
-inherit versionator pax-utils java-vm-2 eutils
-
-UPDATE="$(get_version_component_range 4)"
-UPDATE="${UPDATE#0}"
-MY_PV="$(get_version_component_range 2)u${UPDATE}"
-
-At="jdk-${MY_PV}-dlj-linux-i586.bin"
-DESCRIPTION="Sun's Java SE Runtime Environment (32bit)"
-HOMEPAGE="http://java.sun.com/javase/6/"
-#SRC_URI="http://download.java.net/dlj/binaries/${At}"
-SRC_URI="http://dlc.sun.com/dlj/binaries/${At}"
-
-SLOT="1.6"
-LICENSE="dlj-1.1"
-KEYWORDS="-* amd64"
-RESTRICT="strip"
-IUSE="X alsa nsplugin"
-
-JAVA_VM_NO_GENERATION1=true
-
-RDEPEND="alsa? ( app-emulation/emul-linux-x86-soundlibs )
- X? ( app-emulation/emul-linux-x86-xlibs )"
-
-JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
-
-QA_TEXTRELS_amd64="opt/${P}/lib/i386/motif21/libmawt.so
- opt/${P}/lib/i386/libdeploy.so
- opt/${P}/lib/i386/client/libjvm.so
- opt/${P}/lib/i386/server/libjvm.so"
-QA_DT_HASH="opt/${P}/.*"
-
-src_unpack() {
- mkdir bundled-jdk
- cd bundled-jdk
- sh "${DISTDIR}"/${At} --accept-license --unpack || die "Failed to unpack"
-
- cd ..
- bash "${FILESDIR}"/construct-${SLOT}.sh bundled-jdk sun-jdk-${PV} ${P} || die "construct-${SLOT}.sh failed"
-}
-
-src_compile() {
- # Set PaX markings on all JDK/JRE executables to allow code-generation on
- # the heap by the JIT compiler. This has to be done before CDS - #215225
- pax-mark m $(list-paxables "${S}"/bin/*)
-
- # see bug #207282
- einfo "Creating the Class Data Sharing archives"
- "${S}"/bin/java -client -Xshare:dump || die
- "${S}"/bin/java -server -Xshare:dump || die
-}
-
-src_install() {
- local dirs="bin lib man javaws plugin"
- dodir /opt/${P}
-
- cp -pPR ${dirs} "${D}/opt/${P}/" || die "failed to copy"
-
- dodoc README THIRDPARTYLICENSEREADME.txt || die
- dohtml Welcome.html || die
- dodir /opt/${P}/share/
-
- if use nsplugin; then
- local plugin_dir="ns7-gcc29"
- if has_version '>=sys-devel/gcc-3' ; then
- plugin_dir="ns7"
- fi
-
- install_mozilla_plugin /opt/${P}/lib/i386/libnpjp2.so
- install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so old_oji
- fi
-
- # FIXME figure out how to handle the control pannel conflict with
- # sun-jdk-bin
-
- # install control panel for Gnome/KDE
-# sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
-# -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
-# ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
-# ${T}/sun_java-${SLOT}.desktop
-
-# domenu ${T}/sun_java-${SLOT}.desktop
-
- set_java_env
- java-vm_revdep-mask
-}
-
-pkg_postinst() {
- # Set as default VM if none exists
- java-vm-2_pkg_postinst
-
- elog
- elog "Two variants of the nsplugin are available via eselect java-nsplugin."
- elog "Note that starting with ${PN}-1.6.0.19 their naming and the default changed,"
- elog "users with the old plugin set are switched to the new default automatically."
- elog "The default ${VMHANDLE} is the new 'plugin2' which works in Firefox 3 (xulrunner-1.9)"
- elog "and newer, the ${VMHANDLE}-old_oji is the old plugin using the OJI API"
- elog "that was removed in Firefox 3.6 (xulrunner-1.9.2)."
- elog "For more info see https://jdk6.dev.java.net/plugin2/"
- elog
-
- if ! use X; then
- local xwarn="X11 libraries and/or"
- fi
-
- echo
- ewarn "Some parts of Sun's JDK require ${xwarn} net-print/cups or net-print/lprng to be installed."
- ewarn "Be careful which Java libraries you attempt to use."
-}
diff --git a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.25.ebuild b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.27.ebuild
index d6a12d2a40fa..1d349e9c6e05 100644
--- a/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.25.ebuild
+++ b/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.27.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.25.ebuild,v 1.2 2011/05/21 04:28:05 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-java/emul-linux-x86-java-1.6.0.27.ebuild,v 1.1 2011/09/01 13:55:10 caster Exp $
inherit versionator pax-utils java-vm-2 eutils
@@ -8,16 +8,17 @@ UPDATE="$(get_version_component_range 4)"
UPDATE="${UPDATE#0}"
MY_PV="$(get_version_component_range 2)u${UPDATE}"
-At="jdk-${MY_PV}-dlj-linux-i586.bin"
-DESCRIPTION="Sun's Java SE Runtime Environment (32bit)"
-HOMEPAGE="http://java.sun.com/javase/6/"
-#SRC_URI="http://download.java.net/dlj/binaries/${At}"
-SRC_URI="http://dlc.sun.com/dlj/binaries/${At}"
+DOWNLOAD_LINK="http://www.oracle.com/technetwork/java/javase/downloads/jre-${MY_PV}-download-440425.html"
+X86_AT="jre-${MY_PV}-linux-i586.bin"
+
+DESCRIPTION="Oracle (formerly Sun) Java SE Runtime Environment (32bit)"
+HOMEPAGE="http://www.oracle.com/technetwork/java/javase/overview/index-jsp-136246.html"
+SRC_URI="${X86_AT}"
SLOT="1.6"
-LICENSE="dlj-1.1"
+LICENSE="Oracle-BCLA-JavaSE"
KEYWORDS="-* ~amd64"
-RESTRICT="strip"
+RESTRICT="fetch strip"
IUSE="X alsa nsplugin"
JAVA_VM_NO_GENERATION1=true
@@ -33,15 +34,22 @@ QA_TEXTRELS_amd64="opt/${P}/lib/i386/motif21/libmawt.so
opt/${P}/lib/i386/server/libjvm.so"
QA_DT_HASH="opt/${P}/.*"
-src_unpack() {
- mkdir bundled-jdk
- cd bundled-jdk
- sh "${DISTDIR}"/${At} --accept-license --unpack || die "Failed to unpack"
+S="${WORKDIR}/jre$(replace_version_separator 3 _)"
+
+pkg_nofetch() {
+
+ einfo "Due to Oracle no longer providing the distro-friendly DLJ bundles, the package has become fetch restricted again."
- cd ..
- bash "${FILESDIR}"/construct-${SLOT}.sh bundled-jdk sun-jdk-${PV} ${P} || die "construct-${SLOT}.sh failed"
+ einfo "Please download ${X86_AT} from:"
+ einfo "${DOWNLOAD_LINK}"
+ einfo "and move it to ${DISTDIR}"
}
+src_unpack() {
+ sh "${DISTDIR}"/${A} -noregister || die "Failed to unpack"
+}
+
+
src_compile() {
# Set PaX markings on all JDK/JRE executables to allow code-generation on
# the heap by the JIT compiler. This has to be done before CDS - #215225