summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-07-30 13:22:46 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-07-30 13:22:46 +0000
commit0b1106a4afd8ffefa39d875e8b67dbc714143c45 (patch)
tree127a32ad245c23b66b50ff5a905a73815762de99 /app-emulation
parentDrop pre EAPI=4 version wrt bug #478576 (diff)
downloadgentoo-2-0b1106a4afd8ffefa39d875e8b67dbc714143c45.tar.gz
gentoo-2-0b1106a4afd8ffefa39d875e8b67dbc714143c45.tar.bz2
gentoo-2-0b1106a4afd8ffefa39d875e8b67dbc714143c45.zip
Update live ebuild to latest iteration of the ebuild
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt/ChangeLog5
-rw-r--r--app-emulation/libvirt/libvirt-9999.ebuild50
2 files changed, 28 insertions, 27 deletions
diff --git a/app-emulation/libvirt/ChangeLog b/app-emulation/libvirt/ChangeLog
index d0f1de4fab2c..ebd36dc7b538 100644
--- a/app-emulation/libvirt/ChangeLog
+++ b/app-emulation/libvirt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/libvirt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.299 2013/07/30 13:17:51 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.300 2013/07/30 13:22:46 cardoe Exp $
+
+ 30 Jul 2013; Doug Goldstein <cardoe@gentoo.org> libvirt-9999.ebuild:
+ Update live ebuild to latest iteration of the ebuild
*libvirt-1.1.1 (30 Jul 2013)
diff --git a/app-emulation/libvirt/libvirt-9999.ebuild b/app-emulation/libvirt/libvirt-9999.ebuild
index e294228e2d60..fa6dfd4af5be 100644
--- a/app-emulation/libvirt/libvirt-9999.ebuild
+++ b/app-emulation/libvirt/libvirt-9999.ebuild
@@ -1,19 +1,17 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-9999.ebuild,v 1.49 2013/06/09 22:42:04 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-9999.ebuild,v 1.50 2013/07/30 13:22:46 cardoe Exp $
EAPI=5
-#BACKPORTS=9bf6bec4
+#BACKPORTS=cafcec2f
AUTOTOOLIZE=yes
MY_P="${P/_rc/-rc}"
-PYTHON_DEPEND="python? 2:2.5"
-#RESTRICT_PYTHON_ABIS="3.*"
-#SUPPORT_PYTHON_ABIS="1"
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
-inherit eutils python user autotools linux-info
+inherit eutils python-single-r1 user autotools linux-info systemd
if [[ ${PV} = *9999* ]]; then
inherit git-2
@@ -34,9 +32,10 @@ DESCRIPTION="C toolkit to manipulate virtual machines"
HOMEPAGE="http://www.libvirt.org/"
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="audit avahi +caps firewalld fuse iscsi +libvirtd lvm +lxc +macvtap nfs \
- nls numa openvz parted pcap phyp policykit python qemu rbd sasl \
- selinux +udev uml +vepa virtualbox virt-network xen elibc_glibc"
+IUSE="audit avahi +caps firewalld fuse iscsi +libvirtd lvm lxc +macvtap nfs \
+ nls numa openvz parted pcap phyp policykit python +qemu rbd sasl \
+ selinux +udev uml +vepa virtualbox virt-network xen elibc_glibc \
+ systemd"
REQUIRED_USE="libvirtd? ( || ( lxc openvz qemu uml virtualbox xen ) )
lxc? ( caps libvirtd )
openvz? ( libvirtd )
@@ -46,7 +45,8 @@ REQUIRED_USE="libvirtd? ( || ( lxc openvz qemu uml virtualbox xen ) )
virtualbox? ( libvirtd )
xen? ( libvirtd )
virt-network? ( libvirtd )
- firewalld? ( virt-network )"
+ firewalld? ( virt-network )
+ python? ( ${PYTHON_REQUIRED_USE} )"
# gettext.sh command is used by the libvirt command wrappers, and it's
# non-optional, so put it into RDEPEND.
@@ -85,6 +85,7 @@ RDEPEND="sys-libs/readline
)
pcap? ( >=net-libs/libpcap-1.0.0 )
policykit? ( >=sys-auth/polkit-0.9 )
+ python? ( ${PYTHON_DEPS} )
qemu? (
>=app-emulation/qemu-0.13.0
dev-libs/yajl
@@ -108,8 +109,8 @@ RDEPEND="sys-libs/readline
DEPEND="${RDEPEND}
virtual/pkgconfig
app-text/xhtml1
- dev-libs/libxslt
- =dev-lang/python-2*"
+ dev-lang/perl
+ dev-libs/libxslt"
LXC_CONFIG_CHECK="
~CGROUPS
@@ -151,9 +152,6 @@ VIRTNET_CONFIG_CHECK="
MACVTAP_CONFIG_CHECK="~MACVTAP"
pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-
enewgroup qemu 77
enewuser qemu 77 -1 -1 qemu kvm
@@ -165,11 +163,11 @@ pkg_setup() {
gpasswd -a qemu kvm
fi
+ python-single-r1_pkg_setup
+
# Handle specific kernel versions for different features
- kernel_is lt 3 5 && LXC_CONFIG_CHECK+=" ~USER_NS"
kernel_is lt 3 6 && LXC_CONFIG_CHECK+=" ~CGROUP_MEM_RES_CTLR"
kernel_is ge 3 6 && LXC_CONFIG_CHECK+=" ~MEMCG ~MEMCG_SWAP ~MEMCG_KMEM"
- kernel_is ge 3 8 && LXC_CONFIG_CHECK+=" ~USER_NS"
CONFIG_CHECK=""
use fuse && CONFIG_CHECK+=" ~FUSE_FS"
@@ -305,6 +303,9 @@ src_configure() {
# locking support
myconf="${myconf} --without-sanlock"
+ # systemd unit files
+ use systemd && myconf="${myconf} --with-init-script=systemd"
+
# this is a nasty trick to work around the problem in bug
# #275073. The reason why we don't solve this properly is that
# it'll require us to rebuild autotools (and we don't really want
@@ -343,8 +344,9 @@ src_install() {
emake install \
DESTDIR="${D}" \
HTML_DIR=/usr/share/doc/${PF}/html \
- DOCS_DIR=/usr/share/doc/${PF}/python \
- EXAMPLE_DIR=/usr/share/doc/${PF}/python/examples \
+ DOCS_DIR=/usr/share/doc/${PF} \
+ EXAMPLE_DIR=/usr/share/doc/${PF}/examples \
+ SYSTEMD_UNIT_DIR="$(systemd_get_unitdir)" \
|| die "emake install failed"
find "${D}" -name '*.la' -delete || die
@@ -356,6 +358,8 @@ src_install() {
newconfd "${FILESDIR}/libvirtd.confd-r4" libvirtd || die
keepdir /var/lib/libvirt/images
+
+ use python && python_optimize
}
pkg_preinst() {
@@ -371,12 +375,10 @@ pkg_preinst() {
fi
# Only sysctl files ending in .conf work
- mv "${D}"/usr/lib/sysctl.d/libvirtd "${D}"/etc/sysctl.d/libvirtd.conf
+ mv "${D}"/usr/lib/sysctl.d/libvirtd.conf "${D}"/etc/sysctl.d/libvirtd.conf
}
pkg_postinst() {
- use python && python_mod_optimize libvirt.py
-
if [[ -e "${ROOT}"/etc/libvirt/qemu/networks/default.xml ]]; then
touch "${ROOT}"/etc/libvirt/qemu/networks/default.xml
fi
@@ -423,7 +425,3 @@ pkg_postinst() {
elog "Ensure any resources your VMs use are accessible by qemu:qemu"
fi
}
-
-pkg_postrm() {
- use python && python_mod_cleanup libvirt.py
-}