summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhil Bordelon <sunflare@gentoo.org>2002-07-06 18:06:04 +0000
committerPhil Bordelon <sunflare@gentoo.org>2002-07-06 18:06:04 +0000
commit068c2933fc33421f4a1e2c4ae50c6eab2f9e6c3d (patch)
tree51139a805c9beba9c7304b4bfbc77af0f8d301b2 /app-emulation
parentmake -> emake -j1 so that we can hook in ccache and distcc easily (diff)
downloadgentoo-2-068c2933fc33421f4a1e2c4ae50c6eab2f9e6c3d.tar.gz
gentoo-2-068c2933fc33421f4a1e2c4ae50c6eab2f9e6c3d.tar.bz2
gentoo-2-068c2933fc33421f4a1e2c4ae50c6eab2f9e6c3d.zip
Updated ZSNES ebuild to the latest version; lintool'd and repoman'd as well.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/zsnes/ChangeLog10
-rw-r--r--app-emulation/zsnes/files/digest-zsnes-1.351
-rw-r--r--app-emulation/zsnes/zsnes-1.35.ebuild37
3 files changed, 47 insertions, 1 deletions
diff --git a/app-emulation/zsnes/ChangeLog b/app-emulation/zsnes/ChangeLog
index 94faf88d73a6..e25d0e6ff996 100644
--- a/app-emulation/zsnes/ChangeLog
+++ b/app-emulation/zsnes/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/zsnes
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/zsnes/ChangeLog,v 1.4 2002/05/17 14:13:25 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/zsnes/ChangeLog,v 1.5 2002/07/06 18:06:04 sunflare Exp $
+
+*zsnes-1.35 (06 Jun 2002)
+
+ 06 Jun 2002; Phil Bordelon <sunflare@gentoo.org> zsnes-1.35.ebuild :
+
+ Updated to the latest version. Brought the ebuild up to current repoman
+ and lintool specs. The patch in -r2 is no longer needed. The Author in
+ the ebuild was Dan Armak.
*zsnes-1.337-r2 (17 May 2002)
diff --git a/app-emulation/zsnes/files/digest-zsnes-1.35 b/app-emulation/zsnes/files/digest-zsnes-1.35
new file mode 100644
index 000000000000..9fba14488721
--- /dev/null
+++ b/app-emulation/zsnes/files/digest-zsnes-1.35
@@ -0,0 +1 @@
+MD5 669ec6ad2709f2f04e0bd5003c915cb1 zsnes135src.tar.gz 876712
diff --git a/app-emulation/zsnes/zsnes-1.35.ebuild b/app-emulation/zsnes/zsnes-1.35.ebuild
new file mode 100644
index 000000000000..165a2009ceb2
--- /dev/null
+++ b/app-emulation/zsnes/zsnes-1.35.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Don't attempt to introduce $CFLAGS usage, docs say result will be slower.
+
+S=${WORKDIR}/${P}
+DESCRIPTION="ZSNES is an excellent snes (super nintendo) emulator"
+SRC_URI="mirror://sourceforge/zsnes/zsnes135src.tar.gz"
+HOMEPAGE="http://www.zsnes.com/"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+
+RDEPEND="opengl? ( virtual/opengl )
+ virtual/x11
+ >=media-libs/libsdl-1.2.0
+ sys-libs/zlib
+ media-libs/libpng"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/nasm-0.98"
+
+
+src_compile() {
+ patch -p1 < ${FILESDIR}/${P}-gentoo.patch
+ cd ${S}/src
+ use opengl || myconf="--without-opengl"
+ ./configure --prefix=/usr --host=${CHOST} $myconf || die
+ make || die
+}
+src_install () {
+ cd ${S}/src
+ into /usr
+ dobin zsnes
+ doman linux/zsnes.man
+ cd ${S}
+ dodoc *.txt linux/*
+}