summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-11-14 15:52:49 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-11-14 15:52:49 +0000
commit031416959f4732a728c491f130c839a332531b5d (patch)
treee059dd6b62ad9fd81269d27b49b72e5f5d25edee /app-emulation
parentMarked ppc (diff)
downloadgentoo-2-031416959f4732a728c491f130c839a332531b5d.tar.gz
gentoo-2-031416959f4732a728c491f130c839a332531b5d.tar.bz2
gentoo-2-031416959f4732a728c491f130c839a332531b5d.zip
old
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vice/files/1.14-console-security.patch104
-rw-r--r--app-emulation/vice/files/1.14-po-Makefile.patch17
-rw-r--r--app-emulation/vice/files/digest-vice-1.14-r11
-rw-r--r--app-emulation/vice/vice-1.14-r1.ebuild54
4 files changed, 0 insertions, 176 deletions
diff --git a/app-emulation/vice/files/1.14-console-security.patch b/app-emulation/vice/files/1.14-console-security.patch
deleted file mode 100644
index 9a2e42bcd70e..000000000000
--- a/app-emulation/vice/files/1.14-console-security.patch
+++ /dev/null
@@ -1,104 +0,0 @@
-Index: vice/src/arch/beos/uimon.c
-===================================================================
-RCS file: /var/lib/cvs/cbm/vice/src/arch/beos/uimon.c,v
-retrieving revision 1.9
-retrieving revision 1.9.10.1
-diff -u -r1.9 -r1.9.10.1
---- vice/src/arch/beos/uimon.c 18 Mar 2004 19:12:57 -0000 1.9
-+++ vice/src/arch/beos/uimon.c 8 Jun 2004 19:40:56 -0000 1.9.10.1
-@@ -72,7 +72,7 @@
- {
- va_start(ap, format);
- buffer = lib_mvsprintf(format, ap);
-- rc = console_out(console_log, buffer);
-+ rc = console_out(console_log, "%s", buffer);
- lib_free(buffer);
- }
- return rc;
-Index: vice/src/arch/msdos/uimon.c
-===================================================================
-RCS file: /var/lib/cvs/cbm/vice/src/arch/msdos/uimon.c,v
-retrieving revision 1.10
-retrieving revision 1.10.10.1
-diff -u -r1.10 -r1.10.10.1
---- vice/src/arch/msdos/uimon.c 18 Mar 2004 19:12:57 -0000 1.10
-+++ vice/src/arch/msdos/uimon.c 8 Jun 2004 19:41:01 -0000 1.10.10.1
-@@ -70,7 +70,7 @@
- if (console_log) {
- va_start(ap, format);
- buffer = lib_mvsprintf(format, ap);
-- rc = console_out(console_log, buffer);
-+ rc = console_out(console_log, "%s", buffer);
- lib_free(buffer);
- }
- return rc;
-Index: vice/src/arch/riscos/uimon.c
-===================================================================
-RCS file: /var/lib/cvs/cbm/vice/src/arch/riscos/uimon.c,v
-retrieving revision 1.10
-retrieving revision 1.10.10.1
-diff -u -r1.10 -r1.10.10.1
---- vice/src/arch/riscos/uimon.c 18 Mar 2004 19:12:58 -0000 1.10
-+++ vice/src/arch/riscos/uimon.c 8 Jun 2004 19:41:04 -0000 1.10.10.1
-@@ -72,7 +72,7 @@
- {
- va_start(ap, format);
- buffer = lib_mvsprintf(format, ap);
-- rc = console_out(console_log, buffer);
-+ rc = console_out(console_log, "%s", buffer);
- lib_free(buffer);
- }
- return rc;
-Index: vice/src/arch/unix/uimon.c
-===================================================================
-RCS file: /var/lib/cvs/cbm/vice/src/arch/unix/uimon.c,v
-retrieving revision 1.12
-retrieving revision 1.12.4.1
-diff -u -r1.12 -r1.12.4.1
---- vice/src/arch/unix/uimon.c 3 May 2004 06:09:12 -0000 1.12
-+++ vice/src/arch/unix/uimon.c 8 Jun 2004 19:41:09 -0000 1.12.4.1
-@@ -76,7 +76,7 @@
- {
- va_start(ap, format);
- buffer = lib_mvsprintf(format, ap);
-- rc = console_out(console_log, buffer);
-+ rc = console_out(console_log, "%s", buffer);
- lib_free(buffer);
- }
- return rc;
-Index: vice/src/arch/win32/uimon.c
-===================================================================
-RCS file: /var/lib/cvs/cbm/vice/src/arch/win32/uimon.c,v
-retrieving revision 1.36
-retrieving revision 1.36.2.1
-diff -u -r1.36 -r1.36.2.1
---- vice/src/arch/win32/uimon.c 24 May 2004 10:30:02 -0000 1.36
-+++ vice/src/arch/win32/uimon.c 8 Jun 2004 19:21:23 -0000 1.36.2.1
-@@ -2160,7 +2160,7 @@
- {
- va_start(ap, format);
- buffer = lib_mvsprintf(format, ap);
-- rc = console_out(console_log, buffer);
-+ rc = console_out(console_log, "%s", buffer);
- lib_free(buffer);
- }
- return rc;
-
-Index: vice/src/monitor/mon_util.c
-===================================================================
-RCS file: /var/lib/cvs/cbm/vice/src/monitor/mon_util.c,v
-retrieving revision 1.13
-retrieving revision 1.13.10.1
-diff -u -r1.13 -r1.13.10.1
---- vice/src/monitor/mon_util.c 19 Mar 2004 09:55:01 -0000 1.13
-+++ vice/src/monitor/mon_util.c 8 Jun 2004 19:21:49 -0000 1.13.10.1
-@@ -48,7 +48,7 @@
- va_start(ap, format);
- buffer = lib_mvsprintf(format, ap);
-
-- rc = uimon_out(buffer);
-+ rc = uimon_out("%s", buffer);
- lib_free(buffer);
-
- if (rc < 0)
-
diff --git a/app-emulation/vice/files/1.14-po-Makefile.patch b/app-emulation/vice/files/1.14-po-Makefile.patch
deleted file mode 100644
index 94ba16fe9bf5..000000000000
--- a/app-emulation/vice/files/1.14-po-Makefile.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- po/Makefile.in.in 2000-07-14 18:26:17.000000000 -0400
-+++ po/Makefile.in.in 2003-07-13 03:13:35.000000000 -0400
-@@ -18,10 +18,10 @@
-
- prefix = @prefix@
- exec_prefix = @exec_prefix@
--datadir = $(prefix)/@DATADIRNAME@
--localedir = $(datadir)/locale
--gnulocaledir = $(prefix)/share/locale
--gettextsrcdir = $(prefix)/share/gettext/po
-+datadir = $(DESTDIR)$(prefix)/@DATADIRNAME@
-+localedir = $(DESTDIR)$(datadir)/locale
-+gnulocaledir = $(DESTDIR)$(prefix)/share/locale
-+gettextsrcdir = $(DESTDIR)$(prefix)/share/gettext/po
- subdir = po
-
- INSTALL = @INSTALL@
diff --git a/app-emulation/vice/files/digest-vice-1.14-r1 b/app-emulation/vice/files/digest-vice-1.14-r1
deleted file mode 100644
index 8b3d7db6170d..000000000000
--- a/app-emulation/vice/files/digest-vice-1.14-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 f25df1b8de2bbb536facbc05fcfa1db2 vice-1.14.tar.gz 3794698
diff --git a/app-emulation/vice/vice-1.14-r1.ebuild b/app-emulation/vice/vice-1.14-r1.ebuild
deleted file mode 100644
index 75ef6f6b0bfb..000000000000
--- a/app-emulation/vice/vice-1.14-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-1.14-r1.ebuild,v 1.8 2005/08/15 14:18:34 mr_bones_ Exp $
-
-inherit eutils games
-
-DESCRIPTION="The Versatile Commodore 8-bit Emulator"
-HOMEPAGE="http://www.viceteam.org/"
-SRC_URI="ftp://ftp.funet.fi/pub/cbm/crossplatform/emulators/VICE/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="ppc x86"
-IUSE="arts nls sdl"
-
-DEPEND="virtual/x11
- sdl? ( media-libs/libsdl )
- arts? ( kde-base/arts )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- use nls && epatch "${FILESDIR}/${PV}-po-Makefile.patch"
- # bug #53903
- # http://www.trikaliotis.net/vicekb/vsa-2004-1
- epatch "${FILESDIR}/${PV}-console-security.patch"
-}
-
-src_compile() {
- # disabled gnome support since it doesn't work.
- # see bug #101901 and discussion.
- egamesconf \
- --enable-fullscreen \
- --disable-dependency-tracking \
- --disable-gnomeui \
- $(use_with arts) \
- $(use_enable nls) \
- $(use_with sdl) \
- || die
- emake || die "emake failed"
-}
-
-src_install() {
- local docdir="${D}${GAMES_LIBDIR}/${PN}/doc"
-
- make DESTDIR="${D}" install || die "make install failed"
- dohtml "${docdir}/"* || die "dohtml failed"
- dodoc \
- AUTHORS ChangeLog FEEDBACK README \
- "${docdir}/"{BUGS,NEWS,PETdoc.txt,TODO} \
- "${docdir}/"{cbm_basic_tokens.txt,drive_info.txt,mon.txt,serial.txt}
- rm -rf "${docdir}"
- prepgamesdirs
-}