summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-12-16 16:34:04 +0000
committerIan Delaney <idella4@gentoo.org>2013-12-16 16:34:04 +0000
commitb7fdc64668581b7f03e0e56601c727bceb76f746 (patch)
treebb272818a047eb8bbc29e6ef2054c8160574892f /app-emulation/xen
parentsys-kernel/aufs-sources: Bump to latest genpatches and linux releases (diff)
downloadgentoo-2-b7fdc64668581b7f03e0e56601c727bceb76f746.tar.gz
gentoo-2-b7fdc64668581b7f03e0e56601c727bceb76f746.tar.bz2
gentoo-2-b7fdc64668581b7f03e0e56601c727bceb76f746.zip
KEYWORDS.dropped, x86, along with IUSE pae, in 4.3.x, wrt Bug #493944
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'app-emulation/xen')
-rw-r--r--app-emulation/xen/ChangeLog9
-rw-r--r--app-emulation/xen/xen-4.3.0-r5.ebuild (renamed from app-emulation/xen/xen-4.3.0-r4.ebuild)9
-rw-r--r--app-emulation/xen/xen-4.3.1-r2.ebuild133
3 files changed, 144 insertions, 7 deletions
diff --git a/app-emulation/xen/ChangeLog b/app-emulation/xen/ChangeLog
index 753a1b6740b5..6a7adb0f7db7 100644
--- a/app-emulation/xen/ChangeLog
+++ b/app-emulation/xen/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/xen
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.136 2013/12/10 13:34:51 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.137 2013/12/16 16:34:04 idella4 Exp $
+
+*xen-4.3.1-r2 (16 Dec 2013)
+*xen-4.3.0-r5 (16 Dec 2013)
+
+ 16 Dec 2013; Ian Delaney <idella4@gentoo.org> +xen-4.3.0-r5.ebuild,
+ +xen-4.3.1-r2.ebuild, -xen-4.3.0-r4.ebuild, metadata.xml:
+ KEYWORDS.dropped, x86, along with IUSE pae, in 4.3.x, wrt Bug #493944
10 Dec 2013; Agostino Sarubbo <ago@gentoo.org> xen-4.3.1-r1.ebuild:
Stable for x86, wrt bug #486354
diff --git a/app-emulation/xen/xen-4.3.0-r4.ebuild b/app-emulation/xen/xen-4.3.0-r5.ebuild
index dd672c809be0..d7bbb6eb7138 100644
--- a/app-emulation/xen/xen-4.3.0-r4.ebuild
+++ b/app-emulation/xen/xen-4.3.0-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-4.3.0-r4.ebuild,v 1.1 2013/12/06 14:13:04 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-4.3.0-r5.ebuild,v 1.1 2013/12/16 16:34:04 idella4 Exp $
EAPI=5
@@ -13,7 +13,7 @@ if [[ $PV == *9999 ]]; then
S="${WORKDIR}/${REPO}"
live_eclass="mercurial"
else
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64"
SRC_URI="http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz"
fi
@@ -23,7 +23,7 @@ DESCRIPTION="The Xen virtual machine monitor"
HOMEPAGE="http://xen.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="custom-cflags debug efi flask pae xsm"
+IUSE="custom-cflags debug efi flask xsm"
DEPEND="${PYTHON_DEPS}
efi? ( >=sys-devel/binutils-2.22[multitarget] )
@@ -103,7 +103,6 @@ src_prepare() {
src_configure() {
use debug && myopt="${myopt} debug=y"
- use pae && myopt="${myopt} pae=y"
if use custom-cflags; then
filter-flags -fPIE -fstack-protector
@@ -121,7 +120,6 @@ src_compile() {
src_install() {
local myopt
use debug && myopt="${myopt} debug=y"
- use pae && myopt="${myopt} pae=y"
# The 'make install' doesn't 'mkdir -p' the subdirs
if use efi; then
@@ -136,6 +134,5 @@ pkg_postinst() {
elog " http://www.gentoo.org/doc/en/xen-guide.xml"
elog " http://en.gentoo-wiki.com/wiki/Xen/"
- use pae && ewarn "This is a PAE build of Xen. It will *only* boot PAE kernels!"
use efi && einfo "The efi executable is installed in boot/efi/gentoo"
}
diff --git a/app-emulation/xen/xen-4.3.1-r2.ebuild b/app-emulation/xen/xen-4.3.1-r2.ebuild
new file mode 100644
index 000000000000..f172c49e3fd7
--- /dev/null
+++ b/app-emulation/xen/xen-4.3.1-r2.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-4.3.1-r2.ebuild,v 1.1 2013/12/16 16:34:04 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+if [[ $PV == *9999 ]]; then
+ KEYWORDS=""
+ REPO="xen-unstable.hg"
+ EHG_REPO_URI="http://xenbits.xensource.com/${REPO}"
+ S="${WORKDIR}/${REPO}"
+ live_eclass="mercurial"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz"
+fi
+
+inherit mount-boot flag-o-matic python-any-r1 toolchain-funcs eutils ${live_eclass}
+
+DESCRIPTION="The Xen virtual machine monitor"
+HOMEPAGE="http://xen.org/"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="custom-cflags debug efi flask xsm"
+
+DEPEND="${PYTHON_DEPS}
+ efi? ( >=sys-devel/binutils-2.22[multitarget] )
+ !efi? ( >=sys-devel/binutils-2.22[-multitarget] )"
+RDEPEND=""
+PDEPEND="~app-emulation/xen-tools-${PV}"
+
+RESTRICT="test"
+
+# Approved by QA team in bug #144032
+QA_WX_LOAD="boot/xen-syms-${PV}"
+
+REQUIRED_USE="flask? ( xsm )"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ if [[ -z ${XEN_TARGET_ARCH} ]]; then
+ if use x86 && use amd64; then
+ die "Confusion! Both x86 and amd64 are set in your use flags!"
+ elif use x86; then
+ export XEN_TARGET_ARCH="x86_32"
+ elif use amd64; then
+ export XEN_TARGET_ARCH="x86_64"
+ else
+ die "Unsupported architecture!"
+ fi
+ fi
+
+ if use flask ; then
+ export "XSM_ENABLE=y"
+ export "FLASK_ENABLE=y"
+ elif use xsm ; then
+ export "XSM_ENABLE=y"
+ fi
+}
+
+src_prepare() {
+ # Drop .config and fix gcc-4.6
+ epatch "${FILESDIR}"/${PN/-pvgrub/}-4.3-fix_dotconfig-gcc.patch
+
+ if use efi; then
+ epatch "${FILESDIR}"/${PN}-4.2-efi.patch
+ export EFI_VENDOR="gentoo"
+ export EFI_MOUNTPOINT="boot"
+ fi
+
+ # if the user *really* wants to use their own custom-cflags, let them
+ if use custom-cflags; then
+ einfo "User wants their own CFLAGS - removing defaults"
+ # try and remove all the default custom-cflags
+ find "${S}" -name Makefile -o -name Rules.mk -o -name Config.mk -exec sed \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O3\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-march=i686\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-g3*\s\(.*\)/CFLAGS\1=\2 \3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
+ -i {} \; || die "failed to re-set custom-cflags"
+ fi
+
+ # not strictly necessary to fix this
+ sed -i 's/, "-Werror"//' "${S}/tools/python/setup.py" || die "failed to re-set setup.py"
+
+ # Security patches
+ epatch "${FILESDIR}"/${PN}-CVE-2013-4375-XSA-71.patch \
+ "${FILESDIR}"/${PN}-CVE-2013-4494-XSA-73.patch \
+ "${FILESDIR}"/${PN}-4.3-CVE-2013-6375-XSA-75.patch \
+ "${FILESDIR}"/${PN}-CVE-2013-6375-XSA-78.patch \
+ "${FILESDIR}"/${PN}-CVE-2013-6885-XSA-82.patch
+
+ epatch_user
+}
+
+src_configure() {
+ use debug && myopt="${myopt} debug=y"
+
+ if use custom-cflags; then
+ filter-flags -fPIE -fstack-protector
+ replace-flags -O3 -O2
+ else
+ unset CFLAGS
+ fi
+}
+
+src_compile() {
+ # Send raw LDFLAGS so that --as-needed works
+ emake CC="$(tc-getCC)" LDFLAGS="$(raw-ldflags)" LD="$(tc-getLD)" -C xen ${myopt}
+}
+
+src_install() {
+ local myopt
+ use debug && myopt="${myopt} debug=y"
+
+ # The 'make install' doesn't 'mkdir -p' the subdirs
+ if use efi; then
+ mkdir -p "${D}"${EFI_MOUNTPOINT}/efi/${EFI_VENDOR} || die
+ fi
+
+ emake LDFLAGS="$(raw-ldflags)" DESTDIR="${D}" -C xen ${myopt} install
+}
+
+pkg_postinst() {
+ elog "Official Xen Guide and the unoffical wiki page:"
+ elog " http://www.gentoo.org/doc/en/xen-guide.xml"
+ elog " http://en.gentoo-wiki.com/wiki/Xen/"
+
+ use efi && einfo "The efi executable is installed in boot/efi/gentoo"
+}