summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-05-13 17:25:20 +0000
committerPacho Ramos <pacho@gentoo.org>2012-05-13 17:25:20 +0000
commit4dff18c9e6c078317c49acb23e59137c13443c2b (patch)
treee1cb747c5403b7f2c83f4f4087256c3540cc07f0 /app-emulation/xen
parentFix Manifest. (diff)
downloadgentoo-2-4dff18c9e6c078317c49acb23e59137c13443c2b.tar.gz
gentoo-2-4dff18c9e6c078317c49acb23e59137c13443c2b.tar.bz2
gentoo-2-4dff18c9e6c078317c49acb23e59137c13443c2b.zip
Drop old.
(Portage version: 2.1.10.59/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/xen')
-rw-r--r--app-emulation/xen/ChangeLog8
-rw-r--r--app-emulation/xen/metadata.xml1
-rw-r--r--app-emulation/xen/xen-3.4.2-r4.ebuild114
3 files changed, 6 insertions, 117 deletions
diff --git a/app-emulation/xen/ChangeLog b/app-emulation/xen/ChangeLog
index 00e4a2d3c1ba..e4d11aa14e72 100644
--- a/app-emulation/xen/ChangeLog
+++ b/app-emulation/xen/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/xen
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.94 2011/11/28 18:24:57 alexxy Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.95 2012/05/13 17:25:20 pacho Exp $
+
+ 13 May 2012; Pacho Ramos <pacho@gentoo.org> -xen-3.4.2-r4.ebuild,
+ metadata.xml:
+ Drop old.
28 Nov 2011; Alexey Shvetsov <alexxy@gentoo.org> -xen-9999.ebuild:
Move xen-9999 to virtualization overlay
diff --git a/app-emulation/xen/metadata.xml b/app-emulation/xen/metadata.xml
index 655045919f28..80411f088174 100644
--- a/app-emulation/xen/metadata.xml
+++ b/app-emulation/xen/metadata.xml
@@ -7,7 +7,6 @@
<name>Ian Delaney aka idella4 proxy maintainer</name>
</maintainer>
<use>
- <flag name='acm'>Enable the ACM/sHype XSM module from IBM</flag>
<flag name='flask'>Enable the Flask XSM module from NSA</flag>
<flag name='pae'>Enable support for PAE kernels (usually x86-32 with >4GB memory)</flag>
<flag name='xsm'>Enable the Xen Security Modules (XSM)</flag>
diff --git a/app-emulation/xen/xen-3.4.2-r4.ebuild b/app-emulation/xen/xen-3.4.2-r4.ebuild
deleted file mode 100644
index 643ade2ed3b6..000000000000
--- a/app-emulation/xen/xen-3.4.2-r4.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.4.2-r4.ebuild,v 1.3 2011/10/15 19:38:16 hwoarang Exp $
-
-EAPI=2
-
-inherit mount-boot flag-o-matic toolchain-funcs base
-
-DESCRIPTION="The Xen virtual machine monitor"
-HOMEPAGE="http://xen.org/"
-SRC_URI="http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug custom-cflags pae acm flask xsm"
-
-RDEPEND="|| ( sys-boot/grub
- sys-boot/grub-static )
- >=sys-kernel/xen-sources-2.6.18"
-PDEPEND="~app-emulation/xen-tools-${PV}"
-PATCHES=(
- "${FILESDIR}/"${PN}-3.3.0-unexported-target-fix.patch
- "${FILESDIR}/"${P}-dump_registers-watchdog-fix.patch
- "${FILESDIR}/"${P}-no-DMA.patch
- "${FILESDIR}/"${P}-werror-idiocy.patch
- "${FILESDIR}/"${P}-fix-__addr_ok-limit.patch
- "${FILESDIR}/"${P}-CVE-2011-1583.patch
-)
-
-RESTRICT="test"
-
-# Approved by QA team in bug #144032
-QA_WX_LOAD="boot/xen-syms-${PV}"
-
-pkg_setup() {
- if [ -x "${S}/.config/" ]; then
- die "You will need to remove ${S}/.config by hand"
- fi
- if [[ -z ${XEN_TARGET_ARCH} ]]; then
- if use x86 && use amd64; then
- die "Confusion! Both x86 and amd64 are set in your use flags!"
- elif use x86; then
- export XEN_TARGET_ARCH="x86_32"
- elif use amd64; then
- export XEN_TARGET_ARCH="x86_64"
- else
- die "Unsupported architecture!"
- fi
- fi
-
- if use xsm ; then
- export "XSM_ENABLE=y"
- use acm && export "ACM_SECURITY=y"
- if use flask ; then
- ! use acm && export "FLASK_ENABLE=y"
- use acm && ewarn "Both acm and flask XSM specified, defaulting to acm."
- fi
- elif use acm || use flask ; then
- ewarn "acm and flask require USE=xsm to be set, dropping use flags"
- fi
-}
-
-src_prepare() {
- base_src_prepare
-
- # if the user *really* wants to use their own custom-cflags, let them
- if use custom-cflags; then
- einfo "User wants their own CFLAGS - removing defaults"
- # try and remove all the default custom-cflags
- find "${S}" -name Makefile -o -name Rules.mk -o -name Config.mk -exec sed \
- -e 's/CFLAGS\(.*\)=\(.*\)-O3\(.*\)/CFLAGS\1=\2\3/' \
- -e 's/CFLAGS\(.*\)=\(.*\)-march=i686\(.*\)/CFLAGS\1=\2\3/' \
- -e 's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
- -e 's/CFLAGS\(.*\)=\(.*\)-g3*\s\(.*\)/CFLAGS\1=\2 \3/' \
- -e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
- -i {} \;
- fi
-}
-
-src_compile() {
- local myopt
- use debug && myopt="${myopt} debug=y"
- use pae && myopt="${myopt} pae=y"
-
- if use custom-cflags; then
- filter-flags -fPIE -fstack-protector
- replace-flags -O3 -O2
- else
- unset CFLAGS
- fi
-
- # Send raw LDFLAGS so that --as-needed works
- emake CC="$(tc-getCC)" LDFLAGS="$(raw-ldflags)" -C xen ${myopt} || die "compile failed"
-}
-
-src_install() {
- local myopt
- use debug && myopt="${myopt} debug=y"
- use pae && myopt="${myopt} pae=y"
-
- emake LDFLAGS="$(raw-ldflags)" DESTDIR="${D}" -C xen ${myopt} install || die "install failed"
-}
-
-pkg_postinst() {
- elog "Official Xen Guide and the unoffical wiki page:"
- elog " http://www.gentoo.org/doc/en/xen-guide.xml"
- elog " http://en.gentoo-wiki.com/wiki/Xen/"
-
- if use pae; then
- echo
- ewarn "This is a PAE build of Xen. It will *only* boot PAE kernels!"
- fi
-}