summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2009-01-17 00:02:53 +0000
committerLance Albertson <ramereth@gentoo.org>2009-01-17 00:02:53 +0000
commit6c29073cef618c89445bab979dc80a3bccd5f36a (patch)
treea2fdb8f8ebecfc0ebda7f5a7e63e9b5552f3a386 /app-emulation/xen-tools
parentmake flagedit compatible with directories support of Portage >= 2.2 ( bug #24... (diff)
downloadgentoo-2-6c29073cef618c89445bab979dc80a3bccd5f36a.tar.gz
gentoo-2-6c29073cef618c89445bab979dc80a3bccd5f36a.tar.bz2
gentoo-2-6c29073cef618c89445bab979dc80a3bccd5f36a.zip
Add bzImage support to xen 3.1.3
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-hardened-r3-osl1 x86_64)
Diffstat (limited to 'app-emulation/xen-tools')
-rw-r--r--app-emulation/xen-tools/ChangeLog12
-rw-r--r--app-emulation/xen-tools/files/xen-tools-3.1.3-bzimage.patch205
-rw-r--r--app-emulation/xen-tools/xen-tools-3.1.3-r1.ebuild225
3 files changed, 440 insertions, 2 deletions
diff --git a/app-emulation/xen-tools/ChangeLog b/app-emulation/xen-tools/ChangeLog
index 85ac30204f9a..6db8e5ec8fb6 100644
--- a/app-emulation/xen-tools/ChangeLog
+++ b/app-emulation/xen-tools/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/xen-tools
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.40 2008/09/01 00:41:07 rbu Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.41 2009/01/17 00:02:53 ramereth Exp $
+
+*xen-tools-3.1.3-r1 (16 Jan 2009)
+
+ 16 Jan 2009; Lance Albertson <ramereth@gentoo.org>
+ +files/xen-tools-3.1.3-bzimage.patch, +xen-tools-3.1.3-r1.ebuild:
+ New patch for 3.1.3 which adds bzImage >=v2.08 support to xen. This allows
+ Fedora 10 to run as a DomU for this version. Patch is originally from
+ https://bugzilla.redhat.com/457199
*xen-tools-3.3.0 (01 Sep 2008)
diff --git a/app-emulation/xen-tools/files/xen-tools-3.1.3-bzimage.patch b/app-emulation/xen-tools/files/xen-tools-3.1.3-bzimage.patch
new file mode 100644
index 000000000000..5820c9f9ce94
--- /dev/null
+++ b/app-emulation/xen-tools/files/xen-tools-3.1.3-bzimage.patch
@@ -0,0 +1,205 @@
+x86: Support loading Linux bzImage v2.08 and up.
+
+The latest -mm kernel (2.6.25-rc3-mm1) contains v2.08 of the Linux
+bzImage format which embeds an ELF file in place of the raw payload
+allowing it to be extracted and used by the Xen domain builder.
+
+It is expected that this functionality will be put forward for 2.6.26.
+
+Signed-off-by : Ian Campbell <ijc@hellion.org.uk>
+
+diff -up /dev/null xen-3.1.2-src/tools/libxc/xc_dom_bzimageloader.c
+--- /dev/null 2008-07-30 07:06:19.721092644 +0100
++++ xen-3.1.2-src/tools/libxc/xc_dom_bzimageloader.c 2008-07-30 08:51:24.000000000 +0100
+@@ -0,0 +1,159 @@
++/*
++ * Xen domain builder -- bzImage bits
++ *
++ * Parse and load bzImage kernel images.
++ *
++ * This relies on version 2.08 of the boot protocol, which contains an
++ * ELF file embedded in the bzImage. The loader extracts this ELF
++ * image and passes it off to the standard ELF loader.
++ *
++ * This code is licenced under the GPL.
++ * written 2006 by Gerd Hoffmann <kraxel@suse.de>.
++ * written 2007 by Jeremy Fitzhardinge <jeremy@xensource.com>
++ * written 2008 by Ian Campbell <ijc@hellion.org.uk>
++ *
++ */
++#include <stdio.h>
++#include <stdlib.h>
++#include <inttypes.h>
++
++#include "xg_private.h"
++#include "xc_dom.h"
++
++struct setup_header {
++ uint8_t _pad0[0x1f1]; /* skip uninteresting stuff */
++ uint8_t setup_sects;
++ uint16_t root_flags;
++ uint32_t syssize;
++ uint16_t ram_size;
++ uint16_t vid_mode;
++ uint16_t root_dev;
++ uint16_t boot_flag;
++ uint16_t jump;
++ uint32_t header;
++#define HDR_MAGIC "HdrS"
++#define HDR_MAGIC_SZ 4
++ uint16_t version;
++#define VERSION(h,l) (((h)<<8) | (l))
++ uint32_t realmode_swtch;
++ uint16_t start_sys;
++ uint16_t kernel_version;
++ uint8_t type_of_loader;
++ uint8_t loadflags;
++ uint16_t setup_move_size;
++ uint32_t code32_start;
++ uint32_t ramdisk_image;
++ uint32_t ramdisk_size;
++ uint32_t bootsect_kludge;
++ uint16_t heap_end_ptr;
++ uint16_t _pad1;
++ uint32_t cmd_line_ptr;
++ uint32_t initrd_addr_max;
++ uint32_t kernel_alignment;
++ uint8_t relocatable_kernel;
++ uint8_t _pad2[3];
++ uint32_t cmdline_size;
++ uint32_t hardware_subarch;
++ uint64_t hardware_subarch_data;
++ uint32_t payload_offset;
++ uint32_t payload_length;
++} __attribute__((packed));
++
++extern struct xc_dom_loader elf_loader;
++
++static unsigned int payload_offset(struct setup_header *hdr)
++{
++ unsigned int off;
++
++ off = (hdr->setup_sects + 1) * 512;
++ off += hdr->payload_offset;
++ return off;
++}
++
++static int check_bzimage_kernel(struct xc_dom_image *dom, int verbose)
++{
++ struct setup_header *hdr;
++
++ if ( dom->kernel_blob == NULL )
++ {
++ if ( verbose )
++ xc_dom_panic(XC_INTERNAL_ERROR, "%s: no kernel image loaded\n",
++ __FUNCTION__);
++ return -EINVAL;
++ }
++ if ( dom->kernel_size < sizeof(struct setup_header) )
++ {
++ if ( verbose )
++ xc_dom_panic(XC_INTERNAL_ERROR, "%s: kernel image too small\n",
++ __FUNCTION__);
++ return -EINVAL;
++ }
++
++ hdr = dom->kernel_blob;
++
++ if ( memcmp(&hdr->header, HDR_MAGIC, HDR_MAGIC_SZ) != 0 )
++ {
++ if ( verbose )
++ xc_dom_panic(XC_INVALID_KERNEL, "%s: kernel is not a bzImage\n",
++ __FUNCTION__);
++ return -EINVAL;
++ }
++
++ if ( hdr->version < VERSION(2,8) )
++ {
++ if ( verbose )
++ xc_dom_panic(XC_INVALID_KERNEL, "%s: boot protocol too old (%04x)\n",
++ __FUNCTION__, hdr->version);
++ return -EINVAL;
++ }
++
++ dom->kernel_blob = dom->kernel_blob + payload_offset(hdr);
++ dom->kernel_size = hdr->payload_length;
++
++ if ( xc_dom_try_gunzip(dom, &dom->kernel_blob, &dom->kernel_size) == -1 )
++ {
++ if ( verbose )
++ xc_dom_panic(XC_INVALID_KERNEL, "%s: unable to decompress kernel\n",
++ __FUNCTION__);
++ return -EINVAL;
++ }
++
++ return elf_loader.probe(dom);
++}
++
++static int xc_dom_probe_bzimage_kernel(struct xc_dom_image *dom)
++{
++ return check_bzimage_kernel(dom, 0);
++}
++
++static int xc_dom_parse_bzimage_kernel(struct xc_dom_image *dom)
++{
++ return elf_loader.parser(dom);
++}
++
++static int xc_dom_load_bzimage_kernel(struct xc_dom_image *dom)
++{
++ return elf_loader.loader(dom);
++}
++
++static struct xc_dom_loader bzimage_loader = {
++ .name = "Linux bzImage",
++ .probe = xc_dom_probe_bzimage_kernel,
++ .parser = xc_dom_parse_bzimage_kernel,
++ .loader = xc_dom_load_bzimage_kernel,
++};
++
++static void __init register_loader(void)
++{
++ xc_dom_register_loader(&bzimage_loader);
++}
++
++/*
++ * Local variables:
++ * mode: C
++ * c-set-style: "BSD"
++ * c-basic-offset: 4
++ * tab-width: 4
++ * indent-tabs-mode: nil
++ * End:
++ */
+diff -up xen-3.1.2-src/tools/libxc/Makefile.bzImage xen-3.1.2-src/tools/libxc/Makefile
+--- xen-3.1.2-src/tools/libxc/Makefile.bzImage 2007-11-14 23:35:27.000000000 +0000
++++ xen-3.1.2-src/tools/libxc/Makefile 2008-07-30 08:51:24.000000000 +0100
+@@ -45,10 +45,11 @@ $(LIBELF_SRCS) libelf-private.h:
+ GUEST_SRCS-y += $(LIBELF_SRCS)
+
+ # new domain builder
+-GUEST_SRCS-y += xc_dom_core.c xc_dom_boot.c
+-GUEST_SRCS-y += xc_dom_elfloader.c
+-GUEST_SRCS-y += xc_dom_binloader.c
+-GUEST_SRCS-y += xc_dom_compat_linux.c
++GUEST_SRCS-y += xc_dom_core.c xc_dom_boot.c
++GUEST_SRCS-y += xc_dom_elfloader.c
++GUEST_SRCS-$(CONFIG_X86) += xc_dom_bzimageloader.c
++GUEST_SRCS-y += xc_dom_binloader.c
++GUEST_SRCS-y += xc_dom_compat_linux.c
+
+ GUEST_SRCS-$(CONFIG_X86) += xc_dom_x86.c
+ GUEST_SRCS-$(CONFIG_IA64) += xc_dom_ia64.c
+diff -up xen-3.1.2-src/tools/libxc/xc_dom_elfloader.c.bzImage xen-3.1.2-src/tools/libxc/xc_dom_elfloader.c
+--- xen-3.1.2-src/tools/libxc/xc_dom_elfloader.c.bzImage 2007-11-14 23:35:27.000000000 +0000
++++ xen-3.1.2-src/tools/libxc/xc_dom_elfloader.c 2008-07-30 08:51:24.000000000 +0100
+@@ -281,7 +281,7 @@ static int xc_dom_load_elf_kernel(struct
+
+ /* ------------------------------------------------------------------------ */
+
+-static struct xc_dom_loader elf_loader = {
++struct xc_dom_loader elf_loader = {
+ .name = "ELF-generic",
+ .probe = xc_dom_probe_elf_kernel,
+ .parser = xc_dom_parse_elf_kernel,
+
diff --git a/app-emulation/xen-tools/xen-tools-3.1.3-r1.ebuild b/app-emulation/xen-tools/xen-tools-3.1.3-r1.ebuild
new file mode 100644
index 000000000000..966f08c5682a
--- /dev/null
+++ b/app-emulation/xen-tools/xen-tools-3.1.3-r1.ebuild
@@ -0,0 +1,225 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-3.1.3-r1.ebuild,v 1.1 2009/01/17 00:02:53 ramereth Exp $
+
+inherit flag-o-matic eutils multilib
+
+DESCRIPTION="Xend daemon and tools"
+HOMEPAGE="http://www.xensource.com/xen/xen/"
+SRC_URI="mirror://gentoo/xen-${PV}.tar.bz2"
+S="${WORKDIR}/xen-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug screen custom-cflags pygrub hvm"
+
+CDEPEND="dev-lang/python
+ sys-libs/zlib
+ hvm? ( media-libs/libsdl )"
+
+DEPEND="${CDEPEND}
+ sys-devel/gcc
+ dev-lang/perl
+ app-misc/pax-utils
+ doc? (
+ dev-tex/latex2html
+ media-gfx/transfig
+ media-gfx/graphviz
+ )
+ hvm? (
+ x11-proto/xproto
+ net-libs/libvncserver
+ sys-devel/dev86
+ )"
+
+RDEPEND="${CDEPEND}
+ sys-apps/iproute2
+ net-misc/bridge-utils
+ screen? (
+ app-misc/screen
+ app-admin/logrotate
+ )
+ || ( sys-fs/udev sys-apps/hotplug )"
+
+PYTHON_MODNAME="xen grub"
+
+# hvmloader is used to bootstrap a fully virtualized kernel
+# Approved by QA team in bug #144032
+QA_WX_LOAD="usr/lib/xen/boot/hvmloader"
+
+pkg_setup() {
+ if ! use x86 && ! has x86 $(get_all_abis) && use hvm; then
+ eerror "HVM (VT-x and AMD-v) cannot be built on this system. An x86 or"
+ eerror "an amd64 multilib profile is required. Remove the hvm use flag"
+ eerror "to build xen-tools on your current profile."
+ die "USE=hvm is unsupported on this system."
+ fi
+
+ if [[ -z ${XEN_TARGET_ARCH} ]] ; then
+ if use x86 && use amd64; then
+ die "Confusion! Both x86 and amd64 are set in your use flags!"
+ elif use x86; then
+ export XEN_TARGET_ARCH="x86_32"
+ elif use amd64 ; then
+ export XEN_TARGET_ARCH="x86_64"
+ else
+ die "Unsupported architecture!"
+ fi
+ fi
+
+ if use doc && ! built_with_use -o dev-tex/latex2html png gif; then
+ # die early instead of later
+ eerror "USE=doc requires latex2html with image support. Please add"
+ eerror "'png' and/or 'gif' to your use flags and re-emerge latex2html"
+ die "latex2html missing both png and gif flags"
+ fi
+
+ if use pygrub && ! built_with_use dev-lang/python ncurses; then
+ eerror "USE=pygrub requires python to be built with ncurses support. Please add"
+ eerror "'ncurses' to your use flags and re-emerge python"
+ die "python is missing ncurses flags"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # if the user *really* wants to use their own custom-cflags, let them
+ if use custom-cflags; then
+ einfo "User wants their own CFLAGS - removing defaults"
+ # try and remove all the default custom-cflags
+ find "${S}" -name Makefile -o -name Rules.mk -o -name Config.mk -exec sed \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O3\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-march=i686\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-g3*\s\(.*\)/CFLAGS\1=\2 \3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
+ -i {} \;
+ fi
+
+ # Disable hvm support on systems that don't support x86_32 binaries.
+ if ! use hvm; then
+ chmod 644 tools/check/check_x11_devel
+ sed -i -e '/^CONFIG_IOEMU := y$/d' "${S}"/config/*.mk
+ sed -i -e '/SUBDIRS-$(CONFIG_X86) += firmware/d' "${S}"/tools/Makefile
+ fi
+
+ if ! use pygrub; then
+ sed -i -e "/^SUBDIRS-y += pygrub$/d" "${S}"/tools/Makefile
+ fi
+
+ # Allow --as-needed LDFLAGS
+ epatch "${FILESDIR}/${PN}-3.0.4_p1--as-needed.patch"
+
+ # Fix network broadcast on bridged networks
+ epatch "${FILESDIR}/${PN}-3.1.3-network-bridge-broadcast.patch"
+
+ # Fix building small dumb utility called 'xen-detect' on hardened
+ epatch "${FILESDIR}/${PN}-3.1.0-xen-detect-nopie-fix.patch"
+
+ # Add support for loading Linux bzImage v2.08 and up
+ epatch "${FILESDIR}/${PN}-3.1.3-bzimage.patch"
+}
+
+src_compile() {
+ local myopt myconf
+ use debug && myopt="${myopt} debug=y"
+
+ use custom-cflags || unset CFLAGS
+ if test-flag-CC -fno-strict-overflow; then
+ append-flags -fno-strict-overflow
+ fi
+
+ if use hvm; then
+ myconf="${myconf} --disable-system --disable-user"
+ (cd tools/ioemu && econf ${myconf}) || die "configure failured"
+ fi
+
+ emake -C tools ${myopt} || die "compile failed"
+
+ if use doc; then
+ sh ./docs/check_pkgs || die "package check failed"
+ emake -C docs || die "compiling docs failed"
+ fi
+
+ emake -C docs man-pages || die "make man-pages failed"
+}
+
+src_install() {
+ local myopt="XEN_PYTHON_NATIVE_INSTALL=1"
+
+ make DESTDIR="${D}" -C tools ${myopt} install \
+ || die "install failed"
+
+ # Remove RedHat-specific stuff
+ rm -rf "${D}"/etc/sysconfig
+
+ if use doc; then
+ make DESTDIR="${D}" -C docs install || die "install docs failed"
+ # Rename doc/xen to the Gentoo-style doc/xen-x.y
+ mv "${D}"/usr/share/doc/{${PN},${PF}}
+ fi
+
+ doman docs/man?/*
+
+ newinitd "${FILESDIR}"/xend.initd xend \
+ || die "Couldn't install xen.initd"
+ newconfd "${FILESDIR}"/xendomains.confd xendomains \
+ || die "Couldn't install xendomains.confd"
+ newinitd "${FILESDIR}"/xendomains.initd xendomains \
+ || die "Couldn't install xendomains.initd"
+
+ if use screen; then
+ cat "${FILESDIR}"/xendomains-screen.confd >> "${D}"/etc/conf.d/xendomains
+ cp "${FILESDIR}"/xen-consoles.logrotate "${D}"/etc/xen/
+ keepdir /var/log/xen-consoles
+ fi
+
+ # xend expects these to exist
+ keepdir /var/run/xenstored /var/lib/xenstored /var/xen/dump /var/lib/xen /var/log/xen
+
+ # for xendomains
+ keepdir /etc/xen/auto
+}
+
+pkg_postinst() {
+ elog "Official Xen Guide and the unoffical wiki page:"
+ elog " http://www.gentoo.org/doc/en/xen-guide.xml"
+ elog " http://gentoo-wiki.com/HOWTO_Xen_and_Gentoo"
+
+ if [[ "$(scanelf -s __guard -q $(type -P python))" ]] ; then
+ echo
+ ewarn "xend may not work when python is built with stack smashing protection (ssp)."
+ ewarn "If 'xm create' fails with '<ProtocolError for /RPC2: -1 >', see bug #141866"
+ ewarn "This probablem may be resolved as of Xen 3.0.4, if not post in the bug."
+ fi
+
+ if ! built_with_use dev-lang/python ncurses; then
+ echo
+ ewarn "NB: Your dev-lang/python is built without USE=ncurses."
+ ewarn "Please rebuild python with USE=ncurses to make use of xenmon.py."
+ fi
+
+ if built_with_use sys-apps/iproute2 minimal; then
+ echo
+ ewarn "Your sys-apps/iproute2 is built with USE=minimal. Networking"
+ ewarn "will not work until you rebuild iproute2 without USE=minimal."
+ fi
+
+ if ! use hvm; then
+ echo
+ elog "HVM (VT-x and AMD-V) support has been disabled. If you need hvm"
+ elog "support enable the hvm use flag."
+ elog "An x86 or amd64 multilib system is required to build HVM support."
+ echo
+ elog "The ioemu use flag has been removed and replaced with hvm."
+ fi
+
+ if grep -qsF XENSV= "${ROOT}/etc/conf.d/xend"; then
+ echo
+ elog "xensv is broken upstream (Gentoo bug #142011)."
+ elog "Please remove '${ROOT%/}/etc/conf.d/xend', as it is no longer needed."
+ fi
+}