summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-12-11 09:06:27 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-12-11 09:06:27 +0000
commit24569c35402cb688ba0db00eeb79532e12ac5b08 (patch)
treec0554bbb49437c9a013cbda5088390e193f96e3e /app-emulation/xen-tools
parentMove sys-power/iasl dependency from USE="hvm" to always required because econ... (diff)
downloadgentoo-2-24569c35402cb688ba0db00eeb79532e12ac5b08.tar.gz
gentoo-2-24569c35402cb688ba0db00eeb79532e12ac5b08.tar.bz2
gentoo-2-24569c35402cb688ba0db00eeb79532e12ac5b08.zip
Try to add some proper quoting. A lot of it is still messed up and half of the ebuild needs rewriting due to bad code
(Portage version: 2.2.0_alpha147/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-emulation/xen-tools')
-rw-r--r--app-emulation/xen-tools/xen-tools-4.1.1-r6.ebuild4
-rw-r--r--app-emulation/xen-tools/xen-tools-4.2.0-r1.ebuild8
2 files changed, 6 insertions, 6 deletions
diff --git a/app-emulation/xen-tools/xen-tools-4.1.1-r6.ebuild b/app-emulation/xen-tools/xen-tools-4.1.1-r6.ebuild
index 33b7e2c194fd..0002a91a95b0 100644
--- a/app-emulation/xen-tools/xen-tools-4.1.1-r6.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.1.1-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.1.1-r6.ebuild,v 1.9 2012/12/11 09:02:38 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.1.1-r6.ebuild,v 1.10 2012/12/11 09:06:27 ssuominen Exp $
EAPI="3"
@@ -222,7 +222,7 @@ src_compile() {
fi
unset LDFLAGS
- emake CC=$(tc-getCC) LD=$(tc-getLD) -C tools ${myopt} || die "compile failed"
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" -C tools ${myopt} || die "compile failed"
if use doc; then
sh ./docs/check_pkgs || die "package check failed"
diff --git a/app-emulation/xen-tools/xen-tools-4.2.0-r1.ebuild b/app-emulation/xen-tools/xen-tools-4.2.0-r1.ebuild
index b5824a6bb22f..783ef9ceb18a 100644
--- a/app-emulation/xen-tools/xen-tools-4.2.0-r1.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.2.0-r1.ebuild,v 1.2 2012/12/11 09:02:38 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.2.0-r1.ebuild,v 1.3 2012/12/11 09:06:27 ssuominen Exp $
EAPI="4"
PYTHON_DEPEND="2"
@@ -180,7 +180,7 @@ src_prepare() {
# Prevent the downloading of ipxe, seabios
epatch "${FILESDIR}"/${P/-tools/}-anti-download.patch
- cp $DISTDIR/ipxe.tar.gz tools/firmware/etherboot/ || die
+ cp "${DISTDIR}"/ipxe.tar.gz tools/firmware/etherboot/ || die
mv ../seabios-dir-remote tools/firmware/ || die
pushd tools/firmware/ > /dev/null
ln -s seabios-dir-remote seabios-dir || die
@@ -213,7 +213,7 @@ src_compile() {
unset LDFLAGS
unset CFLAGS
- emake CC=$(tc-getCC) LD=$(tc-getLD) -C tools ${myopt}
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" -C tools ${myopt}
if use doc; then
sh ./docs/check_pkgs || die "package check failed"
@@ -270,7 +270,7 @@ src_install() {
# For -static-libs wrt Bug 384355
if ! use static-libs; then
- rm -f ${ED}usr/$(get_libdir)/*.a ${ED}usr/$(get_libdir)/ocaml/*/*.a
+ rm -f "${ED}"usr/$(get_libdir)/*.a "${ED}"usr/$(get_libdir)/ocaml/*/*.a
fi
#python_convert_shebangs -r 2 "${ED}"