summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-29 23:49:49 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-29 23:49:49 +0000
commit2754ba19e9a58e8a48ec679f2bfe86e02a532d5a (patch)
tree8a8e42305c24dfdfbae766df64e0029c467c2d69 /app-emulation/winex
parentChanged mkdir ${D} to dodir ${D} (diff)
downloadgentoo-2-2754ba19e9a58e8a48ec679f2bfe86e02a532d5a.tar.gz
gentoo-2-2754ba19e9a58e8a48ec679f2bfe86e02a532d5a.tar.bz2
gentoo-2-2754ba19e9a58e8a48ec679f2bfe86e02a532d5a.zip
Changed mkdir ${D} to dodir ${D}
Diffstat (limited to 'app-emulation/winex')
-rw-r--r--app-emulation/winex/winex-20020807.ebuild16
-rw-r--r--app-emulation/winex/winex-20021011.ebuild16
2 files changed, 10 insertions, 22 deletions
diff --git a/app-emulation/winex/winex-20020807.ebuild b/app-emulation/winex/winex-20020807.ebuild
index ea8d6052d7c1..f63918c1aab7 100644
--- a/app-emulation/winex/winex-20020807.ebuild
+++ b/app-emulation/winex/winex-20020807.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex/winex-20020807.ebuild,v 1.6 2002/10/24 23:23:44 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex/winex-20020807.ebuild,v 1.7 2002/11/29 23:45:52 vapier Exp $
IUSE="cups opengl"
@@ -24,12 +24,10 @@ DEPEND="virtual/x11
>=media-libs/freetype-2.0.0
dev-lang/tcl dev-lang/tk"
-
src_compile() {
# Azarah's patches
#patch -p0 < ${FILESDIR}/${P}-opengl.patch || die "opengl-patch failed"
- cd ${S}
local myconf
use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
@@ -61,20 +59,17 @@ src_compile() {
cd programs && emake || die "emake died"
}
-src_install () {
-
+src_install() {
local WINEXMAKEOPTS="prefix=${D}/usr/lib/winex"
-
+
# Installs winex to /usr/lib/winex
- cd ${S}
make ${WINEXMAKEOPTS} install || die "make install failed"
cd ${S}/programs
make ${WINEXMAKEOPTS} install || die "make install failed"
-
# Creates /usr/lib/winex/.data with fake_windows in it
# This is needed for our new winex wrapper script
- mkdir ${D}/usr/lib/winex/.data
+ dodir /usr/lib/winex/.data
cp -R ${WORKDIR}/fake_windows ${D}/usr/lib/winex/.data
cp ${FILESDIR}/${P}-config ${D}/usr/lib/winex/.data/config
@@ -82,7 +77,7 @@ src_install () {
cp ${WORKDIR}/wine/winedefault.reg ${D}/usr/lib/winex/.data/winedefault.reg
# Install the wrapper script
- mkdir ${D}/usr/bin
+ dodir /usr/bin
cp ${FILESDIR}/${P}-winex ${D}/usr/bin/winex
cp ${FILESDIR}/${P}-regedit ${D}/usr/bin/regedit-winex
@@ -106,4 +101,3 @@ pkg_postinst() {
einfo "else. If you have further questions, enhancements or patches"
einfo "send an email to phoenix@gentoo.org"
}
-
diff --git a/app-emulation/winex/winex-20021011.ebuild b/app-emulation/winex/winex-20021011.ebuild
index bb444e30f8c9..0d5f11635166 100644
--- a/app-emulation/winex/winex-20021011.ebuild
+++ b/app-emulation/winex/winex-20021011.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex/winex-20021011.ebuild,v 1.5 2002/11/23 14:22:02 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex/winex-20021011.ebuild,v 1.6 2002/11/29 23:49:49 vapier Exp $
IUSE="cups opengl"
@@ -24,12 +24,10 @@ DEPEND="virtual/x11
>=media-libs/freetype-2.0.0
dev-lang/tcl dev-lang/tk"
-
src_compile() {
# Azarah's patches
#patch -p0 < ${FILESDIR}/${P}-opengl.patch || die "opengl-patch failed"
- cd ${S}
local myconf
use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
@@ -64,12 +62,10 @@ src_compile() {
#######################################################################
}
-src_install () {
-
+src_install() {
local WINEXMAKEOPTS="prefix=${D}/usr/lib/${PN}"
-
+
# Installs winex to ${D}/usr/lib/${PN}
- cd ${S}
make ${WINEXMAKEOPTS} install || die "make install failed"
##### borked really bad ###############################################
@@ -77,11 +73,10 @@ src_install () {
# make ${WINEXMAKEOPTS} install || die "make install failed" #
#######################################################################
-
# Creates /usr/lib/${PN}/.data with fake_windows in it
# This is needed for ~/.${PN} initialization by our
# winex wrapper script
- mkdir ${D}/usr/lib/${PN}/.data
+ dodir /usr/lib/${PN}/.data
cp -R ${WORKDIR}/fake_windows ${D}/usr/lib/${PN}/.data
cp ${FILESDIR}/${P}-config ${D}/usr/lib/${PN}/.data/config
@@ -89,7 +84,7 @@ src_install () {
cp ${WORKDIR}/wine/winedefault.reg ${D}/usr/lib/${PN}/.data/winedefault.reg
# Install the wrapper script
- mkdir ${D}/usr/bin
+ dodir /usr/bin
cp ${FILESDIR}/${P}-winex ${D}/usr/bin/winex
cp ${FILESDIR}/${P}-regedit ${D}/usr/bin/regedit-winex
@@ -121,4 +116,3 @@ pkg_postinst() {
einfo "Manpage has been installed to the system."
einfo "\"man winex\" should show it."
}
-