summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-07-02 23:05:41 +0000
committerMike Frysinger <vapier@gentoo.org>2003-07-02 23:05:41 +0000
commit89462f06803fc015a03f088b65becd741c37a716 (patch)
tree73ced2135c81056459153e54fc65495d17a5c437 /app-emulation/winex-cvs
parenttweaks for desktop entry maker (diff)
downloadgentoo-2-89462f06803fc015a03f088b65becd741c37a716.tar.gz
gentoo-2-89462f06803fc015a03f088b65becd741c37a716.tar.bz2
gentoo-2-89462f06803fc015a03f088b65becd741c37a716.zip
threaded perl fix
Diffstat (limited to 'app-emulation/winex-cvs')
-rw-r--r--app-emulation/winex-cvs/ChangeLog5
-rw-r--r--app-emulation/winex-cvs/Manifest14
-rw-r--r--app-emulation/winex-cvs/winex-cvs-3.1.ebuild12
3 files changed, 22 insertions, 9 deletions
diff --git a/app-emulation/winex-cvs/ChangeLog b/app-emulation/winex-cvs/ChangeLog
index c4e6e2d91eb3..51b65dea0156 100644
--- a/app-emulation/winex-cvs/ChangeLog
+++ b/app-emulation/winex-cvs/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for app-emulation/winex-cvs
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/ChangeLog,v 1.14 2003/06/24 18:40:53 coronalvr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/ChangeLog,v 1.15 2003/07/02 23:05:37 vapier Exp $
*winex-cvs-3.1 (24 Jun 2003)
+ 02 Jul 2003; Svyatogor <svyatogor@gentoo.org> :
+ Added threaded perl fix.
+
24 Jun 2003; Alex Veber <coronalvr@gentoo.org> winex-cvs-3.1.ebuild:
version bump.
diff --git a/app-emulation/winex-cvs/Manifest b/app-emulation/winex-cvs/Manifest
index 4de73e8e1b59..c8ac4a3a21bb 100644
--- a/app-emulation/winex-cvs/Manifest
+++ b/app-emulation/winex-cvs/Manifest
@@ -1,11 +1,11 @@
-MD5 3711d6142994356772611b47413366fe winex-cvs-3.1.ebuild 4279
-MD5 a72aff1af2fed78b4d9bfd663f2bb1b4 winex-cvs-2.2.1.ebuild 4012
-MD5 9479c013a2ef1ad461594f972237a543 winex-cvs-3.0.ebuild 4277
-MD5 4c6bf0d441d1ff5b77023cf2e7898537 ChangeLog 4812
-MD5 dcdbcea3b1e30203a037de864aee829d files/winex-cvs-fake_windows.tar.bz2 546
-MD5 6b63a4e1f7384c6dbb53e53f09198665 files/winex-cvs-regedit 516
-MD5 a0f00bd1db2d0bc928d3845f4aac078a files/winex-cvs-winex 1244
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-winex-cvs-3.0 0
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-winex-cvs-3.1 0
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-winex-cvs-2.2.1 0
+MD5 dcdbcea3b1e30203a037de864aee829d files/winex-cvs-fake_windows.tar.bz2 546
+MD5 6b63a4e1f7384c6dbb53e53f09198665 files/winex-cvs-regedit 516
+MD5 a0f00bd1db2d0bc928d3845f4aac078a files/winex-cvs-winex 1244
MD5 190b622ae744fb68561764ce1b2d9f1d files/winex-cvs-3.0_pre1.patch 287
+MD5 9479c013a2ef1ad461594f972237a543 winex-cvs-3.0.ebuild 4277
+MD5 2910e63f6bed83b9b3a633a6e1d34b57 winex-cvs-3.1.ebuild 4556
+MD5 a72aff1af2fed78b4d9bfd663f2bb1b4 winex-cvs-2.2.1.ebuild 4012
+MD5 1422747ff4dbc5c2599552a9e075c322 ChangeLog 4887
diff --git a/app-emulation/winex-cvs/winex-cvs-3.1.ebuild b/app-emulation/winex-cvs/winex-cvs-3.1.ebuild
index c7475429b492..2da138a10050 100644
--- a/app-emulation/winex-cvs/winex-cvs-3.1.ebuild
+++ b/app-emulation/winex-cvs/winex-cvs-3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/winex-cvs-3.1.ebuild,v 1.1 2003/06/24 18:40:53 coronalvr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/winex-cvs-3.1.ebuild,v 1.2 2003/07/02 23:05:37 vapier Exp $
IUSE="cups opengl"
@@ -48,6 +48,16 @@ newdepend "sys-devel/gcc
opengl? ( virtual/opengl )
cups? ( net-print/cups )"
+src_unpack() {
+ if ! [ -z "`perl -V:archname 2> /dev/null | grep 'thread-multi'`" ]
+ then
+ eerror "Sorry - can't build winex against threaded perl!"
+ eerror "Please remerge perl and libperl WITHOUT 'USE=threads'"
+ die "Not compatible with threaded perl"
+ fi
+ cvs_src_unpack
+}
+
src_compile() {
cd ${S}
local myconf