summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Jones <cretin@gentoo.org>2002-11-13 18:20:43 +0000
committerStefan Jones <cretin@gentoo.org>2002-11-13 18:20:43 +0000
commit085b6450faebe68fb1c8b9a8c94a2515bc1afae5 (patch)
treea658d127696e9e2fec3af3bcd301586e0ebe0bf8 /app-emulation/winex-cvs
parentmore fixors (diff)
downloadgentoo-2-085b6450faebe68fb1c8b9a8c94a2515bc1afae5.tar.gz
gentoo-2-085b6450faebe68fb1c8b9a8c94a2515bc1afae5.tar.bz2
gentoo-2-085b6450faebe68fb1c8b9a8c94a2515bc1afae5.zip
winex-cvs 2.2.1
Diffstat (limited to 'app-emulation/winex-cvs')
-rw-r--r--app-emulation/winex-cvs/ChangeLog9
-rw-r--r--app-emulation/winex-cvs/winex-cvs-2.2.1.ebuild130
2 files changed, 138 insertions, 1 deletions
diff --git a/app-emulation/winex-cvs/ChangeLog b/app-emulation/winex-cvs/ChangeLog
index 9c6a6e03bda1..d3aa21d3cb70 100644
--- a/app-emulation/winex-cvs/ChangeLog
+++ b/app-emulation/winex-cvs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/winex-cvs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/ChangeLog,v 1.6 2002/10/10 15:23:10 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/ChangeLog,v 1.7 2002/11/13 18:20:43 cretin Exp $
+
+*winex-cvs-2.2.1 (13 Nov 2002)
+
+ 13 Nov 2002; Stefan Jones<cretin@gentoo.org> winex-cvs-2.2.1.ebuild :
+
+ Added winex-cvs.2.2.1 and fixed bug in regex for cvs tag use //./- not
+ /./-
*winex-cvs-2.2 (10 October 2002)
diff --git a/app-emulation/winex-cvs/winex-cvs-2.2.1.ebuild b/app-emulation/winex-cvs/winex-cvs-2.2.1.ebuild
new file mode 100644
index 000000000000..3527967682dc
--- /dev/null
+++ b/app-emulation/winex-cvs/winex-cvs-2.2.1.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-cvs/winex-cvs-2.2.1.ebuild,v 1.1 2002/11/13 18:20:43 cretin Exp $
+
+IUSE="cups opengl"
+
+# Dont modify the ECVS_BRANCH setting yourself.
+# Instead, make a backup of this ebuild and rename it to
+# winex-[your branch].ebuild.
+#
+# Example:
+# winex-kohan-2.1.ebuild
+#
+# You can find more branches on
+# http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/winex/wine/
+
+
+ECVS_SERVER="cvs.winex.sourceforge.net:/cvsroot/winex"
+ECVS_MODULE="wine"
+ECVS_BRANCH=${PN/cvs/}${PV//./-}
+ECVS_TOP_DIR="${DISTDIR}/cvs-src/${ECVS_BRANCH}"
+
+inherit cvs
+
+S=${WORKDIR}/${ECVS_MODULE}
+DESCRIPTION="WineX is a distribution of Wine with enhanced DirectX for gaming.
+ This ebuild will fetch the newest cvs sources from the cvs-server."
+HOMEPAGE="http://www.transgaming.com/"
+
+SLOT="0"
+KEYWORDS="x86 -ppc"
+LICENSE="Aladdin"
+
+newdepend "virtual/x11
+ sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ >=media-libs/freetype-2.0.0
+ dev-lang/tcl dev-lang/tk
+ opengl? ( virtual/opengl )
+ cups? ( net-print/cups )"
+
+src_compile() {
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+
+ # the folks at #winehq were really angry about custom optimization
+ unset CFLAGS
+ unset CXXFLAGS
+
+ ./configure --prefix=/usr/lib/winex-cvs \
+ --sysconfdir=/etc/winex-cvs \
+ --host=${CHOST} \
+ --enable-curses \
+ --with-x \
+ ${myconf} || die "configure failed"
+
+ # Fixes a winetest issue
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ # This persuades wineshelllink that "winex-cvs" is a better loader :)
+ cd ${S}/tools
+ cp wineshelllink 1
+ sed -e 's/\(WINE_LOADER=\)\(\${WINE_LOADER:-wine}\)/\1winex-cvs/' 1 > wineshelllink
+
+ cd ${S}
+ make depend all || die "make depend all failed"
+ cd programs && emake || die "emake died"
+}
+
+src_install () {
+ local WINEXMAKEOPTS="prefix=${D}/usr/lib/winex-cvs"
+
+ # Installs winex to /usr/lib/winex-cvs
+ cd ${S}
+ make ${WINEXMAKEOPTS} install || die "make install failed"
+ cd ${S}/programs
+ make ${WINEXMAKEOPTS} install || die "make install failed"
+
+
+ # Creates /usr/lib/winex-cvs/.data with fake_windows in it
+ # This is needed for our new winex-cvs wrapper script
+ mkdir ${D}/usr/lib/winex-cvs/.data
+ pushd ${D}/usr/lib/winex-cvs/.data
+ tar jxvf ${FILESDIR}/${PN}-fake_windows.tar.bz2
+ popd
+ cp ${S}/documentation/samples/config ${S}/documentation/samples/config.orig
+ sed -e 's/"Path" = "\/c"/"Path" = "\$\{HOME\}\/.winex-cvs\/fake_windows"/' \
+ ${S}/documentation/samples/config.orig > ${S}/documentation/samples/config
+ cp ${S}/documentation/samples/config ${D}/usr/lib/winex-cvs/.data/config
+ cp ${WORKDIR}/wine/winedefault.reg ${D}/usr/lib/winex-cvs/.data/winedefault.reg
+ # Install the wrapper script
+ mkdir ${D}/usr/bin
+ cp ${FILESDIR}/${PN}-winex ${D}/usr/bin/winex-cvs
+ cp ${FILESDIR}/${PN}-regedit ${D}/usr/bin/regedit-winex-cvs
+
+ # Take care of the other stuff
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ insinto /usr/lib/winex-cvs/.data/fake_windows/Windows
+ doins documentation/samples/system.ini
+ doins documentation/samples/generic.ppd
+
+ # Manpage setup
+ cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
+
+ # Remove the executable flag from those libraries.
+ cd ${D}/usr/lib/winex-cvs/bin
+ chmod a-x *.so
+
+}
+
+pkg_postinst() {
+ einfo "Use /usr/bin/winex-cvs to start winex."
+ einfo "This is a wrapper-script which will take care of everything"
+ einfo "else. If you have further questions, enhancements or patches"
+ einfo "send an email to phoenix@gentoo.org"
+ einfo ""
+ einfo "Manpage has been installed to the system."
+ einfo "\"man winex-cvs\" should show it."
+}
+