summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-09-22 12:48:28 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-09-22 12:48:28 +0000
commit0714249c5b1041c69562a253ffed9fa7e837efe1 (patch)
treed1aea0d73121a73c18d57bc98ef3af79b0cae424 /app-emulation/winetricks
parentGoodbye to custom-cflags, cleanup a bit. (diff)
downloadgentoo-2-0714249c5b1041c69562a253ffed9fa7e837efe1.tar.gz
gentoo-2-0714249c5b1041c69562a253ffed9fa7e837efe1.tar.bz2
gentoo-2-0714249c5b1041c69562a253ffed9fa7e837efe1.zip
Update to eapi4. Bump to the latest release, fixes crash for me when installing dontnet stuff, remove older.
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/winetricks')
-rw-r--r--app-emulation/winetricks/ChangeLog9
-rw-r--r--app-emulation/winetricks/winetricks-185.ebuild22
-rw-r--r--app-emulation/winetricks/winetricks-696.ebuild (renamed from app-emulation/winetricks/winetricks-672.ebuild)10
-rw-r--r--app-emulation/winetricks/winetricks-99999999.ebuild10
4 files changed, 20 insertions, 31 deletions
diff --git a/app-emulation/winetricks/ChangeLog b/app-emulation/winetricks/ChangeLog
index 7875e09da89e..22206d3f0564 100644
--- a/app-emulation/winetricks/ChangeLog
+++ b/app-emulation/winetricks/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/winetricks
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winetricks/ChangeLog,v 1.2 2011/07/05 21:29:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winetricks/ChangeLog,v 1.3 2011/09/22 12:48:28 scarabeus Exp $
+
+*winetricks-696 (22 Sep 2011)
+
+ 22 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org> -winetricks-185.ebuild,
+ -winetricks-672.ebuild, +winetricks-696.ebuild, winetricks-99999999.ebuild:
+ Update to eapi4. Bump to the latest release, fixes crash for me when
+ installing dontnet stuff, remove older.
*winetricks-99999999 (05 Jul 2011)
*winetricks-672 (05 Jul 2011)
diff --git a/app-emulation/winetricks/winetricks-185.ebuild b/app-emulation/winetricks/winetricks-185.ebuild
deleted file mode 100644
index 5fd1876c6235..000000000000
--- a/app-emulation/winetricks/winetricks-185.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winetricks/winetricks-185.ebuild,v 1.1 2011/03/01 02:35:56 vapier Exp $
-
-EAPI="2"
-
-DESCRIPTION="easy way to install DLLs needed to work around problems in Wine"
-HOMEPAGE="http://code.google.com/p/winetricks/ http://wiki.winehq.org/winetricks"
-SRC_URI="http://winetricks.googlecode.com/svn-history/r${PV}/trunk/src/winetricks-alpha -> ${P}"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-src_unpack() {
- cp "${DISTDIR}"/${P} ${PN} || die
-}
-
-src_install() {
- dobin ${PN} || die
-}
diff --git a/app-emulation/winetricks/winetricks-672.ebuild b/app-emulation/winetricks/winetricks-696.ebuild
index f14df0f46382..8cd817464c92 100644
--- a/app-emulation/winetricks/winetricks-672.ebuild
+++ b/app-emulation/winetricks/winetricks-696.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winetricks/winetricks-672.ebuild,v 1.1 2011/07/05 21:29:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winetricks/winetricks-696.ebuild,v 1.1 2011/09/22 12:48:28 scarabeus Exp $
-EAPI="2"
+EAPI=4
if [[ ${PV} == "99999999" ]] ; then
ESVN_REPO_URI="http://winetricks.googlecode.com/svn/trunk"
@@ -25,6 +25,8 @@ RDEPEND="app-emulation/wine
gtk? ( gnome-extra/zenity )
kde? ( kde-base/kdialog )"
+S="${WORKDIR}"
+
src_unpack() {
if [[ ${PV} == "99999999" ]] ; then
subversion_src_unpack
@@ -37,6 +39,6 @@ src_unpack() {
src_install() {
cd src
- dobin ${PN} || die
- doman ${PN}.1 || die
+ dobin ${PN}
+ doman ${PN}.1
}
diff --git a/app-emulation/winetricks/winetricks-99999999.ebuild b/app-emulation/winetricks/winetricks-99999999.ebuild
index 203b88561578..5825a09f2de1 100644
--- a/app-emulation/winetricks/winetricks-99999999.ebuild
+++ b/app-emulation/winetricks/winetricks-99999999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winetricks/winetricks-99999999.ebuild,v 1.1 2011/07/05 21:29:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winetricks/winetricks-99999999.ebuild,v 1.2 2011/09/22 12:48:28 scarabeus Exp $
-EAPI="2"
+EAPI=4
if [[ ${PV} == "99999999" ]] ; then
ESVN_REPO_URI="http://winetricks.googlecode.com/svn/trunk"
@@ -25,6 +25,8 @@ RDEPEND="app-emulation/wine
gtk? ( gnome-extra/zenity )
kde? ( kde-base/kdialog )"
+S="${WORKDIR}"
+
src_unpack() {
if [[ ${PV} == "99999999" ]] ; then
subversion_src_unpack
@@ -37,6 +39,6 @@ src_unpack() {
src_install() {
cd src
- dobin ${PN} || die
- doman ${PN}.1 || die
+ dobin ${PN}
+ doman ${PN}.1
}