summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-12 21:06:16 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-12 21:06:16 +0000
commita87ec190a570e6af6e2d32a1d2f812119c37fc38 (patch)
tree58e17c6713dbbd9d0f396308bc11bac3fb835df7 /app-emulation/winetricks/winetricks-881.ebuild
parentBump to EAPI 4; use the new rspec recipe for testing, and stop using bundler ... (diff)
downloadgentoo-2-a87ec190a570e6af6e2d32a1d2f812119c37fc38.tar.gz
gentoo-2-a87ec190a570e6af6e2d32a1d2f812119c37fc38.tar.bz2
gentoo-2-a87ec190a570e6af6e2d32a1d2f812119c37fc38.zip
Version bump, drop old. Capitalize description.
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/winetricks/winetricks-881.ebuild')
-rw-r--r--app-emulation/winetricks/winetricks-881.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-emulation/winetricks/winetricks-881.ebuild b/app-emulation/winetricks/winetricks-881.ebuild
new file mode 100644
index 000000000000..ece7cabf20c7
--- /dev/null
+++ b/app-emulation/winetricks/winetricks-881.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winetricks/winetricks-881.ebuild,v 1.1 2012/08/12 21:06:16 tetromino Exp $
+
+EAPI=4
+
+if [[ ${PV} == "99999999" ]] ; then
+ ESVN_REPO_URI="http://winetricks.googlecode.com/svn/trunk"
+ inherit subversion
+else
+ SRC_URI="http://winetricks.googlecode.com/svn-history/r${PV}/trunk/src/winetricks -> ${P}
+ http://winetricks.googlecode.com/svn-history/r${PV}/trunk/src/winetricks.1 -> ${P}.1"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Easy way to install DLLs needed to work around problems in Wine"
+HOMEPAGE="http://code.google.com/p/winetricks/ http://wiki.winehq.org/winetricks"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="gtk kde"
+
+DEPEND=""
+RDEPEND="app-emulation/wine
+ gtk? ( gnome-extra/zenity )
+ kde? ( kde-base/kdialog )"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ subversion_src_unpack
+ else
+ mkdir src
+ cp "${DISTDIR}"/${P} src/${PN} || die
+ cp "${DISTDIR}"/${P}.1 src/${PN}.1 || die
+ fi
+}
+
+src_install() {
+ cd src
+ dobin ${PN}
+ doman ${PN}.1
+}