summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-10-25 05:47:08 +0000
committerMike Frysinger <vapier@gentoo.org>2009-10-25 05:47:08 +0000
commitdcb8c6fe4546b93068cc52f6ff6289e7d76ab1c6 (patch)
treee275847c1a998b42e4008a7473b38915aa830197 /app-emulation/wine
parentVersion bump #290394 by Lars Wendler. (diff)
downloadgentoo-2-dcb8c6fe4546b93068cc52f6ff6289e7d76ab1c6.tar.gz
gentoo-2-dcb8c6fe4546b93068cc52f6ff6289e7d76ab1c6.tar.bz2
gentoo-2-dcb8c6fe4546b93068cc52f6ff6289e7d76ab1c6.zip
Version bump #290400 by kisak42.
(Portage version: 2.2_rc46/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/ChangeLog7
-rw-r--r--app-emulation/wine/wine-1.1.32.ebuild156
2 files changed, 162 insertions, 1 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 053d108bf1f2..bb6a18c50a52 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.282 2009/10/19 01:41:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.283 2009/10/25 05:47:08 vapier Exp $
+
+*wine-1.1.32 (25 Oct 2009)
+
+ 25 Oct 2009; Mike Frysinger <vapier@gentoo.org> +wine-1.1.32.ebuild:
+ Version bump #290400 by kisak42.
*wine-1.1.31 (19 Oct 2009)
diff --git a/app-emulation/wine/wine-1.1.32.ebuild b/app-emulation/wine/wine-1.1.32.ebuild
new file mode 100644
index 000000000000..ba599988f916
--- /dev/null
+++ b/app-emulation/wine/wine-1.1.32.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.32.ebuild,v 1.1 2009/10/25 05:47:08 vapier Exp $
+
+EAPI="2"
+
+inherit multilib eutils
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://source.winehq.org/git/wine.git"
+ inherit git
+ SRC_URI=""
+ KEYWORDS=""
+else
+ MY_P="${PN}-${PV/_/-}"
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+ KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
+ S=${WORKDIR}/${MY_P}
+fi
+
+GV="1.0.0-x86"
+DESCRIPTION="free implementation of Windows(tm) on Unix"
+HOMEPAGE="http://www.winehq.org/"
+SRC_URI="${SRC_URI}
+ gecko? ( mirror://sourceforge/wine/wine_gecko-${GV}.cab )"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="alsa capi cups dbus esd fontconfig +gecko gnutls gphoto2 gsm hal jack jpeg lcms ldap mp3 nas ncurses openal +opengl oss +perl png samba scanner ssl test +threads win64 +X xcomposite xinerama xml"
+RESTRICT="test" #72375
+
+RDEPEND=">=media-libs/freetype-2.0.0
+ media-fonts/corefonts
+ perl? ( dev-lang/perl dev-perl/XML-Simple )
+ capi? ( net-dialup/capi4k-utils )
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ fontconfig? ( media-libs/fontconfig )
+ gphoto2? ( media-libs/libgphoto2 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ openal? ( media-libs/openal )
+ dbus? ( sys-apps/dbus )
+ gnutls? ( net-libs/gnutls )
+ hal? ( sys-apps/hal )
+ X? (
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86vm
+ x11-apps/xmessage
+ )
+ alsa? ( media-libs/alsa-lib )
+ esd? ( media-sound/esound )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )
+ gsm? ( media-sound/gsm )
+ jpeg? ( media-libs/jpeg )
+ ldap? ( net-nds/openldap )
+ lcms? ( media-libs/lcms )
+ mp3? ( media-sound/mpg123 )
+ samba? ( >=net-fs/samba-3.0.25 )
+ xml? ( dev-libs/libxml2 dev-libs/libxslt )
+ scanner? ( media-gfx/sane-backends )
+ ssl? ( dev-libs/openssl )
+ png? ( media-libs/libpng )
+ win64? ( >=sys-devel/gcc-4.4.0 )
+ !win64? ( amd64? (
+ X? (
+ >=app-emulation/emul-linux-x86-xlibs-2.1
+ >=app-emulation/emul-linux-x86-soundlibs-2.1
+ )
+ app-emulation/emul-linux-x86-baselibs
+ >=sys-kernel/linux-headers-2.6
+ ) )"
+DEPEND="${RDEPEND}
+ X? (
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto
+ )
+ sys-devel/bison
+ sys-devel/flex"
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ git_src_unpack
+ else
+ unpack ${MY_P}.tar.bz2
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
+ epatch_user #282735
+ sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
+ sed -i '/^MimeType/d' tools/wine.desktop || die #117785
+}
+
+src_configure() {
+ export LDCONFIG=/bin/true
+
+ use amd64 && ! use win64 && multilib_toolchain_setup x86
+
+ econf \
+ --sysconfdir=/etc/wine \
+ $(use_with alsa) \
+ $(use_with capi) \
+ $(use_with lcms cms) \
+ $(use_with cups) \
+ $(use_with ncurses curses) \
+ $(use_with esd) \
+ $(use_with fontconfig) \
+ $(use_with gnutls) \
+ $(use_with gphoto2 gphoto) \
+ $(use_with gsm) \
+ $(! use dbus && echo --without-hal || use_with hal) \
+ $(use_with jack) \
+ $(use_with jpeg) \
+ $(use_with ldap) \
+ $(use_with mp3 mpg123) \
+ $(use_with nas) \
+ $(use_with openal) \
+ $(use_with opengl) \
+ $(use_with ssl openssl) \
+ $(use_with oss) \
+ $(use_with png) \
+ $(use_with threads pthread) \
+ $(use_with scanner sane) \
+ $(use_enable test tests) \
+ $(use_enable win64) \
+ $(use_with X x) \
+ $(use_with xcomposite) \
+ $(use_with xinerama) \
+ $(use_with xml) \
+ $(use_with xml xslt) \
+ || die "configure failed"
+
+ emake -j1 depend || die "depend"
+}
+
+src_compile() {
+ emake all || die "all"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ANNOUNCE AUTHORS README
+ if use gecko ; then
+ insinto /usr/share/wine/gecko
+ doins "${DISTDIR}"/wine_gecko-${GV}.cab || die
+ fi
+ if ! use perl ; then
+ rm "${D}"/usr/bin/{wine{dump,maker},function_grep.pl} "${D}"/usr/share/man/man1/wine{dump,maker}.1 || die
+ fi
+}