summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Veber <coronalvr@gentoo.org>2003-12-15 09:00:51 +0000
committerAlex Veber <coronalvr@gentoo.org>2003-12-15 09:00:51 +0000
commitb5d53920a09a0572cf862082a9bb8221f7e027bc (patch)
treec7f4073c1ace9dcb7376d3d160df9510b05e996b /app-emulation/wine
parentVersion Bump. (diff)
downloadgentoo-2-b5d53920a09a0572cf862082a9bb8221f7e027bc.tar.gz
gentoo-2-b5d53920a09a0572cf862082a9bb8221f7e027bc.tar.bz2
gentoo-2-b5d53920a09a0572cf862082a9bb8221f7e027bc.zip
Version Bump.
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/ChangeLog7
-rw-r--r--app-emulation/wine/Manifest4
-rw-r--r--app-emulation/wine/files/digest-wine-200312123
-rw-r--r--app-emulation/wine/wine-20031212.ebuild124
4 files changed, 135 insertions, 3 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index f8576e120ff2..e076b1cc8634 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/wine
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.61 2003/12/15 06:00:40 coronalvr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.62 2003/12/15 09:00:40 coronalvr Exp $
+
+*wine-20031212 (15 Dec 2003)
+
+ 15 Dec 2003; Alex Veber <coronalvr@gentoo.org> wine-20031212.ebuild:
+ Version Bump
15 Dec 2003; Alex Veber <coronalvr@gentoo.org> wine-20031118-r1.ebuild:
Bump to stable.
diff --git a/app-emulation/wine/Manifest b/app-emulation/wine/Manifest
index f6b8f91791bb..6278738a1e4a 100644
--- a/app-emulation/wine/Manifest
+++ b/app-emulation/wine/Manifest
@@ -1,7 +1,7 @@
MD5 876f02ad3c4f03281fcb66855ca497d0 wine-20031016.ebuild 3320
-MD5 adf12abcd4f7b6e8dfbc440607c2bb56 wine-20031212.ebuild 3266
+MD5 c6c6cec8c96c05d2933e62f1772772a8 wine-20031212.ebuild 3265
MD5 dfb90e5e211bca76f4770a8e1c8f0415 wine-20031118-r1.ebuild 3398
-MD5 e205413f84b404aa688693b6f46834e7 ChangeLog 11203
+MD5 c8611ae4805a255ed67e1dc1f2ee700a ChangeLog 11320
MD5 6525c48ba09d08599432ea6c299e52f4 metadata.xml 354
MD5 1668a758aa2007cb99a773b3c5c844c9 files/winearts-kdecvs-fix.patch 325
MD5 b5307649654483532930907b0485eaf0 files/wine-alsa.patch 86359
diff --git a/app-emulation/wine/files/digest-wine-20031212 b/app-emulation/wine/files/digest-wine-20031212
new file mode 100644
index 000000000000..4bc30df3b6ef
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20031212
@@ -0,0 +1,3 @@
+MD5 eaac8e7f9864d4c4069cfb2b202e22a5 Wine-20031212.tar.gz 9691334
+MD5 af8da46a0e51578ff1e18e399141d628 wine-20031212-fake_windows.tar.bz2 500
+MD5 159cee5f32139d05df410945aeca3f69 wine-20031212-misc.tar.bz2 5166
diff --git a/app-emulation/wine/wine-20031212.ebuild b/app-emulation/wine/wine-20031212.ebuild
new file mode 100644
index 000000000000..1724baca8059
--- /dev/null
+++ b/app-emulation/wine/wine-20031212.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20031212.ebuild,v 1.1 2003/12/15 09:00:40 coronalvr Exp $
+
+inherit eutils base
+
+DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
+HOMEPAGE="http://www.winehq.com/"
+SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz
+ mirror://gentoo/${P}-fake_windows.tar.bz2
+ mirror://gentoo/${PF}-misc.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc"
+IUSE="nas arts cups opengl alsa tcltk nptl debug"
+
+DEPEND="sys-devel/gcc
+ sys-devel/flex
+ >=sys-libs/ncurses-5.2
+ >=media-libs/freetype-2.0.0
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tcl dev-lang/tk )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )"
+
+src_unpack() {
+ unpack Wine-${PV}.tar.gz
+ cd ${S}
+ epatch ${FILESDIR}/winearts-kdecvs-fix.patch
+}
+
+src_compile() {
+ # there's no configure flag for cups, arts, alsa and nas, it's supposed to be autodetected
+
+ unset CFLAGS CXXFLAGS
+
+ ac_cv_header_jack_jack_h=no \
+ ac_cv_lib_soname_jack= \
+ ./configure \
+ --prefix=/usr/lib/wine \
+ --sysconfdir=/etc/wine \
+ --host=${CHOST} \
+ --enable-curses \
+ `use_enable opengl` \
+ `use_with nptl` \
+ `use_enable debug trace` \
+ `use_enable debug` \
+ || die "configure failed"
+
+ cd ${S}/programs/winetest
+ sed -i 's:wine.pm:include/wine.pm:' Makefile
+
+ # No parallel make
+ cd ${S}
+ make depend all || die
+ cd programs && emake || die
+}
+
+src_install() {
+ local WINEMAKEOPTS="prefix=${D}/usr/lib/wine"
+
+ ### Install wine to ${D}
+ make ${WINEMAKEOPTS} install || die
+ cd ${S}/programs
+ make ${WINEMAKEOPTS} install || die
+
+ # Needed for later installation
+ dodir /usr/bin
+
+ ### Creation of /usr/lib/wine/.data
+ # Setting up fake_windows
+ dodir /usr/lib/wine/.data
+ cd ${D}/usr/lib/wine/.data
+ tar jxvf ${DISTDIR}/${P}-fake_windows.tar.bz2
+ chown root:root fake_windows/ -R
+
+ # Unpacking the miscellaneous files
+ tar jxvf ${DISTDIR}/${PF}-misc.tar.bz2
+ chown root:root config
+
+ # moving the wrappers to bin/
+ insinto /usr/bin
+ dobin regedit-wine wine winedbg
+ rm regedit-wine wine winedbg
+
+ # copying the winedefault.reg into .data
+ insinto /usr/lib/wine/.data
+ doins ${WORKDIR}/${P}/winedefault.reg
+
+ # Set up this dynamic data
+ cd ${S}
+ insinto /usr/lib/wine/.data/fake_windows/Windows
+ doins documentation/samples/system.ini
+ doins documentation/samples/generic.ppd
+ ## Setup of .data complete
+
+ ### Misc tasks
+ # Take care of the documentation
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ # Manpage setup
+ cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man5/wine.conf.5
+ rm ${D}/usr/lib/${PN}/man/man5/wine.conf.5
+
+ # Remove the executable flag from those libraries.
+ cd ${D}/usr/lib/wine/lib/wine
+ chmod a-x *.so
+}
+
+pkg_postinst() {
+ einfo "Use /usr/bin/wine to start wine. This is a wrapper-script"
+ einfo "which will take care of everything else."
+ einfo ""
+ einfo "Use /usr/bin/regedit-wine to import registry files into the"
+ einfo "wine registry."
+}