summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-01-11 20:03:50 +0000
committerMike Frysinger <vapier@gentoo.org>2008-01-11 20:03:50 +0000
commit9a9514c49f6145d7629efdac09ffd5af53ce2152 (patch)
treeba70a6d5817106269c8bb2e82c12238068e7f681 /app-emulation/wine
parentAdded patch to fix compile when not using alsa. (diff)
downloadgentoo-2-9a9514c49f6145d7629efdac09ffd5af53ce2152.tar.gz
gentoo-2-9a9514c49f6145d7629efdac09ffd5af53ce2152.tar.bz2
gentoo-2-9a9514c49f6145d7629efdac09ffd5af53ce2152.zip
Version bump.
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/ChangeLog9
-rw-r--r--app-emulation/wine/files/digest-wine-0.9.536
-rw-r--r--app-emulation/wine/wine-0.9.53.ebuild133
3 files changed, 146 insertions, 2 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index ce2be648a54e..20024c77a08a 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/wine
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.200 2007/12/29 11:11:49 vapier Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.201 2008/01/11 20:03:50 vapier Exp $
+
+*wine-0.9.53 (11 Jan 2008)
+
+ 11 Jan 2008; Mike Frysinger <vapier@gentoo.org> +wine-0.9.53.ebuild:
+ Version bump.
29 Dec 2007; Mike Frysinger <vapier@gentoo.org> wine-0.9.52.ebuild:
Add USE=samba to force lazy people to upgrade their samba #195621 and
diff --git a/app-emulation/wine/files/digest-wine-0.9.53 b/app-emulation/wine/files/digest-wine-0.9.53
new file mode 100644
index 000000000000..d9389917e659
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-0.9.53
@@ -0,0 +1,6 @@
+MD5 48fe690c6f37302401adde4cf5db7c19 wine-0.9.53.tar.bz2 13064017
+RMD160 19f0596d987b1b7da8b33c98e84c6484ad6914ae wine-0.9.53.tar.bz2 13064017
+SHA256 06317d78b7db39458656b6acc6b265ce97f358aefd7ded679263f397a89f1200 wine-0.9.53.tar.bz2 13064017
+MD5 b188c296f045d20abdb11e9c0564894b wine_gecko-0.1.0.cab 5746895
+RMD160 61f85ee39e96f88783541460d2fce31db7cc0183 wine_gecko-0.1.0.cab 5746895
+SHA256 4ef0bffa49a9abc86f74257aa8d7f5db806e8e8bd780149244149aa3f9292d10 wine_gecko-0.1.0.cab 5746895
diff --git a/app-emulation/wine/wine-0.9.53.ebuild b/app-emulation/wine/wine-0.9.53.ebuild
new file mode 100644
index 000000000000..e28acb3133c3
--- /dev/null
+++ b/app-emulation/wine/wine-0.9.53.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.53.ebuild,v 1.1 2008/01/11 20:03:50 vapier Exp $
+
+EAPI="1"
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="free implementation of Windows(tm) on Unix"
+HOMEPAGE="http://www.winehq.com/"
+SRC_URI="mirror://sourceforge/${PN}/wine-${PV}.tar.bz2
+ gecko? ( mirror://sourceforge/wine/wine_gecko-0.1.0.cab )"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
+IUSE="alsa cups dbus esd +gecko hal jack jpeg lcms ldap nas ncurses +opengl oss samba scanner xml +X"
+RESTRICT="test" #72375
+
+RDEPEND=">=media-libs/freetype-2.0.0
+ media-fonts/corefonts
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ dbus? ( sys-apps/dbus )
+ hal? ( sys-apps/hal )
+ X? (
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86vm
+ x11-apps/xmessage
+ )
+ alsa? ( media-libs/alsa-lib )
+ esd? ( media-sound/esound )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )
+ jpeg? ( media-libs/jpeg )
+ ldap? ( net-nds/openldap )
+ lcms? ( media-libs/lcms )
+ samba? ( >=net-fs/samba-3.0.25 )
+ xml? ( dev-libs/libxml2 dev-libs/libxslt )
+ >=media-gfx/fontforge-20060703
+ scanner? ( media-gfx/sane-backends )
+ amd64? (
+ >=app-emulation/emul-linux-x86-xlibs-2.1
+ >=app-emulation/emul-linux-x86-soundlibs-2.1
+ >=sys-kernel/linux-headers-2.6
+ )"
+DEPEND="${RDEPEND}
+ X? (
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto
+ )
+ sys-devel/bison
+ sys-devel/flex"
+
+pkg_setup() {
+ use alsa || return 0
+ if ! built_with_use --missing true media-libs/alsa-lib midi ; then
+ eerror "You must build media-libs/alsa-lib with USE=midi"
+ die "please re-emerge media-libs/alsa-lib with USE=midi"
+ fi
+}
+
+src_unpack() {
+ unpack wine-${PV}.tar.bz2
+ cd "${S}"
+
+ sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
+ epatch "${FILESDIR}"/wine-gentoo-no-ssp.patch #66002
+ sed -i '/^MimeType/d' tools/wine.desktop || die #117785
+}
+
+config_cache() {
+ local h ans="no"
+ use $1 && ans="yes"
+ shift
+ for h in "$@" ; do
+ [[ ${h} == *.h ]] \
+ && h=header_${h} \
+ || h=lib_${h}
+ export ac_cv_${h//[:\/.]/_}=${ans}
+ done
+}
+
+src_compile() {
+ export LDCONFIG=/bin/true
+ use esd || export ac_cv_path_ESDCONFIG=""
+ use scanner || export ac_cv_path_sane_devel="no"
+ config_cache jack jack/jack.h
+ config_cache cups cups/cups.h
+ config_cache alsa alsa/asoundlib.h sys/asoundlib.h asound:snd_pcm_open
+ config_cache nas audio/audiolib.h audio/soundlib.h
+ config_cache xml libxml/parser.h libxslt/pattern.h libxslt/transform.h
+ config_cache ldap ldap.h lber.h
+ config_cache dbus dbus/dbus.h
+ config_cache hal hal/libhal.h
+ config_cache jpeg jpeglib.h
+ config_cache oss sys/soundcard.h machine/soundcard.h soundcard.h
+ config_cache lcms lcms.h
+
+ strip-flags
+
+ use amd64 && multilib_toolchain_setup x86
+
+ # $(use_enable amd64 win64)
+ econf \
+ --sysconfdir=/etc/wine \
+ $(use_with ncurses curses) \
+ $(use_with opengl) \
+ $(use_with X x) \
+ || die "configure failed"
+
+ emake -j1 depend || die "depend"
+ emake all || die "all"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ANNOUNCE AUTHORS ChangeLog README
+ if use gecko ; then
+ insinto /usr/share/wine/gecko
+ doins "${DISTDIR}"/wine_gecko-*.cab || die
+ fi
+}
+
+pkg_postinst() {
+ elog "~/.wine/config is now deprecated. For configuration either use"
+ elog "winecfg or regedit HKCU\\Software\\Wine"
+}