summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-07 08:06:43 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-07 08:06:43 +0000
commit7515d888c246748d030a5d700bf5a2f8e183e26c (patch)
tree6fdcf003f3b3aaee2babf3120898a35c11a6afca /app-emulation/wine
parentMove compiler and linker flags to the front so that they actually work. Reall... (diff)
downloadgentoo-2-7515d888c246748d030a5d700bf5a2f8e183e26c.tar.gz
gentoo-2-7515d888c246748d030a5d700bf5a2f8e183e26c.tar.bz2
gentoo-2-7515d888c246748d030a5d700bf5a2f8e183e26c.zip
Bump, see http://www.winehq.org/announce/1.5.10 for the announcement, thanks to Rafał Mużyło (bug #429386). Note that on amd64, osmesa support is for now win64-only.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/ChangeLog10
-rw-r--r--app-emulation/wine/files/wine-1.5.10-osmesa-check.patch33
-rw-r--r--app-emulation/wine/metadata.xml1
-rw-r--r--app-emulation/wine/wine-1.5.10.ebuild249
-rw-r--r--app-emulation/wine/wine-9999.ebuild18
5 files changed, 306 insertions, 5 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 4a49d8cc55ac..97b49f1eeddf 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.422 2012/07/19 13:57:49 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.423 2012/08/07 08:06:43 tetromino Exp $
+
+*wine-1.5.10 (07 Aug 2012)
+
+ 07 Aug 2012; Alexandre Rostovtsev <tetromino@gentoo.org> +wine-1.5.10.ebuild,
+ +files/wine-1.5.10-osmesa-check.patch, wine-9999.ebuild, metadata.xml:
+ Bump, see http://www.winehq.org/announce/1.5.10 for the announcement, thanks
+ to Rafał Mużyło (bug #429386). Note that on amd64, osmesa support is for
+ now win64-only.
19 Jul 2012; Tomáš Chvátal <scarabeus@gentoo.org> wine-1.4.1.ebuild:
Amd64 stable wrt bug#427060.
diff --git a/app-emulation/wine/files/wine-1.5.10-osmesa-check.patch b/app-emulation/wine/files/wine-1.5.10-osmesa-check.patch
new file mode 100644
index 000000000000..86d90ca5bc4c
--- /dev/null
+++ b/app-emulation/wine/files/wine-1.5.10-osmesa-check.patch
@@ -0,0 +1,33 @@
+From a233e35ca650db2758de0fd31450b8ce2d86d5e3 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Tue, 7 Aug 2012 01:29:01 -0400
+Subject: [PATCH] Do not check for libGL symbols when checking libOSMesa
+
+If mesa had been built with shared glapi, glAccum is not available in
+libOSMesa without explicitly linking to libGL. In addition, in
+mesa-8.0.x and earlier, libOSMesa needs to be explicitly linked to
+libglapi if mesa was built with shared glapi, see
+https://bugs.gentoo.org/show_bug.cgi?id=399813
+---
+ configure.ac | 5 ++++-
+ 1 files changed, 4 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 4bd43d1..c7a718f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1132,7 +1132,10 @@ This probably prevents linking to OpenGL. Try deleting the file and restarting c
+
+ if test "$ac_cv_header_GL_osmesa_h" = "yes"
+ then
+- WINE_CHECK_SONAME(OSMesa,glAccum,,,[$X_LIBS $X_PRE_LIBS $XLIB -lm $X_EXTRA_LIBS])
++ WINE_CHECK_SONAME(OSMesa,OSMesaCreateContext,,,[$X_LIBS $X_PRE_LIBS $XLIB -lm $X_EXTRA_LIBS])
++ if test "x$ac_cv_lib_soname_OSMesa" = "x"; then
++ WINE_CHECK_SONAME(OSMesa,OSMesaCreateContext,,,[-lglapi $X_LIBS $X_PRE_LIBS $XLIB -lm $X_EXTRA_LIBS])
++ fi
+ fi
+ WINE_NOTICE_WITH(osmesa,[test "x$ac_cv_lib_soname_OSMesa" = "x"],
+ [libOSMesa ${notice_platform}development files not found (or too old), OpenGL rendering in bitmaps won't be supported.])
+--
+1.7.8.6
+
diff --git a/app-emulation/wine/metadata.xml b/app-emulation/wine/metadata.xml
index 0b3398a84335..0cbb443104d1 100644
--- a/app-emulation/wine/metadata.xml
+++ b/app-emulation/wine/metadata.xml
@@ -13,6 +13,7 @@ Think of Wine as a compatibility layer for running Windows programs. Wine does n
<flag name='gecko'>Add support for the Gecko engine when using iexplore</flag>
<flag name='mono'>Add support for .NET using Wine's Mono add-on</flag>
<flag name='opencl'>Enable OpenCL support</flag>
+ <flag name='osmesa'>Add support for OpenGL in bitmaps using libOSMesa</flag>
<flag name='perl'>Install helpers written in perl (winedump/winemaker)</flag>
<flag name='samba'>Add support for NTLM auth. see
http://wiki.winehq.org/NtlmAuthSetupGuide and
diff --git a/app-emulation/wine/wine-1.5.10.ebuild b/app-emulation/wine/wine-1.5.10.ebuild
new file mode 100644
index 000000000000..2ee37358f0c0
--- /dev/null
+++ b/app-emulation/wine/wine-1.5.10.ebuild
@@ -0,0 +1,249 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.10.ebuild,v 1.1 2012/08/07 08:06:43 tetromino Exp $
+
+EAPI="4"
+
+inherit autotools eutils flag-o-matic multilib pax-utils
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://source.winehq.org/git/wine.git"
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ MY_P="${PN}-${PV/_/-}"
+ SRC_URI="mirror://sourceforge/${PN}/Source/${MY_P}.tar.bz2"
+ KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
+ S=${WORKDIR}/${MY_P}
+fi
+
+GV="1.7"
+MV="0.0.4"
+PULSE_PATCH="winepulse-2012.06.15.patch"
+DESCRIPTION="free implementation of Windows(tm) on Unix"
+HOMEPAGE="http://www.winehq.org/"
+SRC_URI="${SRC_URI}
+ gecko? (
+ mirror://sourceforge/${PN}/Wine%20Gecko/${GV}/wine_gecko-${GV}-x86.msi
+ win64? ( mirror://sourceforge/${PN}/Wine%20Gecko/${GV}/wine_gecko-${GV}-x86_64.msi )
+ )
+ mono? ( mirror://sourceforge/${PN}/Wine%20Mono/${MV}/wine-mono-${MV}.msi )
+ http://source.winehq.org/patches/data/87234 -> ${PULSE_PATCH}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="alsa capi cups custom-cflags elibc_glibc fontconfig +gecko gnutls gphoto2 gsm gstreamer hardened jpeg lcms ldap +mono mp3 ncurses nls odbc openal opencl +opengl osmesa +oss +perl png pulseaudio samba scanner selinux ssl test +threads +truetype udisks v4l +win32 +win64 +X xcomposite xinerama xml"
+REQUIRED_USE="elibc_glibc? ( threads )
+ mono? ( || ( win32 !win64 ) )
+ osmesa? ( opengl )" #286560
+RESTRICT="test" #72375
+
+MLIB_DEPS="amd64? (
+ truetype? ( >=app-emulation/emul-linux-x86-xlibs-2.1 )
+ X? (
+ >=app-emulation/emul-linux-x86-xlibs-2.1
+ >=app-emulation/emul-linux-x86-soundlibs-2.1[pulseaudio(+)?]
+ )
+ mp3? ( app-emulation/emul-linux-x86-soundlibs )
+ odbc? ( app-emulation/emul-linux-x86-db )
+ openal? ( app-emulation/emul-linux-x86-sdl )
+ opengl? ( app-emulation/emul-linux-x86-opengl )
+ scanner? ( app-emulation/emul-linux-x86-medialibs )
+ v4l? ( app-emulation/emul-linux-x86-medialibs )
+ app-emulation/emul-linux-x86-baselibs
+ >=sys-kernel/linux-headers-2.6
+ )"
+RDEPEND="truetype? ( >=media-libs/freetype-2.0.0 media-fonts/corefonts )
+ perl? ( dev-lang/perl dev-perl/XML-Simple )
+ capi? ( net-dialup/capi4k-utils )
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ fontconfig? ( media-libs/fontconfig )
+ gphoto2? ( media-libs/libgphoto2 )
+ openal? ( media-libs/openal )
+ udisks? (
+ sys-apps/dbus
+ sys-fs/udisks:2
+ )
+ gnutls? ( net-libs/gnutls )
+ gstreamer? ( media-libs/gstreamer media-libs/gst-plugins-base )
+ X? (
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86vm
+ x11-apps/xmessage
+ )
+ xinerama? ( x11-libs/libXinerama )
+ alsa? ( media-libs/alsa-lib )
+ cups? ( net-print/cups )
+ opencl? ( virtual/opencl )
+ opengl? ( virtual/opengl )
+ gsm? ( media-sound/gsm )
+ jpeg? ( virtual/jpeg )
+ ldap? ( net-nds/openldap )
+ lcms? ( =media-libs/lcms-1* )
+ mp3? ( >=media-sound/mpg123-1.5.0 )
+ nls? ( sys-devel/gettext )
+ odbc? ( dev-db/unixODBC )
+ osmesa? ( media-libs/mesa[osmesa] )
+ pulseaudio? ( media-sound/pulseaudio )
+ samba? ( >=net-fs/samba-3.0.25 )
+ selinux? ( sec-policy/selinux-wine )
+ xml? ( dev-libs/libxml2 dev-libs/libxslt )
+ scanner? ( media-gfx/sane-backends )
+ ssl? ( dev-libs/openssl )
+ png? ( media-libs/libpng )
+ v4l? ( media-libs/libv4l )
+ !win64? ( ${MLIB_DEPS} )
+ win32? ( ${MLIB_DEPS} )
+ xcomposite? ( x11-libs/libXcomposite )"
+DEPEND="${RDEPEND}
+ X? (
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto
+ )
+ xinerama? ( x11-proto/xineramaproto )
+ !hardened? ( sys-devel/prelink )
+ virtual/pkgconfig
+ virtual/yacc
+ sys-devel/flex"
+
+src_unpack() {
+ if use win64 ; then
+ [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]] \
+ && die "you need gcc-4.4+ to build 64bit wine"
+ fi
+
+ if use win32 && use opencl; then
+ [[ x$(eselect opencl show) = "xintel" ]] &&
+ die "Cannot build wine[opencl,win32]: intel-ocl-sdk is 64-bit only" # 403947
+ fi
+
+ if [[ ${PV} == "9999" ]] ; then
+ git-2_src_unpack
+ else
+ unpack ${MY_P}.tar.bz2
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
+ epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
+ epatch "${FILESDIR}"/${PN}-1.5.10-osmesa-check.patch #429386
+ epatch "${DISTDIR}/${PULSE_PATCH}" #421365
+ epatch_user #282735
+ eautoreconf
+ sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
+ sed -i '/^MimeType/d' tools/wine.desktop || die #117785
+}
+
+do_configure() {
+ local builddir="${WORKDIR}/wine$1"
+ mkdir -p "${builddir}"
+ pushd "${builddir}" >/dev/null
+
+ with_osmesa=$(use_with osmesa)
+ if use osmesa && use amd64 && [[ $1 = 32 ]]; then #430268
+ elog "win32 osmesa support is disabled for now, see bug #430268"
+ with_osmesa=--without-osmesa
+ fi
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --sysconfdir=/etc/wine \
+ $(use_with alsa) \
+ $(use_with capi) \
+ $(use_with lcms cms) \
+ $(use_with cups) \
+ $(use_with ncurses curses) \
+ $(use_with udisks dbus) \
+ $(use_with fontconfig) \
+ $(use_with gnutls) \
+ $(use_with gphoto2 gphoto) \
+ $(use_with gsm) \
+ $(use_with gstreamer) \
+ --without-hal \
+ $(use_with jpeg) \
+ $(use_with ldap) \
+ $(use_with mp3 mpg123) \
+ $(use_with nls gettext) \
+ $(use_with openal) \
+ $(use_with opencl) \
+ $(use_with opengl) \
+ $(use_with ssl openssl) \
+ ${with_osmesa} \
+ $(use_with oss) \
+ $(use_with png) \
+ $(use_with threads pthread) \
+ $(use_with pulseaudio pulse) \
+ $(use_with scanner sane) \
+ $(use_enable test tests) \
+ $(use_with truetype freetype) \
+ $(use_with v4l) \
+ $(use_with X x) \
+ $(use_with xcomposite) \
+ $(use_with xinerama) \
+ $(use_with xml) \
+ $(use_with xml xslt) \
+ $2
+
+ emake -j1 depend
+
+ popd >/dev/null
+}
+
+src_configure() {
+ export LDCONFIG=/bin/true
+ use custom-cflags || strip-flags
+
+ if use win64 ; then
+ do_configure 64 --enable-win64
+ use win32 && ABI=x86 do_configure 32 --with-wine64=../wine64
+ else
+ ABI=x86 do_configure 32 --disable-win64
+ fi
+}
+
+src_compile() {
+ local b
+ for b in 64 32 ; do
+ local builddir="${WORKDIR}/wine${b}"
+ [[ -d ${builddir} ]] || continue
+ emake -C "${builddir}" all
+ done
+}
+
+src_install() {
+ local b
+ for b in 64 32 ; do
+ local builddir="${WORKDIR}/wine${b}"
+ [[ -d ${builddir} ]] || continue
+ emake -C "${builddir}" install DESTDIR="${D}"
+ done
+ dodoc ANNOUNCE AUTHORS README
+ if use gecko ; then
+ insinto /usr/share/wine/gecko
+ doins "${DISTDIR}"/wine_gecko-${GV}-x86.msi
+ use win64 && doins "${DISTDIR}"/wine_gecko-${GV}-x86_64.msi
+ fi
+ if use mono ; then
+ insinto /usr/share/wine/mono
+ doins "${DISTDIR}"/wine-mono-${MV}.msi
+ fi
+ if ! use perl ; then
+ rm "${D}"usr/bin/{wine{dump,maker},function_grep.pl} "${D}"usr/share/man/man1/wine{dump,maker}.1 || die
+ fi
+
+ if use win32 || ! use win64; then
+ pax-mark psmr "${D}"usr/bin/wine{,-preloader} #255055
+ fi
+ use win64 && pax-mark psmr "${D}"usr/bin/wine64{,-preloader}
+
+ if use win64 && ! use win32; then
+ dosym /usr/bin/wine{64,} # 404331
+ dosym /usr/bin/wine{64,}-preloader
+ fi
+}
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index ac107810c2c0..4f17119ed9cc 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.110 2012/06/24 23:23:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.111 2012/08/07 08:06:43 tetromino Exp $
EAPI="4"
@@ -18,7 +18,7 @@ else
S=${WORKDIR}/${MY_P}
fi
-GV="1.6"
+GV="1.7"
MV="0.0.4"
PULSE_PATCH="winepulse-2012.06.15.patch"
DESCRIPTION="free implementation of Windows(tm) on Unix"
@@ -33,9 +33,10 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="alsa capi cups custom-cflags elibc_glibc fontconfig +gecko gnutls gphoto2 gsm gstreamer hardened jpeg lcms ldap +mono mp3 ncurses nls odbc openal opencl +opengl +oss +perl png pulseaudio samba scanner selinux ssl test +threads +truetype udisks v4l +win32 +win64 +X xcomposite xinerama xml"
+IUSE="alsa capi cups custom-cflags elibc_glibc fontconfig +gecko gnutls gphoto2 gsm gstreamer hardened jpeg lcms ldap +mono mp3 ncurses nls odbc openal opencl +opengl osmesa +oss +perl png pulseaudio samba scanner selinux ssl test +threads +truetype udisks v4l +win32 +win64 +X xcomposite xinerama xml"
REQUIRED_USE="elibc_glibc? ( threads )
- mono? ( || ( win32 !win64 ) )" #286560
+ mono? ( || ( win32 !win64 ) )
+ osmesa? ( opengl )" #286560
RESTRICT="test" #72375
MLIB_DEPS="amd64? (
@@ -86,6 +87,7 @@ RDEPEND="truetype? ( >=media-libs/freetype-2.0.0 media-fonts/corefonts )
mp3? ( >=media-sound/mpg123-1.5.0 )
nls? ( sys-devel/gettext )
odbc? ( dev-db/unixODBC )
+ osmesa? ( media-libs/mesa[osmesa] )
pulseaudio? ( media-sound/pulseaudio )
samba? ( >=net-fs/samba-3.0.25 )
selinux? ( sec-policy/selinux-wine )
@@ -130,6 +132,7 @@ src_unpack() {
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
+ epatch "${FILESDIR}"/${PN}-1.5.10-osmesa-check.patch #429386
epatch "${DISTDIR}/${PULSE_PATCH}" #421365
epatch_user #282735
eautoreconf
@@ -142,6 +145,12 @@ do_configure() {
mkdir -p "${builddir}"
pushd "${builddir}" >/dev/null
+ with_osmesa=$(use_with osmesa)
+ if use osmesa && use amd64 && [[ $1 = 32 ]]; then #430268
+ elog "win32 osmesa support is disabled for now, see bug #430268"
+ with_osmesa=--without-osmesa
+ fi
+
ECONF_SOURCE=${S} \
econf \
--sysconfdir=/etc/wine \
@@ -165,6 +174,7 @@ do_configure() {
$(use_with opencl) \
$(use_with opengl) \
$(use_with ssl openssl) \
+ ${with_osmesa} \
$(use_with oss) \
$(use_with png) \
$(use_with threads pthread) \