summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-19 19:49:59 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-19 19:49:59 +0000
commit6d58cb2346494c1c3ed318ac8fee8190e55b6959 (patch)
tree351a209e222c97d7671fa57e8f78e47984af4a24 /app-emulation/wine
parentStable on alpha. (diff)
downloadgentoo-2-6d58cb2346494c1c3ed318ac8fee8190e55b6959.tar.gz
gentoo-2-6d58cb2346494c1c3ed318ac8fee8190e55b6959.tar.bz2
gentoo-2-6d58cb2346494c1c3ed318ac8fee8190e55b6959.zip
old
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/files/digest-wine-200410193
-rw-r--r--app-emulation/wine/wine-20041019.ebuild141
2 files changed, 0 insertions, 144 deletions
diff --git a/app-emulation/wine/files/digest-wine-20041019 b/app-emulation/wine/files/digest-wine-20041019
deleted file mode 100644
index 811223464fc5..000000000000
--- a/app-emulation/wine/files/digest-wine-20041019
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 412d0e6f2e364c43d8c77b5904c70da9 Wine-20041019.tar.gz 11058180
-MD5 af8da46a0e51578ff1e18e399141d628 wine-20040716-fake_windows.tar.bz2 500
-MD5 e85afd5661bfc1b6dffc05db480b52a8 wine-20040716-misc.tar.bz2 5300
diff --git a/app-emulation/wine/wine-20041019.ebuild b/app-emulation/wine/wine-20041019.ebuild
deleted file mode 100644
index 60d73ef0c6fc..000000000000
--- a/app-emulation/wine/wine-20041019.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20041019.ebuild,v 1.8 2005/01/01 14:19:55 eradicator Exp $
-
-inherit eutils flag-o-matic
-
-STAMP=20040716
-DESCRIPTION="free implementation of Windows(tm) on Unix - CVS snapshot"
-HOMEPAGE="http://www.winehq.com/"
-SRC_URI="mirror://sourceforge/${PN}/Wine-${PV}.tar.gz
- mirror://gentoo/${PN}-${STAMP}-fake_windows.tar.bz2
- mirror://gentoo/${PN}-${STAMP}-misc.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="-* x86"
-IUSE="X jack alsa arts cups debug nas opengl tcltk ncurses"
-
-DEPEND="sys-devel/gcc
- sys-devel/flex
- ncurses? ( >=sys-libs/ncurses-5.2 )
- >=media-libs/freetype-2.0.0
- jack? ( media-sound/jack-audio-connection-kit )
- X? ( virtual/x11 )
- tcltk? ( dev-lang/tcl dev-lang/tk )
- arts? ( kde-base/arts )
- alsa? ( media-libs/alsa-lib )
- nas? ( media-libs/nas )
- cups? ( net-print/cups )
- opengl? ( virtual/opengl )
- >=sys-apps/sed-4"
-
-src_unpack() {
- unpack Wine-${PV}.tar.gz
- unpack ${PN}-${STAMP}-fake_windows.tar.bz2
- mkdir misc ; cd misc
- unpack ${PN}-${STAMP}-misc.tar.bz2
-
- cd ${S}
- epatch ${FILESDIR}/winearts-kdecvs-fix.patch
- sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
-
- test_flag -fstack-protector && epatch ${FILESDIR}/${PV}-no-stack.patch #66002
-}
-
-config_cache() {
- local h ans="no"
- use ${1} && ans="yes"
- shift
- for h in "$@" ; do
- export ac_cv_header_${h}=${ans}
- done
-}
-
-src_compile() {
- export LDCONFIG=/bin/true
- config_cache jack jack_jack_h
- config_cache cups cups_cups_h
- config_cache alsa alsa_asoundlib_h sys_asoundlib_h
- use arts || export ARTSCCONFIG="/bin/false"
- config_cache nas audio_audiolib_h
-
- strip-flags
-
- ./configure \
- --prefix=/usr/lib/wine \
- --sysconfdir=/etc/wine \
- --build=${CBUILD:-${CHOST}} \
- --host=${CHOST} \
- --target=${CTARGET:-${CHOST}} \
- $(use_with ncurses curses) \
- $(use_with opengl) \
- $(use_with X x) \
- $(use_enable debug trace) \
- $(use_enable debug) \
- || die "configure failed"
-
- emake -j1 depend || die "depend"
- emake all || die "all"
- emake -C programs || die "programs"
-}
-
-src_install() {
- local WINEMAKEOPTS="prefix=${D}/usr/lib/wine"
-
- ### Install wine to ${D}
- make ${WINEMAKEOPTS} install || die
- cd ${S}/programs
- make ${WINEMAKEOPTS} install || die
-
- # Needed for later installation
- dodir /usr/bin
-
- ### Creation of /usr/lib/wine/.data
- # Setting up fake_windows
- dodir /usr/lib/wine/.data
- cd ${D}/usr/lib/wine/.data
- cp -r ${WORKDIR}/fake_windows . || die "fake_windows"
- chown root:root fake_windows/ -R
-
- # Unpacking the miscellaneous files
- cp ${WORKDIR}/misc/* . || die "misc"
- chown root:root config
-
- # moving the wrappers to bin/
- insinto /usr/bin
- dobin regedit-wine wine winedbg wine-pthread
- rm regedit-wine wine winedbg wine-pthread
-
- # copying the wine.inf into .data (used to be winedefault.reg)
- cd ${S}
- dodir /usr/lib/wine/.data
- insinto /usr/lib/wine/.data
- doins tools/wine.inf
- insinto /usr/lib/wine/.data/fake_windows/Windows/System
- doins tools/wine.inf
- insinto /usr/lib/wine/.data/fake_windows/Windows/Inf
- doins tools/wine.inf
-
- ### Misc tasks
- # Take care of the documentation
- cd ${S}
- dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS README
-
- # Manpage setup
-
- newman ${D}/usr/lib/${PN}/man/man1/wine.1 ${PN}.1
- rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
- doman ${D}/usr/lib/${PN}/man/man5/wine.conf.5
- rm ${D}/usr/lib/${PN}/man/man5/wine.conf.5
-}
-
-pkg_postinst() {
- einfo "Use /usr/bin/wine to start wine. This is a wrapper-script"
- einfo "which will take care of everything else."
- einfo
- einfo "if you have problems with nptl, use wine-pthread to start wine"
- einfo
- einfo "Use /usr/bin/regedit-wine to import registry files into the"
- einfo "wine registry."
-}