summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-28 01:35:14 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-28 01:35:14 +0000
commit4136984738d90a84444823eb4ab683f5a89c843e (patch)
tree1870bdb2a55bbe7552a86f2320c43dc657fc0364 /app-emulation/wine
parentfix jack DEPEND #69172 (Manifest recommit) (diff)
downloadgentoo-2-4136984738d90a84444823eb4ab683f5a89c843e.tar.gz
gentoo-2-4136984738d90a84444823eb4ab683f5a89c843e.tar.bz2
gentoo-2-4136984738d90a84444823eb4ab683f5a89c843e.zip
stack-protector workaround #66002
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/ChangeLog7
-rw-r--r--app-emulation/wine/files/20041019-no-stack.patch9
-rw-r--r--app-emulation/wine/wine-20041019-r1.ebuild4
-rw-r--r--app-emulation/wine/wine-20041019.ebuild4
4 files changed, 21 insertions, 3 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 8dd6f1664de3..59337d20e1c0 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/wine
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.79 2004/10/27 19:51:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.80 2004/10/28 01:35:14 vapier Exp $
+
+ 27 Oct 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/20041019-no-stack.patch, wine-20041019-r1.ebuild,
+ wine-20041019.ebuild:
+ Filter stack-protector flags on the preloader binary #66002 by vyp08.
*wine-20041019-r1 (27 Oct 2004)
diff --git a/app-emulation/wine/files/20041019-no-stack.patch b/app-emulation/wine/files/20041019-no-stack.patch
new file mode 100644
index 000000000000..3b9b927c4b41
--- /dev/null
+++ b/app-emulation/wine/files/20041019-no-stack.patch
@@ -0,0 +1,9 @@
+--- loader/Makefile.in.orig 2004-10-27 21:26:15.663148264 -0400
++++ loader/Makefile.in 2004-10-27 21:27:44.434652944 -0400
+@@ -55,3 +55,6 @@
+ $(RM) $(WINE_BINARIES) $(MODULE)
+
+ ### Dependencies:
++
++preloader.o:
++ $(CC) -c -fno-pic -fno-stack-protector $(ALLCFLAGS) -o $@ preloader.c
diff --git a/app-emulation/wine/wine-20041019-r1.ebuild b/app-emulation/wine/wine-20041019-r1.ebuild
index 0669fcb63d57..196bf1143b0f 100644
--- a/app-emulation/wine/wine-20041019-r1.ebuild
+++ b/app-emulation/wine/wine-20041019-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20041019-r1.ebuild,v 1.2 2004/10/28 01:24:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20041019-r1.ebuild,v 1.3 2004/10/28 01:35:14 vapier Exp $
inherit eutils flag-o-matic
@@ -41,6 +41,8 @@ src_unpack() {
epatch ${FILESDIR}/winearts-kdecvs-fix.patch
epatch ${FILESDIR}/${PV}-load-wrappers.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
+
+ test_flag -fstack-protector && epatch ${FILESDIR}/${PV}-no-stack.patch #66002
}
config_cache() {
diff --git a/app-emulation/wine/wine-20041019.ebuild b/app-emulation/wine/wine-20041019.ebuild
index e2abe509fe32..5cdf2d41b234 100644
--- a/app-emulation/wine/wine-20041019.ebuild
+++ b/app-emulation/wine/wine-20041019.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20041019.ebuild,v 1.4 2004/10/28 01:24:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20041019.ebuild,v 1.5 2004/10/28 01:35:14 vapier Exp $
inherit eutils flag-o-matic
@@ -39,6 +39,8 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/winearts-kdecvs-fix.patch
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
+
+ test_flag -fstack-protector && epatch ${FILESDIR}/${PV}-no-stack.patch #66002
}
config_cache() {