summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-10 22:52:19 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-10 22:52:19 +0000
commit220b28dad3e629b5717f3636b8169049e332ce90 (patch)
tree899668e7c103dd9cac7eec1eb2e08d3754cfbc02 /app-emulation/wine
parentFixed to compile properly on amd64 with eselect-compiler. Closes bug #128772. (diff)
downloadgentoo-2-220b28dad3e629b5717f3636b8169049e332ce90.tar.gz
gentoo-2-220b28dad3e629b5717f3636b8169049e332ce90.tar.bz2
gentoo-2-220b28dad3e629b5717f3636b8169049e332ce90.zip
revert previous commit
(Portage version: 2.1)
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/ChangeLog6
-rw-r--r--app-emulation/wine/wine-0.9.10.ebuild12
-rw-r--r--app-emulation/wine/wine-0.9.15.ebuild18
3 files changed, 7 insertions, 29 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index c5bfb7dc48fa..4329e6d6c7b3 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,10 +1,6 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.144 2006/06/10 22:39:15 eradicator Exp $
-
- 10 Jun 2006; Jeremy Huddleston <eradicator@gentoo.org> wine-0.9.10.ebuild,
- wine-0.9.15.ebuild:
- Fixed to compile properly on amd64 with eselect-compiler. Closes bug #128772.
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.145 2006/06/10 22:52:19 vapier Exp $
*wine-0.9.15 (09 Jun 2006)
diff --git a/app-emulation/wine/wine-0.9.10.ebuild b/app-emulation/wine/wine-0.9.10.ebuild
index dcd55ee019d9..65cb24fff30f 100644
--- a/app-emulation/wine/wine-0.9.10.ebuild
+++ b/app-emulation/wine/wine-0.9.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.10.ebuild,v 1.4 2006/06/10 22:39:15 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.10.ebuild,v 1.5 2006/06/10 22:52:19 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -60,15 +60,7 @@ DEPEND="${RDEPEND}
sys-devel/flex"
pkg_setup() {
- if use amd64 ; then
- has_multilib_profile || die "Your profile does not support compilation of wine."
-
- export ABI=x86
- if has_version app-admin/eselect-compiler ; then
- CHOST=$(get_abi_CHOST ${ABI})
- CBUILD=${CHOST}
- fi
- fi
+ use amd64 && has_multilib_profile && export ABI=x86
}
src_unpack() {
diff --git a/app-emulation/wine/wine-0.9.15.ebuild b/app-emulation/wine/wine-0.9.15.ebuild
index 1de833f11dfe..0046377c3fa6 100644
--- a/app-emulation/wine/wine-0.9.15.ebuild
+++ b/app-emulation/wine/wine-0.9.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.15.ebuild,v 1.2 2006/06/10 22:39:15 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.15.ebuild,v 1.3 2006/06/10 22:52:19 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -60,6 +60,9 @@ DEPEND="${RDEPEND}
sys-devel/bison
sys-devel/flex"
+# this will not build as 64bit code
+export ABI=x86
+
src_unpack() {
unpack wine-${PV}.tar.bz2
cd "${S}"
@@ -102,19 +105,6 @@ src_compile() {
strip-flags
- if use amd64 ; then
- # If we don't want --enable-win64, then we need override the
- # toolchain. If we do --enable-win64, then configure takes
- # care of it for us
-
- export CHOST="i686-pc-linux-gnu"
- export CBUILD="${CHOST}"
-
- # This should be handled by eselect-binutils in the future:
- export LD="$(tc-getLD) -m elf_i386"
- export AS="$(tc-getAS) --32"
- fi
-
# $(use_enable amd64 win64)
econf \
CC="$(tc-getCC)" \