summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-10 03:59:17 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-10 03:59:17 +0000
commit560efb0f31671af85a2e67092e11539f433b17fb (patch)
treef35e9dce65730f0b30853f586c6bd05927cf9b89 /app-emulation/wine/wine-20050524.ebuild
parents390 love (diff)
downloadgentoo-2-560efb0f31671af85a2e67092e11539f433b17fb.tar.gz
gentoo-2-560efb0f31671af85a2e67092e11539f433b17fb.tar.bz2
gentoo-2-560efb0f31671af85a2e67092e11539f433b17fb.zip
tweak 32bit support on amd64 #96863
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-emulation/wine/wine-20050524.ebuild')
-rw-r--r--app-emulation/wine/wine-20050524.ebuild28
1 files changed, 15 insertions, 13 deletions
diff --git a/app-emulation/wine/wine-20050524.ebuild b/app-emulation/wine/wine-20050524.ebuild
index fd7e50819084..d059c0103e22 100644
--- a/app-emulation/wine/wine-20050524.ebuild
+++ b/app-emulation/wine/wine-20050524.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050524.ebuild,v 1.4 2005/06/17 02:06:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050524.ebuild,v 1.5 2005/07/10 03:59:17 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -39,12 +39,20 @@ DEPEND="${RDEPEND}
# doc? ( app-text/docbook-sgml-utils app-text/jadetex )
pkg_setup() {
- if use amd64 && ! has_m32 ; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "Make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit code"
+ if use amd64 ; then
+ if ! has_m32 ; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
+ fi
+ if has_multilib_profile ; then
+ export ABI=x86
+ else
+ append-flags -m32
+ append-ldflags -m32
+ fi
fi
}
@@ -83,12 +91,6 @@ src_compile() {
strip-flags
use lcms && append-flags -I"${ROOT}"/usr/include/lcms
- if use amd64 ; then
- [[ -n $(get_abi_var) ]] \
- && export ABI=x86 \
- || append-flags -m32
- fi
-
# if ! built_with_use app-text/docbook-sgml-utils tetex ; then
# export DB2PDF=true
# export DB2PS=true