summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-12-03 03:04:41 +0000
committerMike Frysinger <vapier@gentoo.org>2009-12-03 03:04:41 +0000
commit14fa789a32736ef52da804d0736f5ffcdc77edf0 (patch)
tree15146352a97a6d023970aab710608d330395dc7e /app-emulation/wine/wine-1.1.14.ebuild
parentcomment out live KEYWORDS to keep ekeyword happy (diff)
downloadgentoo-2-14fa789a32736ef52da804d0736f5ffcdc77edf0.tar.gz
gentoo-2-14fa789a32736ef52da804d0736f5ffcdc77edf0.tar.bz2
gentoo-2-14fa789a32736ef52da804d0736f5ffcdc77edf0.zip
Add USE=custom-flags and restore strip-flags #257038 by Mr. Bones.
(Portage version: 2.2_rc54/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/wine/wine-1.1.14.ebuild')
-rw-r--r--app-emulation/wine/wine-1.1.14.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/app-emulation/wine/wine-1.1.14.ebuild b/app-emulation/wine/wine-1.1.14.ebuild
index a71663ce68ff..f25b51772be4 100644
--- a/app-emulation/wine/wine-1.1.14.ebuild
+++ b/app-emulation/wine/wine-1.1.14.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.14.ebuild,v 1.10 2009/12/03 02:56:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.14.ebuild,v 1.11 2009/12/03 03:04:41 vapier Exp $
EAPI="2"
-inherit multilib
+inherit eutils flag-o-matic multilib
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://source.winehq.org/git/wine.git"
@@ -26,7 +26,7 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="alsa cups dbus esd +gecko gnutls hal jack jpeg lcms ldap nas ncurses +opengl oss png samba scanner ssl win64 +X xcomposite xinerama xml"
+IUSE="alsa cups custom-cflags dbus esd +gecko gnutls hal jack jpeg lcms ldap nas ncurses +opengl oss png samba scanner ssl win64 +X xcomposite xinerama xml"
RESTRICT="test" #72375
RDEPEND=">=media-libs/freetype-2.0.0
@@ -94,6 +94,7 @@ src_prepare() {
src_configure() {
export LDCONFIG=/bin/true
+ use custom-cflags || strip-flags
use amd64 && ! use win64 && multilib_toolchain_setup x86
# XXX: should check out these flags too: