summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alberto Suarez Lopez <bass@gentoo.org>2003-04-13 12:46:05 +0000
committerJose Alberto Suarez Lopez <bass@gentoo.org>2003-04-13 12:46:05 +0000
commit6d2105499bda0d566dbf643a1b0d3c16026af0ac (patch)
tree8e3683f5413e237cc02604051495424a6c8acd5a /app-emulation/win4lin
parentVersion bump (diff)
downloadgentoo-2-6d2105499bda0d566dbf643a1b0d3c16026af0ac.tar.gz
gentoo-2-6d2105499bda0d566dbf643a1b0d3c16026af0ac.tar.bz2
gentoo-2-6d2105499bda0d566dbf643a1b0d3c16026af0ac.zip
new version
Diffstat (limited to 'app-emulation/win4lin')
-rw-r--r--app-emulation/win4lin/ChangeLog7
-rw-r--r--app-emulation/win4lin/files/digest-win4lin-4.0.202
-rw-r--r--app-emulation/win4lin/win4lin-4.0.20.ebuild79
3 files changed, 87 insertions, 1 deletions
diff --git a/app-emulation/win4lin/ChangeLog b/app-emulation/win4lin/ChangeLog
index eaa0c0cdd005..64c3c7cbd871 100644
--- a/app-emulation/win4lin/ChangeLog
+++ b/app-emulation/win4lin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/win4lin
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/win4lin/ChangeLog,v 1.6 2003/03/02 14:41:42 bass Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/win4lin/ChangeLog,v 1.7 2003/04/13 12:46:05 bass Exp $
+
+*win4lin-4.0.20 (13 Apr 2003)
+
+ 13 Apr 2003; J.Alberto Suárez L. <bass@gentoo.org> win4lin-4.0.20.ebuild:
+ new version
*win4lin-4.0.16 (02 Mar 2003)
diff --git a/app-emulation/win4lin/files/digest-win4lin-4.0.20 b/app-emulation/win4lin/files/digest-win4lin-4.0.20
new file mode 100644
index 000000000000..efc42e93a766
--- /dev/null
+++ b/app-emulation/win4lin/files/digest-win4lin-4.0.20
@@ -0,0 +1,2 @@
+MD5 91f5215337a0e7373e7f1072bd9e47a3 Win4Lin-5.3.20a-d.i386.rpm 4471279
+MD5 baf7aab436cca4cfcf159ffc41999b1f Win4Lin-4.0.0-manual.pdf 1786558
diff --git a/app-emulation/win4lin/win4lin-4.0.20.ebuild b/app-emulation/win4lin/win4lin-4.0.20.ebuild
new file mode 100644
index 000000000000..4a76d88ee41a
--- /dev/null
+++ b/app-emulation/win4lin/win4lin-4.0.20.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/win4lin/win4lin-4.0.20.ebuild,v 1.1 2003/04/13 12:46:05 bass Exp $
+
+IUSE="doc"
+
+MY_P=Win4Lin-5.3.20a-d.i386
+
+S=${WORKDIR}
+DESCRIPTION="Win4Lin allows you run Windows applications somewhat natively
+under linux."
+HOMEPAGE="http://www.netraverse.com/"
+SRC_URI="mirror://gentoo/${MY_P}.rpm
+ doc? ( https://www.netraverse.com/support/docs/Win4Lin-4.0.0-manual.pdf )"
+
+SLOT="0"
+LICENSE="NeTraverse"
+KEYWORDS="~x86"
+
+DEPEND="app-arch/rpm2targz
+ sys-kernel/win4lin-sources"
+
+src_unpack() {
+ rpm2targz ${DISTDIR}/${MY_P}.rpm
+ tar zxf ${WORKDIR}/${MY_P}.tar.gz
+}
+
+src_compile() {
+ einfo "nothing to compile; binary package."
+}
+
+src_install() {
+ mv ${S}/opt ${D}
+ mv ${S}/etc ${D}
+ cp ${FILESDIR}/registerme.sh ${D}/opt/win4lin/
+
+ if [ -n "`use doc`" ]
+ then
+ dodoc ${DISTDIR}/Win4Lin-4.0.0-manual.pdf
+ fi
+}
+
+
+pkg_postinst() {
+ /opt/win4lin/postinst_rpm.sh
+ echo "LICENSE_CODE=1w4e053x-n0aaf8-7tw9-587j-h47j-d6" > /var/win4lin/install/license.lic
+ einfo "If this is a new Win4Lin Install you will need to run the following command"
+ einfo "ebuild /var/db/pkg/app-emulation/${PF}/${PF}.ebuild config"
+ einfo "to install the windows setup files. You will need your Windows cdrom in the "
+ einfo "drive in order to complete this step."
+}
+
+
+pkg_prerm() {
+ /opt/win4lin/remove_rpm.sh
+}
+
+pkg_config() {
+ loadwindowsCD cddevice /dev/cdrom
+ ln -s /etc/rc.d/init.d/Win4Lin /etc/init.d/Win4Lin
+ #put debugging stuff here
+ if [ ${?} -eq "0" ]; then
+ einfo "You can now run the command \"installwindows\" from an xterm "
+ einfo "as a non-root user to install a personal copy of Windows that Win4Lin "
+ einfo "will use for that user."
+ einfo
+ einfo "Win4Lin is a commercial product, you now are using a evaluation-license"
+ einfo "for 15 days evaluation. If you want a extra 15 days of evaluation you"
+ einfo 'must run "sh /opt/win4lin/registerme.sh"'
+ einfo
+ einfo 'You can help Gentoo Linux and obatin a full license at a discont offer'
+ einfo 'for gentoo users in http://www.netraverse.com/gentoo.htm'
+ einfo 'Netraverse donate to Gentoo Linux a percent of each purchase.'
+ einfo 'Thanks Netaverse.'
+ einfo
+ einfo 'Remember, you must do "/etc/init.d/Win4Lin start" before start w4l'
+ einfo 'Also you can add it to default boot "rc-update add Win4Lin default"'
+ fi
+}