summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-05-19 18:28:38 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-05-19 18:28:38 +0000
commit3a6e41a95a21ff52818b735eaa83c8974b8702b0 (patch)
treea534a466b09a55339d4069b863375d2792d8f0c4 /app-emulation/vmware-workstation-tools
parentStable on ppc64 (diff)
downloadgentoo-2-3a6e41a95a21ff52818b735eaa83c8974b8702b0.tar.gz
gentoo-2-3a6e41a95a21ff52818b735eaa83c8974b8702b0.tar.bz2
gentoo-2-3a6e41a95a21ff52818b735eaa83c8974b8702b0.zip
Fix a couple places where we're doing something on /etc/vmware instead of /etc/vmware-tools.
(Portage version: 2.1_rc1-r2)
Diffstat (limited to 'app-emulation/vmware-workstation-tools')
-rw-r--r--app-emulation/vmware-workstation-tools/ChangeLog8
-rw-r--r--app-emulation/vmware-workstation-tools/vmware-workstation-tools-4.5.3.ebuild12
-rw-r--r--app-emulation/vmware-workstation-tools/vmware-workstation-tools-5.0.0.ebuild12
3 files changed, 19 insertions, 13 deletions
diff --git a/app-emulation/vmware-workstation-tools/ChangeLog b/app-emulation/vmware-workstation-tools/ChangeLog
index 6dea79199bcb..339b7d8bb42b 100644
--- a/app-emulation/vmware-workstation-tools/ChangeLog
+++ b/app-emulation/vmware-workstation-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/vmware-linux-tools
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation-tools/ChangeLog,v 1.5 2006/05/10 16:11:09 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation-tools/ChangeLog,v 1.6 2006/05/19 18:28:38 wolf31o2 Exp $
+
+ 19 May 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ vmware-workstation-tools-4.5.3.ebuild,
+ vmware-workstation-tools-5.0.0.ebuild:
+ Fix a couple places where we're doing something on /etc/vmware instead of
+ /etc/vmware-tools.
*vmware-workstation-tools-4.5.3 (10 May 2006)
diff --git a/app-emulation/vmware-workstation-tools/vmware-workstation-tools-4.5.3.ebuild b/app-emulation/vmware-workstation-tools/vmware-workstation-tools-4.5.3.ebuild
index a5402d59f35b..0c98ac5f7ac0 100644
--- a/app-emulation/vmware-workstation-tools/vmware-workstation-tools-4.5.3.ebuild
+++ b/app-emulation/vmware-workstation-tools/vmware-workstation-tools-4.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation-tools/vmware-workstation-tools-4.5.3.ebuild,v 1.1 2006/05/10 16:11:09 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation-tools/vmware-workstation-tools-4.5.3.ebuild,v 1.2 2006/05/19 18:28:38 wolf31o2 Exp $
inherit eutils
@@ -39,7 +39,7 @@ vmware_create_initd() {
# This is to fix a problem where if someone merges vmware and then
# before configuring vmware they upgrade or re-merge the vmware
# package which would rmdir the /etc/vmware/init.d/rc?.d directories.
- keepdir /etc/vmware/init.d/rc{0,1,2,3,4,5,6}.d
+ keepdir /etc/vmware-tools/init.d/rc{0,1,2,3,4,5,6}.d
}
vmware_run_questions() {
@@ -52,8 +52,8 @@ vmware_run_questions() {
echo "answer DOCDIR ${dir}/doc" >> ${locations}
echo "answer SBINDIR ${dir}/sbin" >> ${locations}
echo "answer RUN_CONFIGURATOR no" >> ${locations}
- echo "answer INITDIR /etc/vmware/init.d" >> ${locations}
- echo "answer INITSCRIPTSDIR /etc/vmware/init.d" >> ${locations}
+ echo "answer INITDIR /etc/vmware-tools/init.d" >> ${locations}
+ echo "answer INITSCRIPTSDIR /etc/vmware-tools/init.d" >> ${locations}
}
pkg_setup() {
@@ -99,7 +99,7 @@ src_install() {
vmware_create_initd || die
- cp -pPR installer/services.sh ${D}/etc/vmware-tools/init.d/vmware || die
+ cp -pPR installer/services.sh ${D}/etc/vmware-tools/init.d/vmware-tools || die
vmware_run_questions || die
}
@@ -137,7 +137,7 @@ pkg_postinst () {
done
einfo "To start using the vmware-tools, please run the following:"
einfo
- einfo " /usr/bin/vmware-config-tools.pl"
+ einfo " ${dir}/bin/vmware-config-tools.pl"
einfo " rc-update add vmware-tools default"
einfo " /etc/init.d/vmware-tools start"
einfo
diff --git a/app-emulation/vmware-workstation-tools/vmware-workstation-tools-5.0.0.ebuild b/app-emulation/vmware-workstation-tools/vmware-workstation-tools-5.0.0.ebuild
index 3931481bfd19..589dccbf3753 100644
--- a/app-emulation/vmware-workstation-tools/vmware-workstation-tools-5.0.0.ebuild
+++ b/app-emulation/vmware-workstation-tools/vmware-workstation-tools-5.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation-tools/vmware-workstation-tools-5.0.0.ebuild,v 1.4 2006/05/10 16:11:09 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation-tools/vmware-workstation-tools-5.0.0.ebuild,v 1.5 2006/05/19 18:28:38 wolf31o2 Exp $
inherit eutils
@@ -39,7 +39,7 @@ vmware_create_initd() {
# This is to fix a problem where if someone merges vmware and then
# before configuring vmware they upgrade or re-merge the vmware
# package which would rmdir the /etc/vmware/init.d/rc?.d directories.
- keepdir /etc/vmware/init.d/rc{0,1,2,3,4,5,6}.d
+ keepdir /etc/vmware-tools/init.d/rc{0,1,2,3,4,5,6}.d
}
vmware_run_questions() {
@@ -52,8 +52,8 @@ vmware_run_questions() {
echo "answer DOCDIR ${dir}/doc" >> ${locations}
echo "answer SBINDIR ${dir}/sbin" >> ${locations}
echo "answer RUN_CONFIGURATOR no" >> ${locations}
- echo "answer INITDIR /etc/vmware/init.d" >> ${locations}
- echo "answer INITSCRIPTSDIR /etc/vmware/init.d" >> ${locations}
+ echo "answer INITDIR /etc/vmware-tools/init.d" >> ${locations}
+ echo "answer INITSCRIPTSDIR /etc/vmware-tools/init.d" >> ${locations}
}
pkg_setup() {
@@ -99,7 +99,7 @@ src_install() {
vmware_create_initd || die
- cp -pPR installer/services.sh ${D}/etc/vmware-tools/init.d/vmware || die
+ cp -pPR installer/services.sh ${D}/etc/vmware-tools/init.d/vmware-tools || die
vmware_run_questions || die
}
@@ -137,7 +137,7 @@ pkg_postinst () {
done
einfo "To start using the vmware-tools, please run the following:"
einfo
- einfo " /usr/bin/vmware-config-tools.pl"
+ einfo " ${dir}/bin/vmware-config-tools.pl"
einfo " rc-update add vmware-tools default"
einfo " /etc/init.d/vmware-tools start"
einfo