summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-05-31 10:12:44 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-05-31 10:12:44 +0000
commit343a34c7dacc17fc0ffaeeaf4eb625d9a1eacf20 (patch)
treeaf098e5c957d80147a848f8f719ff22e2c2f013e /app-emulation/virtualbox
parentCleanup and fix paths per bug #172548 thanks to Sergij Borodych (diff)
downloadgentoo-2-343a34c7dacc17fc0ffaeeaf4eb625d9a1eacf20.tar.gz
gentoo-2-343a34c7dacc17fc0ffaeeaf4eb625d9a1eacf20.tar.bz2
gentoo-2-343a34c7dacc17fc0ffaeeaf4eb625d9a1eacf20.zip
Apply build fix from dev overlay, thanks to x-drum :)
(Portage version: 2.1.2.7)
Diffstat (limited to 'app-emulation/virtualbox')
-rw-r--r--app-emulation/virtualbox/ChangeLog6
-rw-r--r--app-emulation/virtualbox/virtualbox-1.3.8.ebuild13
-rw-r--r--app-emulation/virtualbox/virtualbox-9999.ebuild14
3 files changed, 28 insertions, 5 deletions
diff --git a/app-emulation/virtualbox/ChangeLog b/app-emulation/virtualbox/ChangeLog
index e03cc8d4bb52..440b0f394e7a 100644
--- a/app-emulation/virtualbox/ChangeLog
+++ b/app-emulation/virtualbox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/virtualbox
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/ChangeLog,v 1.15 2007/05/13 08:56:00 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/ChangeLog,v 1.16 2007/05/31 10:12:44 jokey Exp $
+
+ 31 May 2007; Markus Ullmann <jokey@gentoo.org> virtualbox-1.3.8.ebuild,
+ virtualbox-9999.ebuild:
+ Apply build fix from dev overlay, thanks to x-drum :)
13 May 2007; Markus Ullmann <jokey@gentoo.org>
-files/virtualbox-1.3.6-remove-alsa.patch,
diff --git a/app-emulation/virtualbox/virtualbox-1.3.8.ebuild b/app-emulation/virtualbox/virtualbox-1.3.8.ebuild
index b5bc91382d51..7b1735589016 100644
--- a/app-emulation/virtualbox/virtualbox-1.3.8.ebuild
+++ b/app-emulation/virtualbox/virtualbox-1.3.8.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header $
-inherit eutils qt3
+inherit eutils flag-o-matic qt3 toolchain-funcs
MY_P=VirtualBox-OSE-${PV}
DESCRIPTION="Softwarefamily of powerful x86 virtualization"
@@ -59,7 +59,16 @@ src_compile() {
cd "${S}"
./configure || die "configure failed"
source ./env.sh
- kmk all || die "kmk failed"
+
+ # Force kBuild to respect C[XX]FLAGS and MAKEOPTS (bug #178529)
+ # and strip all flags
+ strip-flags
+
+ MAKE="kmk" emake TOOL_GCC3_CC="$(tc-getCC)" TOOL_GCC3_CXX="$(tc-getCXX)" \
+ TOOL_GCC3_AS="$(tc-getCC)" TOOL_GCC3_AR="$(tc-getAR)" \
+ TOOL_GCC3_LD="$(tc-getCXX)" TOOL_GCC3_LD_SYSMOD="$(tc-getLD)" \
+ TOOL_GCC3_CFLAGS="${CFLAGS}" TOOL_GCC3_CXXFLAGS="${CXXFLAGS}" \
+ all || die "kmk failed"
}
src_install() {
diff --git a/app-emulation/virtualbox/virtualbox-9999.ebuild b/app-emulation/virtualbox/virtualbox-9999.ebuild
index f1859c6fbdb5..2216e1f4f38b 100644
--- a/app-emulation/virtualbox/virtualbox-9999.ebuild
+++ b/app-emulation/virtualbox/virtualbox-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header $
-inherit eutils linux-mod qt3 subversion
+inherit eutils flag-o-matic linux-mod qt3 subversion toolchain-funcs
DESCRIPTION="Softwarefamily of powerful x86 virtualization"
HOMEPAGE="http://www.virtualbox.org/"
@@ -50,7 +50,17 @@ src_compile() {
cd "${S}"
./configure || die "configure failed"
source ./env.sh
- kmk all || die "kmk failed"
+
+ # Force kBuild to respect C[XX]FLAGS and MAKEOPTS (bug #178529)
+ # and strip all flags
+ strip-flags
+
+ MAKE="kmk" emake TOOL_GCC3_CC="$(tc-getCC)" TOOL_GCC3_CXX="$(tc-getCXX)" \
+ TOOL_GCC3_AS="$(tc-getCC)" TOOL_GCC3_AR="$(tc-getAR)" \
+ TOOL_GCC3_LD="$(tc-getCXX)" TOOL_GCC3_LD_SYSMOD="$(tc-getLD)" \
+ TOOL_GCC3_CFLAGS="${CFLAGS}" TOOL_GCC3_CXXFLAGS="${CXXFLAGS}" \
+ all || die "kmk failed"
+
linux-mod_src_compile
}