summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-08-10 14:56:07 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-08-10 14:56:07 +0000
commit0656022f538ccda502ad0b42a8e960318bef1c9b (patch)
tree0efbe979242adbde396630190f78ffbafb60c13b /app-emulation/virtualbox/files
parentMask app-emulation/virtualbox-guest-additions on no-multilib profile (diff)
downloadgentoo-2-0656022f538ccda502ad0b42a8e960318bef1c9b.tar.gz
gentoo-2-0656022f538ccda502ad0b42a8e960318bef1c9b.tar.bz2
gentoo-2-0656022f538ccda502ad0b42a8e960318bef1c9b.zip
Add version bump from my overlay wrt bug #233683
(Portage version: 2.2_rc6/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'app-emulation/virtualbox/files')
-rw-r--r--app-emulation/virtualbox/files/virtualbox-1.6.4-fix-missing-makefiles.patch66
-rw-r--r--app-emulation/virtualbox/files/virtualbox-1.6.4-remove-unused.patch87
-rw-r--r--app-emulation/virtualbox/files/virtualbox-wrapper44
3 files changed, 180 insertions, 17 deletions
diff --git a/app-emulation/virtualbox/files/virtualbox-1.6.4-fix-missing-makefiles.patch b/app-emulation/virtualbox/files/virtualbox-1.6.4-fix-missing-makefiles.patch
new file mode 100644
index 000000000000..efbfc22bcdf1
--- /dev/null
+++ b/app-emulation/virtualbox/files/virtualbox-1.6.4-fix-missing-makefiles.patch
@@ -0,0 +1,66 @@
+--- src/apps/Makefile.kmk 1970-01-01 01:00:00.000000000 +0100
++++ src/apps/Makefile.kmk 2008-08-02 16:06:11.358197514 +0200
+@@ -0,0 +1,28 @@
++# $Id: virtualbox-1.6.4-fix-missing-makefiles.patch,v 1.1 2008/08/10 14:56:07 jokey Exp $
++## @file
++# Sub-Makefile for the external apps.
++#
++
++#
++# Copyright (C) 2006-2007 Sun Microsystems, Inc.
++#
++# Sun Microsystems, Inc. confidential
++# All rights reserved
++#
++
++DEPTH = ../..
++include $(KBUILD_PATH)/subheader.kmk
++
++ifdef VBOX_WITH_KCHMVIEWER
++ ifneq ($(wildcard $(PATH_SUB_CURRENT)/kchmviewer-2.6),)
++ include $(PATH_SUB_CURRENT)/kchmviewer-2.6/Makefile.kmk
++ endif
++endif
++ifneq ($(wildcard $(PATH_SUB_CURRENT)/tunctl),)
++ ifeq ($(KBUILD_TARGET),linux)
++ include $(PATH_SUB_CURRENT)/tunctl/Makefile.kmk
++ endif
++endif
++
++include $(KBUILD_PATH)/subfooter.kmk
++
+--- src/apps/tunctl/Makefile.kmk 1970-01-01 01:00:00.000000000 +0100
++++ src/apps/tunctl/Makefile.kmk 2008-08-02 16:06:37.447936207 +0200
+@@ -0,0 +1,32 @@
++# $Id: virtualbox-1.6.4-fix-missing-makefiles.patch,v 1.1 2008/08/10 14:56:07 jokey Exp $
++## @file
++# Sub-Makefile for VBoxTunctl
++#
++# VBoxTunctl is identical to tunctl from Usermode Linux except for the name.
++#
++
++#
++# Copyright (C) 2006-2007 Sun Microsystems, Inc.
++#
++# This file is part of VirtualBox Open Source Edition (OSE), as
++# available from http://www.virtualbox.org. This file is free software;
++# you can redistribute it and/or modify it under the terms of the GNU
++# General Public License (GPL) as published by the Free Software
++# Foundation, in version 2 as it comes in the "COPYING" file of the
++# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
++# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
++#
++# Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa
++# Clara, CA 95054 USA or visit http://www.sun.com if you need
++# additional information or have any questions.
++#
++
++DEPTH = ../../..
++include $(KBUILD_PATH)/subheader.kmk
++
++PROGRAMS.linux += VBoxTunctl
++VBoxTunctl_TEMPLATE = VBOXR3EXE
++VBoxTunctl_SOURCES = tunctl.c
++
++include $(KBUILD_PATH)/subfooter.kmk
++
diff --git a/app-emulation/virtualbox/files/virtualbox-1.6.4-remove-unused.patch b/app-emulation/virtualbox/files/virtualbox-1.6.4-remove-unused.patch
new file mode 100644
index 000000000000..e9b6696f3776
--- /dev/null
+++ b/app-emulation/virtualbox/files/virtualbox-1.6.4-remove-unused.patch
@@ -0,0 +1,87 @@
+--- Config.kmk.orig 2008-08-04 01:11:59.000000000 +0200
++++ Config.kmk 2008-08-04 01:15:23.000000000 +0200
+@@ -134,26 +134,26 @@
+
+ # This indicates that additions (of some kind or another) is being _built_.
+ # VBOX_WITHOUT_ADDITIONS overrides it.
+-if1of ($(KBUILD_TARGET),l4 linux os2 solaris win)
+- VBOX_WITH_ADDITIONS = 1
+-else ifdef VBOX_WITH_WIN32_ADDITIONS # for ssh cross builds -remove later!
+- VBOX_WITH_ADDITIONS = 1
+-else ifdef VBOX_WITH_LINUX_ADDITIONS # for ssh cross builds - remove later!
+- VBOX_WITH_ADDITIONS = 1
+-endif
++#if1of ($(KBUILD_TARGET),l4 linux os2 solaris win)
++# VBOX_WITH_ADDITIONS = 1
++#else ifdef VBOX_WITH_WIN32_ADDITIONS # for ssh cross builds -remove later!
++# VBOX_WITH_ADDITIONS = 1
++#else ifdef VBOX_WITH_LINUX_ADDITIONS # for ssh cross builds - remove later!
++# VBOX_WITH_ADDITIONS = 1
++#endif
+ # Build the optional ring-0 part of the additions for syntax checking.
+ # (Ignored ifndef VBOX_WITH_ADDITIONS. Hack for 32/64 linux issues.)
+-VBOX_WITH_ADDITION_DRIVERS = 1
++#VBOX_WITH_ADDITION_DRIVERS = 1
+ # Build win32 additions (cross building them on linux and l4 using wine).
+-if1of ($(KBUILD_TARGET),l4 linux win)
+- VBOX_WITH_WIN32_ADDITIONS = 1
+-endif
++#if1of ($(KBUILD_TARGET),l4 linux win)
++# VBOX_WITH_WIN32_ADDITIONS = 1
++#endif
+ # Build linux additions.
+ # Note! VBOX_WITH_LINUX_ADDITIONS will be removed later and only
+ # VBOX_WITH_WIN32_ADDITIONS will be kept around for cross building.
+-if1of ($(KBUILD_TARGET),l4 linux)
+- VBOX_WITH_LINUX_ADDITIONS = 1
+-endif
++#if1of ($(KBUILD_TARGET),l4 linux)
++# VBOX_WITH_LINUX_ADDITIONS = 1
++#endif
+ # Build X11 additions. Can be disabled separately.
+ ifndef VBOX_WITH_X11_ADDITIONS
+ ifdef VBOX_WITH_LINUX_ADDITIONS
+@@ -209,7 +209,7 @@
+ # The SDL based GUI.
+ VBOX_WITH_VBOXSDL = 1
+ # The basic frontend (w/o Main).
+-VBOX_WITH_VBOXBFE = 1
++#VBOX_WITH_VBOXBFE = 1
+ # The Qt GUI.
+ VBOX_WITH_QTGUI = 1
+ # The Qt 4 GUI (experimental).
+@@ -245,9 +245,9 @@
+ # Enable the kchmviewer
+ VBOX_WITH_KCHMVIEWER = 1
+ # Build the testsuite.
+-VBOX_WITH_TESTSUITE = 1
++#VBOX_WITH_TESTSUITE = 1
+ # Build the testcases.
+-VBOX_WITH_TESTCASES = 1
++#VBOX_WITH_TESTCASES = 1
+ # Set this to not use COM or XPCOM in places where it can be avoided.
+ #VBOX_WITHOUT_COM = 1
+ # Set this to skip installing the redistributable compiler runtime.
+--- configure.orig 2008-08-04 01:12:11.000000000 +0200
++++ configure 2008-08-04 01:16:04.000000000 +0200
+@@ -1785,14 +1785,14 @@
+ # some things are not available in for OSE
+ if [ $OSE -ge 1 ]; then
+ cnf_append "VBOX_OSE" "1"
+- cnf_append "VBOX_WITH_TESTSUITE" ""
++# cnf_append "VBOX_WITH_TESTSUITE" ""
+ cnf_append "VBOX_WITH_WIN32_ADDITIONS" ""
+
+- if [ "$OS" = "linux" ]; then
+- cnf_append "VBOX_WITH_LINUX_ADDITIONS" "1"
+- else
+- cnf_append "VBOX_WITH_LINUX_ADDITIONS" ""
+- fi
++# if [ "$OS" = "linux" ]; then
++# cnf_append "VBOX_WITH_LINUX_ADDITIONS" "1"
++# else
++# cnf_append "VBOX_WITH_LINUX_ADDITIONS" ""
++# fi
+ echo >> $CNF
+ fi
+
diff --git a/app-emulation/virtualbox/files/virtualbox-wrapper b/app-emulation/virtualbox/files/virtualbox-wrapper
index e389bd268520..7caf24f1cc40 100644
--- a/app-emulation/virtualbox/files/virtualbox-wrapper
+++ b/app-emulation/virtualbox/files/virtualbox-wrapper
@@ -1,16 +1,21 @@
#!/bin/sh
#
-# innotek VirtualBox
+# Sun xVM VirtualBox
+#
+# Copyright (C) 2006-2007 Sun Microsystems, Inc.
+#
+# This file is part of VirtualBox Open Source Edition (OSE), as
+# available from http://www.virtualbox.org. This file is free software;
+# you can redistribute it and/or modify it under the terms of the GNU
+# General Public License (GPL) as published by the Free Software
+# Foundation, in version 2 as it comes in the "COPYING" file of the
+# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
+# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
+#
+# Please contact Sun Microsystems, Inc., 4150 Network Circle, Santa
+# Clara, CA 95054 USA or visit http://www.sun.com if you need
+# additional information or have any questions.
#
-# Copyright (C) 2006-2007 innotek GmbH
-#
-# This file is part of VirtualBox Open Source Edition (OSE), as
-# available from http://www.virtualbox.org. This file is free software;
-# you can redistribute it and/or modify it under the terms of the GNU
-# General Public License as published by the Free Software Foundation,
-# in version 2 as it comes in the "COPYING" file of the VirtualBox OSE
-# distribution. VirtualBox OSE is distributed in the hope that it will
-# be useful, but WITHOUT ANY WARRANTY of any kind.
PATH="/usr/bin:/bin:/usr/sbin:/sbin"
CONFIG="/etc/vbox/vbox.cfg"
@@ -19,7 +24,7 @@ if [ ! -r "$CONFIG" ]; then
echo "Could not find VirtualBox installation. Please reinstall."
exit 1
fi
-
+
. "$CONFIG"
# Note: This script must not fail if the module was not successfully installed
@@ -89,6 +94,7 @@ EOF
fi
export LD_LIBRARY_PATH="$INSTALL_DIR${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}"
+export VBOX_LOG_DEST="nofile"
SERVER_PID=`ps -U \`whoami\` | grep VBoxSVC | awk '{ print $1 }'`
if [ -z "$SERVER_PID" ]; then
@@ -110,21 +116,25 @@ if [ "$SHUTDOWN" = "true" ]; then
fi
APP=`which $0`
+APP=`basename $APP`
APP=${APP##/*/}
case "$APP" in
VirtualBox)
exec "$INSTALL_DIR/VirtualBox" "$@"
- ;;
+ ;;
VBoxManage)
exec "$INSTALL_DIR/VBoxManage" "$@"
- ;;
+ ;;
VBoxSDL)
exec "$INSTALL_DIR/VBoxSDL" "$@"
- ;;
+ ;;
+ VBoxVRDP)
+ exec "$INSTALL_DIR/VBoxHeadless" "$@"
+ ;;
VBoxHeadless)
- exec "$INSTALL_DIR/VBoxHeadless" "$@"
- ;;
+ exec "$INSTALL_DIR/VBoxHeadless" "$@"
+ ;;
*)
echo "Unknown application - $APP"
- ;;
+ ;;
esac