summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-10-09 17:41:14 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-10-09 17:41:14 +0000
commit63191a99a76dcec81c47966b5954dd6fe0017424 (patch)
tree6d4fee00f2f8d9a019c0a8dd557f828077e43fbc /app-emulation/virtualbox-ose
parentamd64 stable wrt #287694 (diff)
downloadgentoo-2-63191a99a76dcec81c47966b5954dd6fe0017424.tar.gz
gentoo-2-63191a99a76dcec81c47966b5954dd6fe0017424.tar.bz2
gentoo-2-63191a99a76dcec81c47966b5954dd6fe0017424.zip
Fix for use=-hal. Thanks to upstream for the patch, fixes #288057
(Portage version: 2.2_rc44/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/virtualbox-ose')
-rw-r--r--app-emulation/virtualbox-ose/ChangeLog7
-rw-r--r--app-emulation/virtualbox-ose/files/virtualbox-ose-3.0.8-without-hal-fix.patch32
-rw-r--r--app-emulation/virtualbox-ose/virtualbox-ose-3.0.8.ebuild5
3 files changed, 42 insertions, 2 deletions
diff --git a/app-emulation/virtualbox-ose/ChangeLog b/app-emulation/virtualbox-ose/ChangeLog
index 01fa1b4f45f1..c16cee0aa115 100644
--- a/app-emulation/virtualbox-ose/ChangeLog
+++ b/app-emulation/virtualbox-ose/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/virtualbox-ose
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox-ose/ChangeLog,v 1.30 2009/10/06 19:54:00 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox-ose/ChangeLog,v 1.31 2009/10/09 17:41:14 patrick Exp $
+
+ 09 Oct 2009; Patrick Lauer <patrick@gentoo.org>
+ virtualbox-ose-3.0.8.ebuild,
+ +files/virtualbox-ose-3.0.8-without-hal-fix.patch:
+ Fix for use=-hal. Thanks to upstream for the patch, fixes #288057
*virtualbox-ose-3.0.8 (06 Oct 2009)
diff --git a/app-emulation/virtualbox-ose/files/virtualbox-ose-3.0.8-without-hal-fix.patch b/app-emulation/virtualbox-ose/files/virtualbox-ose-3.0.8-without-hal-fix.patch
new file mode 100644
index 000000000000..e2ac8c55173d
--- /dev/null
+++ b/app-emulation/virtualbox-ose/files/virtualbox-ose-3.0.8-without-hal-fix.patch
@@ -0,0 +1,32 @@
+--- VirtualBox-3.0.8_OSE/src/VBox/Main/linux/HostHardwareLinux.cpp
++++ VirtualBox-3.0.8_OSE/src/VBox/Main/linux/HostHardwareLinux.cpp
+@@ -212,10 +212,8 @@
+ && (!success || testing()))
+ rc = getDriveInfoFromHal(&mFloppyList, false /* isDVD */, &success);
+ #endif /* VBOX_WITH_DBUS defined */
+- if ( RT_SUCCESS(rc)
+- && RT_SUCCESS(VBoxLoadDBusLib())
+- && (!success || testing()))
+- rc = getDriveInfoFromHal(&mFloppyList, false /* isDVD */, &success);
++ if ( RT_SUCCESS(rc) && (!success || testing()))
++ rc = getDriveInfoFromSysfs(&mFloppyList, false /* isDVD */, &success);
+ /* As with the CDROMs, on Linux we have to take a multi-level approach
+ * involving parsing the mount tables. As this is not bulletproof, we
+ * give the user the chance to override the detection using an
+@@ -1086,6 +1084,7 @@
+ LogFlowFunc (("rc=%Rrc, halSuccess=%d\n", rc, halSuccess));
+ return rc;
+ }
++#endif /* RT_OS_LINUX && VBOX_WITH_DBUS */
+
+ /**
+ * Send an SCSI INQUIRY command to a device and return selected information.
+@@ -1422,6 +1421,8 @@
+ return rc;
+ }
+
++#if defined(RT_OS_LINUX) && defined(VBOX_WITH_DBUS)
++
+ /**
+ * Helper function to query the hal subsystem for information about drives
+ * attached to the system.
diff --git a/app-emulation/virtualbox-ose/virtualbox-ose-3.0.8.ebuild b/app-emulation/virtualbox-ose/virtualbox-ose-3.0.8.ebuild
index b6aeb22498fb..47a23c88878c 100644
--- a/app-emulation/virtualbox-ose/virtualbox-ose-3.0.8.ebuild
+++ b/app-emulation/virtualbox-ose/virtualbox-ose-3.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox-ose/virtualbox-ose-3.0.8.ebuild,v 1.1 2009/10/06 19:54:00 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox-ose/virtualbox-ose-3.0.8.ebuild,v 1.2 2009/10/09 17:41:14 patrick Exp $
EAPI=2
@@ -109,6 +109,9 @@ src_prepare() {
# unset useless/problematic mesa checks in configure
epatch "${FILESDIR}/${PN}-3.0.0-mesa-check.patch"
+
+ # stupid hal being stupid code
+ use hal || epatch "${FILESDIR}/${P}-without-hal-fix.patch"
}
src_configure() {